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This section describes the enhancements made to the version 6.18 of TopSolid'Wood. 

Improved user interface 

The TopSolid 2017 user interface has been completely redesigned to be more user-friendly and intuitive. 

A start page enables faster and easier access to recent documents. 

 

Right-clicking on a preview thumbnail allows the following actions: 

- Open the document 
- Remove the document from the list of recent documents 
- Open the file's Windows directory 
- Empty the whole list of recent documents 

 
 
 
 
 
 
 
For new documents, the different types available (design, drafting…) are 
shown on the left of the start page. 
The template documents are grouped in the lower section. Double-clicking 
on a document type or a template name creates a new document. 
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All open documents are now displayed in tabs. 

 

Right-clicking on a tab provides access to various functions: 

- Copy the file name 
- Copy full path 
- Open directory 
- Save 
- Save all 
- Close 
- New vertical tab group 
- Move to previous/next tab group 
- Back to one group 

 
Note: The Move to previous/next tab group and Back to one group functions are available only when there are at 
least two groups on the screen. Below is an example of a two-group display. 
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The Status bar configuration dialog box includes all the settings that were previously available in the lower section 
of the graphics area (Current material, Transparency, Current coordinate system…). 

 

The alpha bar is now divided into three tabs to make it easier to find the information you need. The Messages tab 
includes all the messages displayed (as was the case with the alpha bar previously). The Named parameters tab 
displays the name and value of the parameters created or changed by the user. The Measures tab contains the 
values of the measurements carried out from the Analysis menu. 

 

You can change the position and size of the alpha bar and the status bar configuration by clicking and dragging the 
dialog box's title bar (like a Windows dialog box). 

TopSolid provides a measurement tool based on the scale. To use it, you have to click and drag the sphere from the 
scale at bottom right to a flat face. This measures the distance to the opposite plane. 
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Once the measure is displayed, you can right-click on the symbol to bring up a contextual menu that lets you create 
the dimension displayed, create a distance parameter that can be reused later, or create a coordinate system on 
the selected face. The Unhook option closes the measurement tool. 
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Design 

New sketch constraints 

Two new fixity and rigidity constraints have been added to the sketch. 

Fixity constraint 

The fixity constraint lets you fix sketch elements at their position without having to create dimensions. 

 In a sketch, select Constraint > Fixity. 

In the sketch below, the drawn contour is not constrained. 

 

 Select the elements you want to fix. 

 Once selected, the fixed elements turn gray and they cannot be moved anymore. 

 

 To remove a fixity, launch Constraint > Fixity and pick the elements you want to unfix. You can also remove it by 
editing the sketch from the tree, and then right-clicking and selecting Remove fixity on the constraint to be 
deleted. 
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Rigidity constraint 

The Rigidity constraint is used to group sketch elements so that they can be moved together for example. 

 In a sketch, start Constraint > Rigidity. 

 Select the components you want to group. 

 When you're finished, click STOP. 

The rigidity constraint is shown by the symbol . 

 

 To remove rigidity, use Delete element and click the constraint symbol. You can also remove it by editing the 
sketch from the tree, and then right-clicking and selecting Delete on the rigidity constraint. 
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Rough nesting 

You can nest the rough of parts during nesting. 

 In a document, select Wood > Define part. 

 Click the part with the rough to be nested. 

In the following example, the rough of the two shelves will be nested. 

 

 In the Nesting tab, select the Nest rough box. 

 

Note: If you want this option selected by default, select Tools > Options > TopSolid'Wood configuration > Define 
parts and open the Nesting tab where you can specify the default setting of the parts and the panel support. 

 Select Wood > Automatic nesting. 

 Pick the parts to be nested. 

 Configure the nesting settings. 

After the nesting is generated, the parts with nested rough appear transparent. 
  



TopSolid 2017  What's New in TopSolid'Wood v6.18 

Missler Software  9 

In the example below, the counter's parts have been nested and the Shelf 1 and Shelf 2 parts are transparent. 

 

Note: When the rough of a part is positioned, only the operations performed on the top face are retrieved during 
nesting (one groove and drillings in the example). 
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Wood machining 

Biesse CIX interface 

A new machining interface includes the ability to export parts designed in TopSolid'Wood to CIX format. The 
resulting file contains all the part's machining information (toolpath, position, tools…) and can be opened with 
BiesseWorks (version 3.4.14 or later) and BSolid. 

 
 

BiesseWorks 
 

BSolid 
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Bill of material 

Generic codification of edges and laminates 

You can define a generic codification for edges and laminates. These codification rules predefined upon 
configuration are then applied to edges and laminates. 
This lets you quickly create codifications without the need to assign a codification to each edge type. 

Creating a generic codification 

 To create an edge generic codification, select Tools > Options > TopSolid'Wood configuration > Edge/Laminate. 

 In the Generic codifications section of the Edge configuration tab, double-click in the Rule column to create a 
new codification rule. 

 Enter the generic codification. 

Note: Some of the edge or laminate parameters can be retrieved in the codification: 

- Edge or laminate matter: [matter] 
- Edge or laminate coating: [coating] 
- Edge catalog code: [code] 
- Edge or laminate thickness: [t] 
- Edge length: [l] 
- Edge height: [h] 
- Laminate width: [w] 

In the example below, the CP-[matter]-EP [t|00mm] codification is created. The codification will display the matter 
and thickness of the edge in millimeters and rounded to the nearest whole number. 

 

 Next select the edges where you want to apply the codification by double-clicking in the Standard column. 

In the following example, the codification will be applied to all flat edges of the TopSolid'Wood library. 
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Note: If no selection is made in one of the drop-down lists (Type, Variant, Version…), the codification will be applied 
to all edges of these categories. 

 Specify the over dimension length and the calibration overvaluation. 

In this example, no over dimension length is specified. For the calibration overvaluation, the [cat:ep] syntax 
retrieves the ep parameter value from the edge catalog. This ensures that the calibration overvaluation always 
matches the thickness of the edge used. 

 

 To create a generic codification for laminates, repeat the steps in the Laminate configuration tab. 

In the example below, the ST-[matter] codification will be applied to all laminates using a matter from the 
TopSolid'Wood library's Hardwoods category, regardless of the coating or thickness. 

  

Using generic codifications 

 Start Wood > Panel and click a face of an existing part to create a new Panel entity. 

 Select the edge type you want to apply by double-clicking in the Edge type - code column. 

 

Note: In order for the generic codification to be applied, you need to select the edge to be applied directly. The 
codification is then automatically generated based on the parameters defined when creating the generic 
codification.  
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In the following example, a PVC flat edge from the TopSolid'Wood library is applied. 

 

A 1mm thick oak laminate is also applied. 

 

Using the generic codifications that were defined previously, here is the codification of the edges and the laminate 
displayed in a bill of material: 
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Special situations 

 When there are codifications other than generic codifications, the codification assigned to the edge has priority 
over the generic codification. 

In the example below, the 2mm thick PVC flat edge with pine coating uses the PVC-PINE-EP 2 codification. The 
generic codification points to the flat edges too. 

 

The flat edge with the PVC-PINE-EP 2 codification is applied to a panel. 

 

In the bill of material, you'll notice that the codification assigned to the edge is used, not the generic codification. 

 

Note: To use only generic codifications, you need to delete the codifications assigned to the relevant edges. 
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 When two generic codifications point to the same library, the list of generic codifications is read from top to 
bottom and TopSolid will use the first true codification. 

In the following example, the two generic codifications point to the same TopSolid'Wood library. The first one is 
applied to edges from the Thin edge/Flat edge category, and the second one is applied to all edges from the Thin 
edge category. 

 

A flat edge from the Thin edge category is applied to a panel. In this case, the two generic codifications can work as 
they both point to the Thin edge category. 

 

In the bill of material, you'll notice that the first codification of the list has been used. 

 

If the order of generic codifications was reversed, the second codification would be used. Below is the BOM result 
after reversing the generic codifications in the list. 

  

Note: To change the order of generic codifications, open the Edge-Laminate.cfg file from the Group/V6X folder. 
Next, change the order of lines beginning with ZWOO_EDGE_GENERIC_CODIFICATION. 
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BOM export to xlsm file 

You can export a bill of material to an Excel file that contains macros. 

 Start Wood > Export bill of material. 

 Select the BOM template you want to use. 

 Specify the BOM depth and select the document containing the set to export. 

 

 Select a filter by criteria if necessary. 

 Adjust the Use an Excel template = NO option to YES. 

 Select the xlsm file that will be used as a template. 

 

 Click NAVIGATOR to specify the name of the file and where to save it. 

 From the Files of type drop-down list, select the Excel format (*.xlsx; *.xlsm; *.xls). 

 

 Name the file and click OK to confirm. 

 Select the parts to be exported and click OK to confirm. 

The file is then generated in xlsm format. 

Numbering by type of part 

When you number a bill of material in Use element type mode, you are now able to number parts without type. In 
previous releases, you had to launch the Numbering function twice to achieve this. 

 In Tools > Options > Predefined index, define BOM indexes for each part type. 

In the example below, the NEST- prefix is assigned to the Nesting part type. 
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 In a Design document, right-click on the main assembly line and select Display bill of material. 

 

 Select a BOM template and click OK to confirm. 

 Once you can see the bill of material, right-click on the main assembly line and select Number automatically. 

 

 Choose Use element type as the numbering mode and set the Number parts without type option to YES. 

 When you're finished completing the settings, click OK to confirm. 

All the BOM's parts are numbered and the Nesting parts have a number starting with NEST-. 
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Configuration 

Script documents 

Configuration improvements include the ability to automate repetitive tasks using Script documents. This makes it 
possible to execute and string together various actions automatically. 

Creating a script 

 To create a new Script document, launch Wood > Script. 

The Script documents dialog box opens. 

 Choose whether the script must be created in the local configuration or the group configuration. 

 Click New. 

 

Note: The Script documents have the .topscript extension and are saved in the Config/Template/Scripts or 
Group/Template/Scripts folder. 

 Select the unit to be used in the Script document and give the script a name. 

 

 Add the tasks to be executed by the script. You can use the following features: 

- BOM numbering 
- Cut export 
- BOM export 
- Multi-drafting 
- Machining export 
- Multi-machining 

Note: Each task is shown by a node containing all the necessary settings for each function. These nodes are linked 
with each other and will be executed in order from top to bottom. 

For example, here is the procedure on how to create a script in order to do numbering, multi-drafting, and then a 
WoodWop export. 

 In a new Script document, start Wizard > Numbering. 

 The node is attached to the cursor. Click the blank page to position the node. 

 The Node to connect option lets you choose the node after which the task being created will be executed. As 
there is yet no node, click Start node.  
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Result: 

 

 To configure the numbering, select Modify element and click the created node. 
 Specify the numbering parameters. 
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 Click OK to confirm. 

 Start Wizard > Multi-draft. 
 Place the node on the document and click the Bill of material numbering node to produce multiple drawings 

after numbering. 

 

 Use Modify element on the created node in order to configure the multi-drawings. 

 Specify the BOM depth for the part selection. 

 Select the elements to export. 

You can export parts from any set of the document (alternative set or in-place subset) by entering the name of the 
set to be used in the Set to export field. You can also filter the bill of material and the part selection using multi 
criteria filters. If no filter is used, all parts contained in the set will be exported. 

Note: These settings are available in the nodes of every function that requires part selection (machining export, 
sawing-up export, etc.). 

 Configure the multi-drawing parameters. 

Note: When all the drawings are placed on the same document, you need to define the multi drawing file name. 
This file will be saved in the same location as the document from which the script has been run. However, you can 
add subfolders using the syntax ./folder name/draft name before the file name. 
If a file is generated for each drawing, you need to specify a generation directory. The file names will be given by the 
WOO_DFT_FILE_NAME used in the BOM file specified in TopSolid'Wood configuration > Files > Parts selection 
sorting > Multi-draft. 
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In this example, the multi-draft is configured to export all parts except the Hardware ones. All drawings will be 
placed in the same Drawings file that will be saved in a Drafting subfolder created in the same location as the 
document from which the script will be run. 

 

 Click OK to confirm the settings. 

 To add the WoodWop export, select Wizard > Machining export > WoodWop. 

 Place the node in the document. 

 Click the Multi-drawings node to perform the export after multi-drafting. 

 Configure the WoodWop export. 

 As with multi-drafting, you can filter the bill of material and the part selection. 

The settings available in Machining parameters are those available during a WoodWop export performed from the 
Wood > Machining export > WoodWop function. 

In this example, all parts except the Hardware ones contained in the main set will be exported. The other settings 
keep their default values. 

 

Note: For machining exports, the generated files are automatically saved to the location defined in Tools > 
Options > TopSolid'Wood configuration > Machining > WoodWop, Maestro, etc. The file names will be formatted 
by the WOO_CAM_FILE_NAME used in the BOM file specified in TopSolid'Wood configuration > Files > Parts 
selection sorting > WoodWop export.  
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Once you have added and configured the WoodWop export, the following script document is created: 

 

 Save the file. 

Using the script 

 To use a script, open a Design document of the project. 

 To launch the script, right-click on the script to be executed and select Run the script. 
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In the example, the previously created script is executed on the following document. 

 

 During the script execution, messages are displayed in the alpha bar which let you know whether the script has 
started, which node is being executed and when it is finished. 

After launching the script in the example document, here are the messages displayed in the alpha bar for each step 
of the script: 

Beginning of the script. 

 

Bill of material numbering. 

 

Multi-drafting and the file containing all the drawings is saved. 

 

WoodWop export and number of generated files. 

 

End of the script. 
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In the example document, you'll notice that the parts have been numbered and displayed as a bill of material in the 
tree. 

 

The WoodWop files have been generated to your specified location. 
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Similarly for the file generated by the multi-drafting. 

 

Modifying a script 

 To modify an existing script, select Wood > Script. 
 From the list of scripts, right-click and select Open the document. 

 

 Use Modify element or Delete element and click the node to change the settings or delete the node. 
In the following example, the node which appeared in second place has been removed. In order for the Script 
document to work, you need to connect the two remaining nodes. 
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 To connect two nodes, select Modify element. 
 Click the lower part of the node that'll need to be above the connected node. 

 

 Click the node to connect. 

 

This also has to be done when a new node must be inserted between two existing nodes. 
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Parameter edit dialog box 

When you edit a parameter, a dialog box appears with which you can, for example, modify dimensions more 
intuitively. 

 Edit a parameter. 

The dialog box for editing parameters opens. 

 

 You can then modify the parameter in one of the following ways: 

- By typing the desired value into the appropriate box directly. 
- By entering a modification step and clicking the arrows to vary the step value. 

 

- By sliding the cursor along the bar to quickly vary the values. 

 

Note: Select Tools > Options > Other to display or hide this dialog box and change its opacity. 
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Drafting 

Drilling table and index table in multi-drawings 

You can include a drilling table and/or an index table in the multi-drawing template. These tables are then 
automatically completed based on the projected element. 

 Create a new Drafting document and open an existing multi-drawing template. 

 Select Wood > Multi-draft and choose Create template. 

Two new functions are available: Create table of indices and Create table of drills. 

- Create table of indices: 

 Select the index table template. 

 Position the table by clicking two points in the drawing. 

Note: If the drawings are placed in the same document during multi-drafting, the index table will be local to each 
drawing and will display the indices of the projected element. 

 

- Create table of drills: 

 Choose the drilling table template. 

 Select the reference view on which the drilling indices will be placed. 

 Select the origin point or coordinate system for the drilling's coordinates. Choose Use reference view origin to 
define the coordinate origin as the 2D view coordinate system. Set Show xy coordinates origin to Yes to view 
the origin coordinate system. 

 

 The Allow inverted drill = Yes/No option lets you display/hide the drillings on the opposite face to the projected 
face in the view. Define the origin face to calculate the drilling depth by setting Origin for z coordinates = Top 
face/Bottom face. 

 Click OK to confirm these two options. 
  



TopSolid 2017  What's New in TopSolid'Wood v6.18 

Missler Software  29 

 Specify how the table has to be sorted: 

- By type of element: Groups the drillings by type. For example, the table will display the drilled holes, then 
the tapped holes, then the countersunk holes, etc. 

- By operation: Sorts the drillings by operation. For example, if there are tapped holes and countersunk holes, 
the table will display the drilling and its tapping, then the drilling and its countersinking, etc. 

 Next select the types of drillings to be displayed in the table: All drills, Not through drills only or Through drills 
only. 

 In the advanced options >>, you can choose to display the diameter or the radius of the drilling and use a 
diameter/radius constraint to see only the drillings with a diameter greater or less than 10mm. 

 Click two points to position the drilling table and finish creating it. 

Result of multi-drawings using a template containing a drilling table and an index table: 
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View style 

The ability has now been added to define view styles in order to quickly adjust all the projection parameters. A view 
style is a drafting document containing a view in which various projection parameters are set. This style is then 
applied to a drafting document or to existing views. 

Creating the view style 

 To create a new view style, select File > New > Draft document. 

 Select Without template. 

 Create a blank view. Select View > Main view. 

 Click No element. 

 The View creation window opens. Specify the different projection parameters that you want to apply to the 
view style. The view style can use the parameters from the following sections: 

- Edges/Rendering 
- Colors 
- Title 
- Representation/Schematic 
- Exceptions  

In the example below, the view style will apply to the following parameters: 

- Edges/Rendering: The smooth edges will be displayed in half-intensity and the view will be shaded. 
- Colors: The visible lines will be projected in black. 
- Title: No title will be displayed on the view. 
- Representation/Schematic: The shapes will be projected in detailed representation. 
- Exceptions: A multi-criteria filter will be used to prevent the Hardware parts from being projected. 

 

  

 Place the view in the document. 

Note: A View style document can contain only one view and must not reference other documents. 
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 Select View > Define style. 

 Choose whether the view style will be saved in local or group configuration. 

 Give the style a name. 

Note: The view style documents have the same extension as the drafting files (.dft) and are saved in 
Config/Template/ViewStyle or Group/Template/ViewStyle. 

 For each parameter, specify whether you want to forbid any modification. 

In the following example, changing the title and the representation is not permitted. Once the style view is applied, 
the Representation/Schematic and Title settings will be disabled when modifying a view. 

 

Note: This ensures that all drawings produced using this view style will have the same projection parameters. 

Using the view style 

The view styles can be used either through drafting templates, or directly in an existing drawing. 

Creating a drafting template using a view style 

When a view style must be used each time a drafting template is used, you need to define the default style in the 
drafting template document. 

 Select Config/Template or Group/Template and open the drafting template to be modified. 

 Open File > Properties > Drafting view > View style. 

 Click Apply view style on all new created views. 

 Select the default view style to be used with the drafting template. 

 

 Choose the settings of the view style to be applied by selecting/deselecting the corresponding boxes. 

In the example, all settings are selected except the title. The views that will be created will not retrieve the settings 
defined in the Title section of the view style. All other settings will be applied. 

 
 Click OK to confirm the settings. 
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Using a drafting template with a view style 

 Create a new drafting document and create a view. 

In the following example, the parameters are those set in the Style1 – Without hardware view style that you 
created previously. The view is shaded, the hidden lines are hidden, the visible lines are black, no title is specified, 
the projected shapes are displayed in detailed representation and an exception excludes the Hardware parts. 

  

Note: The Representation/Schematic parameters are disabled since it has been specified in the style definition that 
no changes to these parameters are permitted. Changing the title is also forbidden, but no title must appear on the 
view as defined in the view style. 
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Using a view style in an existing drawing 

A view style can also be applied to existing views. 

 In a drafting document containing one or more views, select View > Apply style. 

 From the drop-down list, select the view style you want to apply. 

For example, you can use the previously created view style. 

 

 Specify the settings to be applied. 

In the example, only the selected Edges/Rendering and Colors settings of the view style will be applied. The view 
will be shaded, the hidden edges will be invisible and the visible lines will be displayed in black. 

 

 Select the views on which to apply the style. 
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In the example below, all the document's views have been selected. 

 

You can also copy the projection settings of an existing view to apply them to other views of the drawing or 
another drafting document. 

 In a drafting document containing one or more views, select View > Apply style. 

 Select the reference view containing the settings to be copied. 

Note: To click a view of another drafting document, click the corresponding tab and select the view you want to use. 

In the following example, the shaded view is selected to apply its projection settings to the other two wireframe 
views. 
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 Once you have selected the view, define the settings to apply. 

 

 Finally, click the views to be modified. 

Result:  

 

Modifying the view style 

 Go to Config/Template/ViewStyle or Group/Template/ViewStyle. 

 Open the document containing the view style to be modified. 

 Use Modify on the view to edit the projection settings. 

 To change the forbidden settings, select Main view > Define style. 

 When you're finished making changes, click OK to confirm and save the document. 

Note: A view style is not associative, which means that if the view style you have modified was already used, the 
views on which the style was applied will not change. 

View alignment 

Views can be aligned quickly using Adjust alignment. 

For example, let's use the following drawing: 
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 Select View > Adjust alignment. 

Gray arrows show the existing alignments such as the alignment between a reference view and its auxiliary views. 

 

Note: The alignments indicated by gray arrows cannot be changed. However, the views can be moved along the axis 
of this alignment. 

 Click an edge of the view to be aligned. 

In the example, the cross section on the bottom left of the drawing will be aligned with the drawing's reference 
view. An edge of the cross section is selected. 

 

 Next click an edge of the reference view for alignment. 
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The corresponding edge is selected in the reference view. 

 

 Once the views are aligned, a green arrow appears. 

 

Note: The green arrows represent the alignments that you can change. 

 To edit an existing alignment, start View > Adjust alignment. 

 Click the arrow of the alignment to be modified, on the side of the edge to be replaced. 

In the example, the created alignment will be changed to align the cross section with the top view of the item, so 
you need to click on the right portion of the arrow. 
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 Select Reconnect. 

 Click the reference edge for alignment. 

 

Result: 

 

Note: Arrows may appear in red, which means that one of the two geometries used for alignment no longer exists. 
You need to select View > Adjust alignment, click the red arrow, and reconnect it to an existing geometry. 

White background 

The drawing's backgrounds contained in a drafting document are now white. 

 To change a drawing's background to white, select Modify element. 

 Click a drawing's border. 

 Select White background. 
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The modified drawing is on a white background. 

 

Note: All TopSolid templates are now using a white background. If you want the existing user templates to have this 
white background too, you need to open each template document and make the change. 

Margins in multi-drawings 

You can use the margins defined in the paper format for multi-drafting. 

 From a Drafting document, select Tools > Options > Drawing. 

 Specify the dimensions, the margins and the name of the paper format. 

 

 To be able to use these margins, check Use drawing's margins in multi-draft in Tools > Options > 
TopSolid'Wood configuration > Draft. 

 Create multi-drawings and set Put together all drafts in one document to YES. 
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Result: In the resulting drawings, the projection is based on the defined margins. 

 

Offset between dimensions 

The offset between dimensions defined in the multi-drawing template or in Tools > Options is no longer based on 
the drawing scale factor, providing improved readability of dimensions. 

 Open a multi-drawing template. 

 Specify the dimension offset in File > Document properties > TopSolid'Wood properties > Draft. 

 

 Create multi-drawings from a project. 
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Below is a comparison between multi-drawings produced in the 2016 release and multi-drawings produced in the 
2017 release. 

Version 2016 

The offset between dimensions is based on the drawing 
scale factor. The offset may change from one drawing 
to another. 

Version 2017 

The offset between dimensions is no longer based on the 
drawing scale factor. The offset is the same for all 
drawings. 
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Interfaces 

BIM IFC import/export 

Import 

Enhancements include the ability to import IFC files into TopSolid. The shapes and properties contained in these IFC 
files are retrieved in a .top file tree. 

 To import an IFC file, select File > Open. 

 Select the file and click OK to confirm. 

 Choose the directory where you want to save the .top files resulting from the import. 

A window providing a document overview appears. The check boxes let you choose whether you want to import the 
selected shapes, by building, by floor, etc. 

 

Note: The retrieved shapes are polyhedral shapes. The imported properties are copied into the set of associative 
IFC properties. 

 

Export 

You can export the shapes and the IFC properties to IFC format. To do this, select File > Save as and choose the IFC 
format (*.ifc). 
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Miscellaneous 

 The Part category property can be used in the part selection dialog boxes. 
 

 You can import the windows of a Sky light with a component. To achieve this, you need to include the Sky light 
in the component's main set, with the windows. The windows will be added to those of the assembly's Sky light. 

 

 When using a workspace, you can define context sets to group elements to be used as contexts in multiple 
workspaces. These sets make the workspaces much easier to draft, as well final assembly. 
 

 Using Shape > Other shapes > From bitmap, you can create a surface from an image inserted in TopSolid. 
 

 When you create a sawing operation, a groove operation or a user machining, you can select several guide 
curves. 
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What's New in TopSolid'SheetMetal v6.18 
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This section describes the enhancements made to the version 6.18 of TopSolid'Punch and TopSolid'Cut. 

TopSolid'Punch and TopSolid'Cut 

Importing a family of V7 unfoldings 

A new menu function lets you automatically create all the PART documents for the various variants defined in a V7 
family document. 

Creating a family of parts in TopSolid 7 

 Example of a sheet metal part created from a sketch on which parameters have been defined. 

  

 Consider the following family document linked to the sheet metal part in which catalog codes and parameters 
values have been defined. 

 

 Unfold the part. 

 Check the document into the vault.  
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Importing the unfolding and preparing the part's machinings 

 In TopSolid'SheetMetal, create a part document based on the unfolding using Import single part. 

 

 Place the machinings and save the document. 

Creating the family's part documents while retaining the machinings updated 

 From the current document, select Import v7 family. 

 

 The system will ask you whether you want to complete the existing machinings with automatic allocation and 
whether the family's parts must be included in the Task manager. 

 

 Choose the directory where you want to save the unfoldings derived from variants. 
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 The PCH documents are generated and named by concatenating the catalog code and the document's original 
name. 

 Each PCH document is automatically linked to the unfolding created in TopSolid 7. 

 

Creating a part family without original document 

 When you call up the Import v7 family function from an empty PCH document, you are asked to choose an 
unfolding whose 3D part has at least one family. In this case, all the project's unfoldings are not available in the 
Project Explorer. 

 

 Select the unfolding and the destination directory. 
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 Specify the machine and the other general parameters. 

 

 Choose the directory where you want to save the unfoldings. 

 

 All PCH documents have been created and named by concatenating the catalog code and the unfolding name. 
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Task Manager 

Comment column 

A new Comment column has been added to the Task Manager's Parts and Matters tabs. 

 

 

The comment information is retrieved from the PCH document when the part is inserted into the Task Manager, and 
it can be edited by double-clicking in the Comment column of the desired line. 

 

The part comments are already displayed in the standard operator card. 

If the Task Manager's comment column is empty, the comment of the PCH document is displayed instead. 

The matter comment can be displayed in both the simple order operator card and the complete order operator card 
(orderopcardcompl.full). 
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Each part's comment is also available in the complete order operator card, in the table of parts for each nesting. 

 

New columns in the archive file 

New columns have been added to the Task Manager's archive file: 

- In the Nestings tab: 
 

o Column O: From a waste 
 If the nesting has been performed from a waste, the value Yes will appear in this column. 

o Column T: Extracted waste 
 If a waste has been created from this sheet, the value Yes will appear in this column. 

o Column U: Comment 
 Nesting comment. 

- In the Parts tab: 
 

o Column U : Average time per part 
Warning: It is only available for orders created from the 6.18 release. 

o Column V : Weight 
 Weight of the single part. 

o Column W : Comment 
 Part comment. 

Nesting in holes 

In both Insert parts and Move parts manual nesting functions, an option that lets you nest in part's holes has been 
added at the first level. 

 

In the previous release, this option was available in the Parameters dialog box. 
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Displaying sheets with dotted extracted wastes 

When a waste has been created and the sheet has been resized, the wastes are now displayed with dotted lines. 
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Waste surface displayed in order operator card 

In the complete order operator card, a new word allows you to display the surfaces of wastes extracted from the 
sheet. 

#waste_surf_matter# 

 

The reference template operator card can be found in \Missler\V618\Local\EnglishUS\OrderOpcardCompl_full.dft. 

Below is an example of result for a sheet with an extracted L-shaped waste: 
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Multi-order operator card 

You can create a common operator card for several orders. 
A template can be found in \Missler\V618\Local\EnglishUS\MultiOrdersOpcard.dft. 

 

This template lists the matter data, the nesting documents, and the details of each command for each order in 
summary tables. 
To enable this feature, you need to copy the operator card template into the $PUNCHDATA folder. 

In the Task Manager's Orders tab, if you select several orders and you enable the  function to create the multi-
order operator card, a new dialog box lets you choose whether you want to create an operator card per order, or an 
operator card common to all the selected orders. 

 

After this, you have to specify a name for the resulting operator card as well as the folder where it should be saved.  
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Example: 
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What's New in TopSolid'WoodCam v6.18 
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This section describes the new features in the version 6.18 of TopSolid'WoodCam. 

Template machine 

Post-processor's default values in the machine template creation 

In the Misc. machine definition window, the option to display the post-processor's dialog box is selected by default. 
In the case of a mixed machine pool including a number of post-processors, this feature prevents you from selecting 
a post-processor which is incompatible with the machine template. 

 

Warning message if link movements and machine template are not linked 

If user link movements have been assigned to a unit of the machine and this macro can no longer be found by 
TopSolid - for example because the directory has been changed or the file has been renamed or deleted - an error 
message appears in the alpha bar. 

 

Saw machining on the bottom face 

Some small-footprint machines make it possible to machine above and below the part. This strategy requires you to 
choose the blade unit to be used, since the frame of the saw machining is the same for an operation performed 
above and an operation performed below. 

The blade unit is selected according to the priorities of operations. If an operation is defined on the main 
positioning, the main unit will be used. 
Alternatively, if the operation is defined on the secondary positioning, the secondary unit will be used.  
The selection is done in Misc > Machine > Tool units. 
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To enable the operations under the part, you need to check Select valid operations under the part in Misc > 
Machine > Misc modifications. 

 

Configuring the bottom face's origin 

The Origins  function lets you choose how to position the origin on the bottom face. 
As with other faces, you need to select the face to be modified (Bottom) and choose the position of the origin on 
the face (Bottom left, Bottom right…). The positions on the bottom face are described as if the part had rotated 
180° around X. The new images show you where the origin is located on the 3D part. 

  

When positioning the part, if the Misc > Machine > Misc modifications > Options > Create frame under the part (if 
kinematics allow it) option is selected, a frame is created on the part's bottom face. 

Frames projected on the stock or finish 

A new option available in Misc > Machine > Misc modifications allows you to offset the frame's origins to the 
nearest face of the stock or the finished part's bounding box. This option ensures the compatibility of 
TopSolid'WoodCam with BiesseWorks and Maestro systems which do not tolerate the tilted planes with an origin 
outside the part. 
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Group work 

Group processes 

Processes can now be used in a group configuration. 
The list of available processes is divided into three categories: 
 

- *** STANDARD PROCESSES ***: These processes are provided by Missler Software. 
 

- *** USER PROCESSES ***: These processes are created by the user locally and are stored in $TOPCONFIG. 
 

- *** GROUP PROCESSES ***: These processes are created and shared by a user in group configuration. They are 
stored in $TOPGROUP. 

Group link movements 

The principle of user or group processes has been extended to link movements. You can share link movements from 
TopSolid without moving folders from $TOPCONFIG to $TOPGROUP. 

- *** STANDARD APPROACHES *** / *** STANDARD RETRACTS ***: These link movements are provided by Missler 
Software. 
 

- *** USER APPROACHES *** / *** USER RETRACTS ***: These link movements are created by the user locally and are 
stored in $TOPCONFIG. 

 

- *** GROUP APPROACHES *** / *** GROUP RETRACTS ***: These link movements are created and shared by a user in 
group configuration. They are stored in $TOPGROUP. 

 

Script 

Multi-machining node 

The Script function lets you configure and execute one or more multi-machinings. You need 
to create a new script or edit an existing script, and then click the Multi-machinings icon to 
create a Multi-machinings node. 
 

 
 
Once the node has been included in the script, you only 
have to configure the BOM, filter and machining 
parameters. 

You can string together several Multi-machinings nodes 
using different filters, different bills of materials, different 
machines, etc. 
 
 
 
 
 
 
 

 

  



TopSolid 2017  What's New in TopSolid'WoodCam v6.18 

Missler Software  61 

Link movements 

Calling up link movements 

You can call up retract movements by right-clicking on an operation. 
The F4 or Shift+F4 shortcuts still work. 

 

Comments in approach and retract macros 

You can save a comment related to a link movement. 

 

When this link movement is assigned to a tool unit, the comment appears when you click the Information icon. 

 

The comment is displayed at the end of the ASCII file in the following form. 
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Aggregates 

Managed multi-spindle drilling aggregates 

To machine holes aligned with a multi-drilling aggregate when the number of holes is not a multiple of the number 
of tools available on the aggregate, you need to move the aggregate backwards to X times the distance per instance. 
For the following 5-spindle aggregate, which only has 4 mounted tools and must machine 10 holes, the aggregate 
will move down 3 times. 

 Step 1: 4 holes are drilled, 6 holes left to be done. 

 Step 2: 4 holes are drilled again, 2 holes left to be done. 

 Step 3: The driven tool (1) moves down into the hole 7 of the propagation and the tools 3 and 4 of the ramp drill 
the holes 9 and 10 of the propagation. 

 

This method is also available for the fixed ramps of the machine. To enable it, select Document properties > Routing 
configuration > Holes and check Shift last hole in the Aligned holes field. 

 

  



TopSolid 2017  What's New in TopSolid'WoodCam v6.18 

Missler Software  63 

Tool management 

New images for tool units 

New images have been added to simplify the use of the tool magazine and help differentiate the various machining 
units in the magazine. They are different depending on the unit type. 

Below are a few examples: 

 

Routing units 3X/5X 

 

Vertical drilling units X/Y 

 

Horizontal drilling units X+/X- 

 

Horizontal drilling units Y+/Y- 

 

Blade units 

 

Indexable units 

 

Aggregate 

New images for tools 

New images have been added to make it easier to create tools, allowing you to view the different parameters of a 
tool. 
Each parameter listed on the left of the window appears on the tool diagram on the right. 
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Tool magazine displayed as a table 

The tool magazine is now displayed as a table to improve readability and allow you to change the size and position 
of columns, or sort the tools according to various criteria. 
In the example below, the tools are sorted by diameter in descending order. 

 

Modifying tool primitives 

The tool primitives called up by TopSolid'WoodCam have been renamed in the reduced database, which allows 
them to be isolated from the mechanical reduced database. 
All primitives used by TopSolid'WoodCam are prefixed with TSWC_XXXXXXX. 
A fixed parameter has been added for the shank length, which prevents the profiles from intersecting when the tool 
length is equal to the tool cutting length. 

Saving the PP word for the tool 

The PP word assigned to a tool in the current tool magazine is taken into account when saving tool magazines. 
It is recovered when a magazine is reloaded by the user. 

Recalculating the conical tool's dimensions 

For conical tools such as chamfer mills, reverse chamfer mills, conical countersinks etc., the diameter and angle 
parameters are recalculated in relation to each other. This calculation is primarily based on the angle. 
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Contouring cycles 

New starting element category 

A new Starting element category including all the parameters related to the starting element of a contouring has 
been added. 

 

Selecting the starting element for contouring 

The new Choice of contouring's starting element parameter helps select the starting element: 

- If this parameter is 1, TopSolid picks the largest linear element or the largest circular element if no segment is 
available. 

- If this parameter is 0, TopSolid behaves as in previous releases. 

Minimum length of longest element to choose for start 

This parameter lets you specify a minimum length to choose the starting element. For example, you can remove 
from the list of starting elements the elements with a length less than twice the tool diameter. If a linear element 
has a length less than 2*Tool.diam and a circular element has a length greater than 2*Tool.diam, TopSolid will 
choose the circular element. 

 

Analysis 

Searching for a tool in millimeters in an inch database 

For an operation, you can search for a tool by its diameter in the database with a tolerance. As a result, the tool 
entered in millimeters will be found in an inch database even if the diameter is not strictly the same. 

 

Scoring 

Saw machining with scoring 

A new pre-scoring depth parameter is available for all saw machinings: sawing, grooving and rabbeting. 

This parameter can be configured at several levels: 

- in the default values 
- in the processes of the groove, rabbet and sawing operations 
- in the manual sawing operation's dialog box 

To avoid scoring, you just need to set the parameter value to 0. 

Note: This pre-scoring parameter is processed directly by the post-processor, which means that the post-processor 
needs to be updated to use this parameter and the scoring pass is not simulated in TopSolid'WoodCam. 

 
  



What's New in TopSolid'WoodCam v6.18  TopSolid 2017 

66  Missler Software 

Nesting machining 

Sawing operations 

The 2017 release includes the ability to perform saw machinings, such 
as groove or rabbet operations, in nesting. 

To achieve this, you need to select the Slot and fold with saw box. 
Accordingly, the frames of the groove and rabbet operations will be 
created on the nesting. 

This option is also available for a nesting multi-machining. 
 
 
 
 
 
 
 

 

Multi-machining 

Displaying the length/width ratio 

Information on the part's length/width ratio can be displayed in the list of parts to be machined. 

 

You can configure this ratio in Tools > Options > Routing configuration > Multi-machining. 
This information can be displayed according to whether the ratio is < ; > ; < or = ; > or = to a user value. 

 

Displaying the ratio makes it easy for you to identify the parts whose positioning is to be modified by right-clicking 
and selecting Positioning. 

Default options for nesting multi-machining 

The Positioning and machining window's default options are those defined in the properties of the selected 
template. 

General machining journal 

The machining journal now displays the list of: 

- inactive machinings 
- unupdated machinings 
- machinings with no path  
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Nesting machining journal 

The nesting multi-machining journal now displays the list of unexecuted operations. 

Filters in part selection (6.17) 

Selection by filter has been added during the version 6.17, allowing you to filter the parts to be displayed in multi-
machining. 

Additional operations for nesting multi-machining (6.17) 

New choices have been added to the nesting multi-machining: Slope faces user machinings/Continuous 5 axis user 
machinings. 

 

User machining 

Managed calibration/milling operation type 

The operation type for multi-machining is taken into account by TopSolid'WoodCam. If a part contains a user 
machining like a calibration operation, the TopSolid'WoodCam calibration operation does not appear in the analysis 
and will not be created at the execution stage. 

 

Ergonomics 

New CAD interface supported in CAM 

The tile mode is now managed by window groups. To return to a behavior similar to what it was in previous 
versions, when you position a part, two window groups are created when less than three documents are open, 
which lets you directly select the part to be positioned. 

For multi-export with less than three opened documents, two groups are created: one including the design 
document and the start page and another one including all the generated files. 

 

Workshop documents 

White background 

As with drafting documents, you can set a white background for workshop documents. The workshop documents 
come standard with the white background enabled by default. 
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Stop parameter modification 

Modifying the basic_m parameter in the wood_basic_m_break section (6.17) 

In the default values, you can configure the M function for the basic stop operation. 

 

 

Additional parameters for post-processor 

Operation geometry and parameters in the PDB 

CREATE PARAMETERS=YES 

This PDB configuration displays the following parameters in the PDB: 

- The geometry index if there are several geometries in a single operation -> Db.Geometry.Index 
- The reference Z of the operation -> Db.Geometry.z_ref 
- The operation depth -> Db.Geometry.depth 
- The final pass depth -> Db.Geometry.final_depth 
- The number of passes -> Db.Geometry.nb_passes 
- The material height -> Db.Geometry.h_mat 

MACHINING FEATURE=YES 

This parameter lets you write the geometry in the GEOMETRY section of the operation. 
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Position of a tool holder element's coordinate system in the PDB 

The PP configuration word USE CHANGER LOC POS / NOT USE CHANGER LOC POS has been added. 
The values are 999999 if the origin coordinate system of the face is not defined. The position of this coordinate 
system is associative. If the position of the spindle (and thus the position of the coordinate system) changes in the 
TopSolid'WoodCam document, it changes in the PDB too. 

Rails and pods (6.17/6.18) 

An extra line has been added to specify all the sets used: 

*N0008 TYPE=SET            NAME=Rails&Pods Left                MACHINE_REF=L 

*N00XX TYPE=RAIL          ORDER=1            NAME=ZmiWoodMachine#Rail[1] 

*N00XX TYPE=RAIL          ORDER=1            NAME=ZmiWoodMachine#Rail[2] 

*N00XX TYPE=RAIL          ORDER=1            NAME=ZmiWoodMachine#Rail[3] 

*N00XX TYPE=RAIL          ORDER=1            NAME=ZmiWoodMachine#Rail[4] 

*N00XX TYPE=SET            NAME=Rails&Pods Right             MACHINE_REF=R 

                *N00XX TYPE=RAIL          ORDER=1            NAME=ZmiWoodMachine#Rail[5] 

                *N00XX TYPE=RAIL          ORDER=1            NAME=ZmiWoodMachine#Rail[6] 
 
The Generate only used set positions in ISO code option is no longer displayed in the 6.18 version. Consequently, all 
the sets used will be displayed. 
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