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This section describes the new features in the version 6.17 of TopSolid'Wood. 

Design 

Constrained block 

A panel can now be created at the end of the Constrained block function, after the distribution. 

To do this, start by defining one or more panel models. 

• In a new document, create an extruded shape. 
• Launch the Wood > Panel function, and then create the panel on the extruded shape. 

Note: The created panel will then be saved as a model. For example, if three edges are applied to this panel model, 
then three edges will also be applied to the part on which the model will be used. However, the model is for 
reference only. All the panel settings can be changed later on. 

• Launch the Wood > Panel function again. 

• Click  and then . 
• Select the panel you have just created. 
• Specify whether the model has to be saved in the User or in the Group configuration. 
• Finally, name the model and click OK to confirm. 

 
 
Once the panel model has been created, it can be used at the end of the Constrained block function. 

• Create a constrained block. 
• At the end of the function, select the panel model you want to use. 

 
After selecting your panel model, two labels are displayed allowing you to select the reference face of the panel. 
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Note: These labels consist of two separate areas: 

- The first area lets you select the panel's reference face. 
- The second area lets you change the panel model. 

 
• Once you have created the panel on the constrained block, you can modify it using the Modify element function 

as with all other panel entities. 

Construction volume 

Construction volumes can now be created. They can then be used to position a driver block component. 

First, you need to define the attributes of the future construction volumes. 

• Launch the Tools > Options > Shape > Construction volumes function. 
• Define the characteristics of the construction volumes. 

- Layer: 
When this option is enabled, the created volume will be 
automatically placed on the level you specify. 

 
 

- Material: 
Check this box to define the material you want to apply to the volume. If 
this box is cleared, the created volume will use the current material. 

 
Note: Make sure to choose a transparent material in order to have a 
transparent construction volume in realistic rendering. 

 
 
 
 
 
 
 
 
 

- Transparency: 
This option lets you define a transparency for the 
construction volume. A value from 0 to 10 can be entered. 

 

- Color: 
If the box is checked, the construction volume will use the 
color selected in the drop-down list.  
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• Once you have defined these values, close the Options window. 
• Switch to the Construction volumes mode by selecting the Tools > Construction volumes function or by clicking 

directly on CV=Off in the status bar. 

 
• Then create a shape. 
Note: Only the Shape > Extruded and Shape > Block functions can create construction volumes. 

• The created shape automatically takes the attributes that you have defined. 
Here is an example of a construction volume. As defined in the Tools > Options > Shape > Construction volumes 
section, the extruded shape uses the green color, a transparency of 7 and is created on layer 10. 

 
 
In the following example, several construction volumes have been created. 
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Driver block components are then included in each construction volume. 

 
Here is the final result: 
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Panel 

Elliptical panel 

A panel entity can now be created on an elliptical shape. 

 

Laminate sawing-up on panel's maximum dimensions 

The panel's maximum dimensions can now be retrieved in the sawing-up of laminates. For a panel with a sloped 
edge, the panel's maximum length can be retrieved in the sawing-up of both laminates. 

• Launch the Wood > Panel function. 
• Open the Advanced Options window by clicking the >> button. 
• Check the new Sawing-up on panel maximum dimensions option. 
• Finish creating the panel. 
 
 
 
 
 
 

In the following example, the panel contains a sloped edge. If the Sawing-up on panel maximum dimensions option 
is checked, both laminates will be 795mm long. 

If the box is cleared, the top laminate will be 770mm long and the bottom laminate 795mm long. 
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Definition of parts/sets 

Bent part sawing-up 

It is no longer necessary to define the unwound shape of a bent part at each assembly level. The sawing-up 
information is automatically retrieved. 

• Define a bent part in a document. 

A counter will be used as an example since the front and 
baseboards are bent parts. 

• Include this component in an assembly. 
 
 
 
 
 

Note: The unwound part is included in the assembly with the component. It is automatically made invisible when 
inserted to prevent any errors. 

• All the document's unwound shapes are grouped together in the unwound shape set. 

Additional operations 

When drilling operations are performed on the bent part, they have to be added to the unwound shape. 

• Edit the component in the symbolic tree. 
• Expand the Advanced node. 
• Right-click the line of the unwound shape on which the 

drillings have been created. 
• Select Report drills. 
• From the graphics area, select the drillings to be added or 

deselect the drillings that are not to be reported on the 
unwound shape. 

• Click OK to end the function. 
 
 
 
 
 

Note: Only drilling operations can be reported on the unwound shape. However it is possible to report curves, 
frames or points. To do this, right-click on the unwound shape line and select Report points, frames and curves. 

Cut/Machining export 

From now on, when a bent part is selected for a cut or machining export, the unwound shape is exported. 
  



What's new in TopSolid'Wood v6.17  TopSolid 2016 

8  Missler Software 

Drafting 

You can now define the projection mode of bent parts (i.e., choose whether you want to project the bent part, the 
unwound part, or both). 

• Create a new Draft document. 
• Launch the File > Properties > Drafting view function. 
• Select the projection mode of bent parts. 

 

Note: As this setting has been made in File > Properties, it only applies to this document. To adjust the default value 
for all documents, define the projection mode of bent parts from the Tools > Options > Drafting view > Initial 
values section. 

Again using the counter example, the projection mode of bent parts has been set to Both in the multi-drafting 
template. 
 
Note: In this projection mode, the bent part and its unwound shape are projected in different views. 

This is the result of the multi-drafting operation for the Front part: 
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Management of parts without sawing-up 

The Define part function has been improved to make the definition of parts without sawing-up more intuitive. 

Definition of a shape 

• Launch the Define part function. 

 

Note: The Select axis automatically and Bent part options must now be adjusted before you select the part to be 
defined. 

A new With sawing-up button is available. 

-  
If this option is set to Yes, the function behaves the same way as in the previous version. The part sawing-up 
information will be displayed in the bill of material. 

 

-  
If this option is set to No, the defined parts will have no 
sawing-up information. This mode is useful when, for 
example, you define hardware parts. 

 
Note: Once the option has been set to No, the adjustment 
of the Select axis automatically and Bent part options is no 
longer taken into account. 

 
In the Part definition window, the Add to cutting-up box is 
cleared and the part sawing-up information is grayed out. 

 
 
 
 
 
 
 
 
 
 
 
 

Definition of a non-shape element 

Sometimes non-shape elements need to be inserted in the main set (profiles, coordinate systems, lights…). 

• Open the symbolic tree. 
• Right-click the Assembly line and select Insert. 
• Select the element you want to insert in the assembly. 
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Note: Unlike the previous version, the axes are no longer required when adding the following elements to an 
assembly: 

- Curves or sketches 
- Lights 
- Coordinate systems 
- Background images 
- Texts 
- Dimensions 
- Notes 

• The Part definition windows opens and the Add to cutting-up box is automatically cleared. All you need to do is 
click OK to add the element to the assembly. 
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Set over-dimensions 

When a part uses the Additional or Fixed over-dimension modes, the over-dimension can now be set by specifying a 
parameter that will act as the over-dimension value. This parameter can then be defined as a driver so that its value 
can be changed when including the component. 

- Over-dimensions in Additional mode: 
For a part with over-dimensions defined in Additional mode, specifying a parameter as the value allows you to 
include a component with the possibility of changing the over-dimension value. 

• Create parameters for the over-dimensions. 
• In the part definition, enter the parameter name as the over-

dimension value. 

 
 
 
 

• Use the Assembly > Define component > Define drivers function to declare the over-dimension parameters as 
drivers. 

• When including the component, the over-dimension values are required.  

 

- Over-dimensions in Fixed mode: 
The Fixed mode is used to force the length, width or thickness of a part by specifying the desired dimension 
directly. 
Below is an example of how this mode can be used on a component using a driver profile. Here, the component 
length cannot be known automatically since the profile is not necessarily straight. You need to use a parameter 
to retrieve the length of the driver profile. 

 
The shape section has been extruded along the blue curve. This guide curve matches the length of this seal 
component. 

• Create a length parameter by clicking the  icon, then click the  icon. 
• Choose the guide curve as the reference element (the blue curve here). 

 
• Name the parameter. Here, the parameter is named Seal_Length.  
• Define the part. 
• In the Over dimensions column, set the length to Fixed mode, 

and then enter the parameter name as the value. 
• As the width and thickness do not change, you can also set 

their over-dimensions to Fixed mode in order to enter their 
exact value manually. 
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• Once the component has been inserted in the assembly, its length is updated and matches the length of the 
curve on which the component was included. 

 

 

Repetition on curve: Give priority to ends 

The new Give priority to ends option is available when performing a repetition on curve. 
It allows you to change the order in which the repetition instances are created. 

-  
When this option is disabled, the instances are created one after the other along the curve. 
Consequently, the last instance is not always the same if the quantity changes. 

                 
 

-  
When this option is enabled, the instances are created alternatively, starting from each end of the curve. 
This means that, even if the quantity is modified, the instances placed at the ends of the curve are always the 
same. 

               

This mode is useful when, for example, the instances at the ends undergo further geometry changes, such as a 
drilling in the above example. 
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Assembly 

Components 

Automatic activation of the component layer 

When a component layer is set to Template attributes or Initial values of template in the Tools > Options > 
Component > Attributes section, the corresponding layer in the assembly is automatically activated in order to see 
the component immediately when included. 

Extruded components 

Drivers and processes of an extruded component 

The drivers and processes are now required when you include an extruded 
component. It is also possible to perform its processes. 

• Create the extruded component. 
• Declare the component's tools and driver parameters. 

 
In this example, a rail component has been created. This component generates a groove and has two dimensional 
parameters to be specified when included (the l parameter being the length parameter required to create an 
extruded component). 

 
• In the assembly, launch the Assembly > Include standard function and select the extruded component. 

In our example, the rail is included in a cabinet in which sliding doors will be positioned. 

• Specify the component's driver parameter values. 
• Choose the insertion mode. In most cases, the extruded components are 

inserted by clicking directly on two points in the graphics area or by using the 
On curves mode. 

 
As shown opposite, two sketches, each containing two lines (blue) indicating the 
locations of the rails in this cabinet, have been drawn. Consequently, the rails are 
included using the On curves mode. 
 
 
•  The On curves mode provides several options:  

- New contour: This option allows you to create a new profile or sketch on which the extruded component will 
be inserted. 

- Generatrix sketch selection mode: If the Global mode is selected, you can select the entire sketch by only 
clicking one of its segments. The Local mode allows you to select only a segment of the sketch. 

 
Note: In Global mode, if a segment is subsequently added to the selected sketch, a component will be automatically 
added. 

For inserting the rails in this cabinet, the Global mode is used so that the rails can be included on all the selected 
sketch's segments. 
  



What's new in TopSolid'Wood v6.17  TopSolid 2016 

14  Missler Software 

• Then define the key point to be used. A rotation angle and cuts can also be defined. 

 
• Click OK to confirm and to complete the insertion. 
• If processes were defined in the component model, you can activate them by clicking on the Automatic button 

or perform them manually (as with any other component). 

Note: The Automatic mode provides an additional option. 

- Global mode: The process will be performed for all the components you inserted. 
- Local mode: This mode is most often used when processes are performed once the components are inserted 

using the Assembly > Use process function. Indeed, it allows you to perform only the processes of the 
selected component. 
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Nesting 

The position of label texts for parts and orientation symbols has been optimized. In previous versions, these texts 
were placed in the middle of the part's enclosing rectangle. Consequently, for the parts containing open areas or 
internal pockets, the text was placed outside the part, or worse, on another part placed in the internal offcut of the 
first part. 
TopSolid now provides an automatic mode that detects the part's operated areas and prevents the text and symbol 
from being positioned in these areas. 
 

Old method: Centered position    New method: Automatic position 

    

Note: Label texts always use the automatic positioning method. 

For symbols, the Automatic positioning mode must be specified in the Tools > Options > Nesting > Nesting default 
parameters section. 
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Wood machining 

Machining export interfaces 

2D½ DXF export 

In the CADCode interface of the 2D½ DXF export, you can now choose the export unit. 

 
In the TopSolid configuration directory, the cadcode.cfg and cadcode.bom files are no longer used. 
Instead TopSolid adds two new configuration files whose names contain the export unit. There are now four 
configuration files for this interface in the $TOPCONFIG\dxf_wood folder: 

- For exports in millimeters: cadcode#mm.bom and cadcode#mm.cfg 
- For export in inches: cadcode#inch.bom and cadcode#inch.cfg 

Note: If the contents of the previous configuration files were customized, these changes must be applied in the new 
corresponding files. 

Maestro interface 

A new machining interface is available, allowing you to export parts designed in TopSolid'Wood to Maestro. 
TopSolid'Wood generates a .xcs file that contains all the machining information of the part (toolpath, position, 
tools…). 
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Bill of material 

Recovery of parent information 

It is now possible to retrieve information on the parent below the final parent. For example, you can retrieve the 
designation of the assembly to which the part belongs on several levels. 

For example, a cabinet is created in a file. 

 
This cabinet is included in a new document with a door. 

 
To finish, this Cabinet with door component is included several times in an assembly. Their designation has been 
changed so that they can be quickly identified. 

 
In this example, thanks to the OWNER_N BOM property, it will be possible for the Top part to retrieve the 
designations of assemblies in which this part is included: Simple cabinet, Cabinet with door A. 
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• Create a new bill of material file in .bom format. 
• Open the file in with a text editor. 
• Use the following BOM column to retrieve the designation of the Cabinet with door A assembly. 

NAME=DESIGNATION_PARENT 
"DEF=<DESIGNATION|OWNER_N>" 
TYPE=STRING 
ALIGN=LEFT 
TITLE_ALIGN=LEFT 
WIDTH=0.015 
FORMAT=02|mm 
VISIBLE=YES 
; 

• To retrieve the designation of the sub-assembly level, create a new column and add the assembly level of the 
set after the OWNER_N property. 

In this example, the OWNER_N property of the Top part matches the Cabinet with door A set. To retrieve the 
designation of the Simple cabinet assembly, use the OWNER_N-1 property. Similarly, you can retrieve the 
properties of assemblies on X level (N-1, N-2, N-3, etc.). 

 
In the BOM file: 

NAME=DESIGNATION_PARENT_N-1 
"DEF=<DESIGNATION|OWNER_N-1>" 
TYPE=STRING 
ALIGN=LEFT 
TITLE_ALIGN=LEFT 
WIDTH=0.015 
FORMAT=02|mm 
VISIBLE=YES 
; 

Here is the BOM result: 
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Configuration 

Optimized Group configuration 

This new version comes with an improved Group configuration, allowing users working in group configuration to 
manage the configuration files more safely, including through cfg file locking. 

New configuration files 

In order to facilitate working with configuration files, three new cfg files have been created. These cfg files contain 
settings that were previously found in the topzwoo.cfg file. They are located in the same folder as the topzwoo.cfg 
file, in the Group/V6X folder. 

Note: The autoasm.cfg file can now be stored in the Group/V6X folder like any other TopSolid'Wood configuration 
file. 

The three new configuration files are the following: 

- Edge-Laminate.cfg: This file groups together all the settings done in the Tools > Options > TopSolid'Wood 
Configuration > Edge/Laminate section. Edge or laminate codifications created on the fly in the Panel, Edge 
shape and Laminate shape functions are also saved in this file. 

 
- Material-Overdim.cfg: All settings made in the Tools > Options > TopSolid'Wood Configuration > Matters 

overvaluations definition section are saved in this file. 
 

- Propag.cfg: Propagations created from the Tools > Options > TopSolid'Wood Configuration > Propagations 
configuration section are saved in this file. 

Note: All other settings available in the Tools > Options > TopSolid'Wood Configuration section are always saved in 
the topzwoo.cfg file and in the autoasm.cfg file for automatic assemblies. 

Functioning of new configuration files 

These three new configuration files and the autoasm.cfg file are automatically locked when a change is made from 
TopSolid. This prevents a user from unintentionally overwriting settings configured by another user. 

A .lck file is automatically created when the .cfg file is locked. The image below indicates that the three new 
configuration files are locked. 

 

Note: The topzwoo.cfg file is never locked by TopSolid. However, Windows safety features can be defined on the 
file to prevent some users from making changes to it. 
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These files are locked in the following cases: 

- Edge-Laminate.cfg 

The configuration file for edges and laminates is locked when a user clicks the Edge/Laminate line in the Tools > 
Options > TopSolid'Wood Configuration section. This prevents two users from creating different codifications at the 
same time. 
This file is also locked when codification is created in the Panel, Edge shape and Laminate shape functions. 

For example, in the Panel function, a user A creates a new codification by double-clicking a line of the Edge type - 
code column, and then clicking the Add button. 

   
 

Note: A new Init the list button is available, allowing you to update the list of codifications for edges or laminates, 
and thus add a codification recently added by another user. 

When the codification is created, the file is locked, which prevents another user from creating the same codification 
or overwriting a change. On the user B's workstation, the following message is displayed in the alpha bar if he 
attempts to add or modify a codification when the file is locked. 

 

If the Edge-Laminate.cfg file is locked, the settings available in the Tools > Options > TopSolid'Wood 
Configuration > Edge/Laminate section are grayed out and the above message is displayed in the alpha bar. 
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The file is unlocked when the user exits the Tools > Options window or finishes creating the codifications from the 
Panel, Edge shape and Laminate shape functions. 

- Material-Overdim.cfg 

The file containing the matter overvaluations is locked only when a user defines matter overvaluations from the 
Tools > Options > TopSolid'Wood Configuration > Matters overvaluations definition section. The settings available 
are disabled on the other workstations and a message indicating that the file is locked by another user is displayed 
in the alpha bar. 

 

- Propag.cfg 

This file is locked only when a user creates, modifies or deletes an existing propagation from the Tools > Options > 
TopSolid'Wood Configuration > Propagations configuration section. 
When the Propag.cfg file is locked, all settings available in the Tools > Options > TopSolid'Wood Configuration > 
Automatic assembly, Propagations configuration, Propagation, Assemblies and Multi-drillings sections are grayed 
out. As for the two previous files, a message indicating that the file is locked is displayed in the alpha bar. 

 

- Autoasm.cfg 

This file is locked only when the user goes to the Tools > Options > TopSolid'Wood Configuration > Automatic 
assembly section. As for previous files, a message indicating that the file is locked is displayed in the alpha bar. 

 

The Material-Overdim.cfg, Propag.cfg and autoasm.cfg files are unlocked when the user exits the Tools > Options 
window. 
  



What's new in TopSolid'Wood v6.17  TopSolid 2016 

22  Missler Software 

Dialog box resizing 

You can now resize certain dialog boxes. Like in Windows, you just have to click and drag one edge of the dialog box 
to adjust its size. 

You can resize the windows of the following functions: 

- File > Export project 
- File > Import project 
- File > Links 
- Parameter > Edit list 
- Assembly > Include standard 
- Tools > Text > Several lines 
- Tools > Note 
- Attribute > Properties > Properties editor 

Note: The window size adjustment is kept for the full TopSolid session, i.e. as long as the software is left open. 
When the software is closed, the windows go back to default size. 
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Multi-criteria filters 

New operators 

When you create a multi-criteria filter, you can now use the following operators in the Tools > Options > Multi 
criteria filter section: 

- Does not start with 
- Does not contain 
- Ends with 
- Does not end with 

Selection through filters 

Filter selection can now be used in the Define multiple parts function. 

• Launch the Wood > Define > Define multiple parts function. 
• Select parts in the graphics area or click Main assembly. 
• To choose the filter selection, enable the By filters option, or click in the Filters tab directly. 
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Management of materials 

Obsolete materials 

Some materials can now be defined as obsolete so that they are no longer displayed when defining a part. This 
saves the material from being deleted so that parts of old projects don't lose their material. 

• Launch the Attribute > Material > Manage materials function. 

A new Obsolete option is available in the Data tab of the Material editor. 

 
 

Note: Once the Obsolete box is checked, the material can no longer be used on a part. However, the old parts that 
used this material will always be linked to it, and the material will always appear in the bill of material. 

• The Beech european material has been defined as obsolete. When a 
part is defined, this material is no longer visible in the list of 
materials. 

 
Note: If all materials of a category are defined as obsolete, then the 
category is not displayed in the list of materials. 
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Drafting 

Views 

Non-dynamic projections 

When creating an auxiliary view, if the File > Properties > Projection parameters > Dynamic projection mode option 
is cleared, TopSolid now displays the view frame without contents. The view is only calculated when positioned. 

Note: This mode is useful if, for example, the size of the set to be projected is large and requires long calculation 
times when generating the view. 

Formatted view title 

You can now retrieve information in a view title. For files with multiple drawings, this makes it possible to display in 
a section view title the number of the page where the reference view appears. 

In this example, the sections views are created on other pages than the main view.  

 

• Edit a view using the Modify element function. 
• In the Title field, enter the syntax to retrieve the desired properties. 
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Here is a list of properties that can be retrieved in the title, as well as the syntax to be used. The properties must be 
entered between the < and > characters. 

Property Purpose 

title View title 

scale View scale 

drawingscale Drawing scale 

paper Drawing format (A4, A3, etc.) 

folio View drawing's folio number 

folio|nb Retrieves the drawing's folio number in 2/4 format 

depth Cross section/section depth 

sectionname Cross section polygon name 

nl Skips a line between two properties 

Note: To retrieve a property of the reference view, add refview. before the property. 

In this example, the section name, the reference view folio number and the reference view title will be retrieved in 
the title of a section view. The properties to be used are in the following order: <sectionname> <refview.folio|nb> 
<refview.title>. 
 

 
 
Note: For further clarity, plain text has been added (Section:, Ref view on page: and Ref view title:) and a line is 
skipped after each property using <nl>. 
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Here is the final result in the drafting document: 

 

Elevation view 

It is now possible to straighten section views or sections in order to create elevation views. 

• Create a main view. 

Again using the kitchen example, a section is created to better view one of the walls. 
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• Launch the Full section function and create the cutting curve. 
• Before positioning the view, adjust Alignment = NO. 
• The new Set the view upright option appears. 

Note: This option is used to force the view orientation to be vertical. It is only available in Alignment = NO mode. 
 
Set the view upright = NO 

 

Set the view upright = YES 

 
 
The Set the view upright option can be modified after the view is created. 

• Launch the Modify function. 
• Select the view to make upright. 
• Check/Uncheck the Set view upright when not aligned option. 
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Interfaces 

SketchUp import 

A new mode for importing SketchUp files has been developed. You can now import objects in polyhedral mode that 
are smaller in size than if exact shapes were generated during import. The SketchUp files with the .skp extension are 
most frequently used to import decorative objects into TopSolid. 

• Launch the File > Open function. 
• Choose the .skp file you want to import, then click OK to confirm. 
• Two import mode are available. Select Import polyhedrons.  
• The following options are available: 

- Unit: Used to choose the export unit. By default, this option is set to Automatic, i.e. the file will be imported 
in the unit with which it was created. 

- Import free curves: Used to import the curves of the .skp file. If the option is set to No, only volumes will be 
imported. 

- Import textures: Used to retrieve the textures applied on the faces. 
 

• Click OK to confirm and to end the function. 

Here is an example of a file that was imported in polyhedral mode. 
 
Note: Once the file is imported, the resulting shapes are stored in the 
Polyhedral shapes set. 
 
In this example, the polyhedral file size is more than seven times smaller 
than the file containing the exact shapes. 
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Miscellaneous 

- An ellipse can now be selected as the guide curve in the Shape > Pipe function. 
 

- In the Wood > User machining function, a new Centered tool = YES/NO option enables the centered tool 
path of the machining to be exported. 
 

- The new configuration word D_DRIVER_HOUSING_DEFAULT_NAME "default_name" lets you define the 
default name of a driver block. This line must be added to the top.cfg file. If this configuration word is 
available, you will not be asked to enter the name of the driver block. 
 

- The Include standard and Include sub assembly/part functions are now available in neutral mode by clicking 
in the screen background. 
 

- The  Make visible function, which is available in the same menu as the  Visibility function, only 
displays the invisible elements. You then need to click the elements you want to make visible. 

 
- The current coordinate system is now shown in green in the symbolic tree. 

 
- In a distribution, a component can now be inserted in gaps (for example, inserting a pole between two 

distributed partitions). 
 

- The new Automatic for all button is available when including a component with driver parameters. This 
automatically connects all the component's driver parameters to the corresponding parameters in the 
assembly. 

 
- In the Automatic mode of the Wood > Constrained block function, when a face with non-parallel edges is 

selected, a constrained block with non-parallel faces is automatically created. 
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This section describes the new features in the version 6.17 of TopSolid'Punch and TopSolid'Cut. 

New features common to TopSolid'Punch and TopSolid'Cut 

Sequence visualization 

The access to this functionality is now faster. 

From the toolbar, you just need to activate the icon's drop-down menu in order for sequences (displayed in green) 
to regenerate more quickly without interrupting the current LIP macro. 
The view filter on a given tool remains active. 

 

Production date 

In this new version, the production date has been removed from the update dialog box. 

When opening the Task Manager from a Punch part document, the part data is checked to see whether it matches 
that of the Task Manager. 
If there are differences, a dialog box appears allowing you to select the data fields you want to update. 
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Task Manager at startup by default 

This new version lets you start the application with a Task Manager document by default. 
This can be configured under Tools > Options. 

 

The option you choose is kept throughout the session, until you change it. 
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Column sizes in Task Manager 

This new version makes it possible to preserve any manual changes made to the column sizes of the various Task 
Manager's lists. 
These changes are saved throughout the TopSolid session. 
This new feature, which can be configured under Tools > Options, is also available in the favorite part and nesting 
dialog boxes. 

 

Task Manager recovery 

The backup files of the Task Manager are regularly backed up when the manager is saved. 
These backup files can be found in the $PUNCHDATA\Archives_TMan folder. 
By default, there are three files with the following extension: #B=-1.bak, #B=-2.bak and #B=-3.bak. 
They are replaced every time the manager is saved. 

If a problem occurs when saving or reading the manager, a new system allows you to prevent the saving of backup 
files so that you don't overwrite a valid backup file with wrong data. 
In addition, when the Task Manager dialog box is open, the system will launch the data recovery procedure using 
the backup files . 
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Part imports from nesting document 

A drop-down menu has been added to the nesting document to help you import parts without having to create an 
"empty part" document. 

 

Free line 

In the Miscellaneous > Free contours > Free line command, a button has been added to freeze the axes horizontally 
or vertically. 

 

 

Pressing the z or Z key (not case-sensitive) changes the status of the button. 

Custom marking of parts in the nesting 

In this version, you can customize the marking of parts that are created directly during a nesting. 
The data to be marked can be configured under Tools > Options. 
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By default, only the part reference is marked. It is now possible to mark the Designation, the Plane, the name of the 
Set, the name of the Customer and the Order. 
You can also compose the information you want to mark and the order of data using the arrows. 
You can use a separator character as a field delimiter. 
If a data is unknown, it can be replaced by special characters. 

Moving a cut rest line 

A new function has been added to the Punch and Cut modules to move a cut rest line.   

You can click on the horizontal or vertical line to move it dynamically. 

If wastes were marked, a message will appear to indicate that the marking texts may be moved. 
If only one waste is marked, you will be asked whether you want to move the marking text. 

 
A lettering, which can be a waste marking, can now be moved dynamically, and it is represented by the oriented 
rectangle of the lettering box. 

Management of completion parts 

This new version gives priority to waste cutting in order for completion parts to be placed only in the free space 
corresponding to priority parts. 

Example of a nesting without completion parts (preset and recovered cutting waste): 
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Example of a nesting with completion parts (preset and recovered cutting waste): 

 
If you don't want this behavior, you can add the following configuration word manually to the topzpch.cfg file in 
order to return to the behavior of older versions. 

ZPCH_NEST_COMPLEX_FAVOR_CUTREST_ON_COMPLETIONPARTS 0 

Improved part coloring feature 

From now on, a color is always assigned automatically to each of the nesting parts, even if coloring is not necessarily 
requested. 
This function can be enabled/disabled in the nesting order. 

 
 
This gives each part a different color even if coloring was not requested during the nesting. 
Automatic color assignment is not applied if the nesting order contains only one part or in the case of unit part 
nesting, which makes it possible to keep the color defined in the part document. 
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TopSolid'Punch 

Punch sequence display 
The punch sequences can be displayed immediately in nesting documents from the Task Manager. 
This feature can be enabled under Tools > Options. 

 

Default marking tool selection 

During automatic punch allocation, you can configure the default tool to be used for marking. 
This feature can be enabled under Tools > Options. 

 
When manual lettering is created using the Miscellaneous > Free contours > Lettering function, you can choose the 
tool to be used for lettering in the case of several tools. 
The types of tools included are Rollerball, Rolling shear and Punch marker.  
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Copy of macro's free geometries 

When an internal macro is modified, free geometries can be added to it. 
When the macro is automatically recognized, the free geometries and their machinings are copied into the 
machining document. 
 
For example, in order for the ellipse to be fully machined, it may be useful to add a free geometry rectangle to 
punch the inside of the rectangle. 
During automatic allocation, the free geometries are automatically created when the macro is recognized. 

 

Note: In the machining document, the free geometries automatically created through macro recognition will be 
automatically removed (during update) when there is no more tool left on this free geometry. 

Creation of special tools from TopSolid 7 

It is possible to create special tools in TopSolid 7 that will be recognized in TopSolid'Punch. 

Methodology 

• From TopSolid 7, create a new unfolding document. 
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• Create a new 2D sketch. 

- Draw the curve of the tool. 
- In the sketch, create the center point of the tool (make sure this point is internal). 
- Optionally, draw a curve of the rectangle type that will be used as the tool's safety zone. 

• Confirm the sketch. 
• Save and check-in the document. 
 
Example of a keyhole tool: 

 
 
• Create the special tool in TopSolid'Punch: 

- Use the Manage > Special tools creation function. 

 

- Click the V7 Explorer button and select the project and the document for the tool. 
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- In the current document, select the curve, and then the center point of the tool. 

 

- Specify the tool name. 
- Select the segments to be used as supports for automatic allocation (all in this example). 
- Select NONE for the safety zone. 
- Specify the tool-specific data. 

 

• Case of multi-curve tools: 

- After choosing the document in the Project tree, click the MULTI CURVES special tool button. 

Note: If no direct link exists with TopSolid 7, make an export of the special tool with TopSmi conversion in 
TopSolid 7 and use the EXPLORER button to retrieve the TopSmi document. 
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• Case of special tools with complex curves (example of an elliptical-shaped special tool created in TopSolid 7): 

- Create a new 2D sketch. 
- Convert the curve into arcs and lines using the 2D Sketch > Operations > Lines arcs conversion function. 
- Create the center point of the tool. 
- Validate the sketch. 
- Save and check-in the document. 

 

Cut rest manual function for punching 

A new function is available in the Splitting menu to create either vertical, horizontal, mixed or in L-shape cut rest. 

 
The default settings can be adjusted under Tools > Options. 

 
The Auto mode lets you create one or more wastes at a given distance from the last part. 
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The Machining options button lets you configure: 

- whether the waste will be evacuated with a machine stop or held by micro-junctions; 
- the tool selection to punch the lines; 
- whether the waste cutting must be done at the end or before all other machinings. 

Example of L-shaped cut rest with micro-junctions: 

 

Flange 

A new function in the Punching menu can be used to create flanges on geometries with Z elevation management. 

You need to define an Oblong tool and enable the Quick flange option in the punching conditions. 
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Functioning 

• Call up the function. 

Several modes are available. 

 
 
Part of contour mode: 

• Select the start segment (an arrow indicates the direction). 
• If necessary, click the INVERT DIRECTION button to change the direction. 
• If necessary, specify an offset, the Z start and the Z end values of the last flange segment. 
• Select the end segment. 

 
• You can rotate the view to put the result into perspective. 
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The flange is displayed as a green thick line. The elevation is done progressively along the segments. 
Once the flange has been created, any changes to it will be made using the wrench. 

Modification 

It is possible to change the offset, the Z start and the Z end values of the flange. 
Depending on the segment selected, it is possible to force the Z end value of this segment. 

 
 
The elevation is done progressively along the segments. The Z end value of the first segment is free. 

• To force a new value, click the FREE button. The displayed value corresponds to the Z value considering the 
progressiveness. 

Addition of intermediate points 

To vary the elevation before the end of a segment, an intermediate point can be added by cutting the segment in 
half. 

• Use the wrench on the flange and click the Intermediate points button. 

Two modes are available: Manual or Position value. 

• Click the black geometry in front of the flange. 

A new segment has been inserted and its Z end value can be modified like any other segment. 
The cutting point appears as a dotted line. 

• To change the position of the point, use the wrench and click on the dotted line. 
• If necessary, you can specify a specific value in relation to the beginning of the line. 
• To delete the segment created, check the Delete it box. 

Mouse tool orientation 

When the tool is shown dynamically on the mouse, its displayed orientation is now the angle of the mounting key on 
the turret + the definition orientation of the tool itself. 
If the tool is not yet mounted or it is mounted on an indexing station, only the definition orientation is taken into 
account. 

This is a fast way to determine if a geometry can be machined with the tool. 
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Punch marker tool 

The new Punch Marker feature has been added to the round tool management. 
In the tool management, enabling the Punch Marker option allows you to define the step between each punch 
mark. 

 

Its allocation is done directly on the geometry using the  With ROUND tool or  Tool machining on profile 
function. 
 
Example: 
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TopSolid'Cut 

Part groups 

A new function is available in laser to define machining zones in order to limit overheating of very thick sheets. 
This function can be accessed from the icon bar in a Nesting document. 

 
These groups are defined by the user. 

The following three options are available: CREATE, MODIFY and REMOVE. 
In order to make the selection easier, cutting sequences are hidden and parts can be colored as soon as the function 
is launched. 

Group creation 
Parts can be selected freely or using a filter on the names of the nesting parts. 
Existing groups can be hidden or visible. 
Multiple selection is possible. 

If only one part is selected, it can be included in the group or removed from the group if it already exists. 
If only one part is selected and this part belongs to a cutting path, all parts of this path will be included in the group 
(each part must have only one cutting instance). 

When confirming the group by clicking OK, a group number is provided and, if there are several zones (shifts) in the 
part selection, a group number is created for each zone. 
The parts that overlap several zones will be contained in a specific group. 
To associate a part that overlaps several zones with a group of parts that only includes parts of a given zone, you 
need to use the Modify a group function. 

Group modification 
A drop-down list allows you to select the group to be modified. 
The other existing groups can be hidden or visible. When the other groups are visible, a part can be easily 
transferred from a group to another. 
The END button allows you to quit the change function. 

Group deletion 
A drop-down list allows you to select the group to be deleted. 
An option is also available to delete all groups. 
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Cutting strategies 

In this version, simulation allows path strategies to be taken into account for cutting. 

Functioning 

For cutting, the path is given by the links defined between cuttings in the part document and/or nesting document. 
These links are generated using the Automatic cutting and linking function or the Linking path between cutting 
path function. The links set a path between cuttings. 

Cutting strategies involve creating or recreating automatically the links between cuttings or between parts during 
the simulation. 
Consequently, no links must be defined between cuttings or parts. Keep only imposed links that cannot be modified 
by the simulation. 

Imposed links are shown in blue. They are created by the user with the Automatic cutting and linking or Linking 
path between cutting function. 

The links created automatically by the simulation are shown in black and depend on the required strategies. 
When changing the strategy, these links will be readapted. 

You can make changes to a link generated by simulation (shown in black), but it will turn into a blue-colored 
imposed link which is no longer impacted by the simulation. 

This can be configured under Tools > Options. 
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Dialog box for cutting machines 

When the simulation is launched, the following dialog box appears. 
 
A drop-down list containing the different groups 
defined in the zone is available at the top of the 
window, with a line for each zone. 
 
The paths that match the selection in the graphics area 
are highlighted. 
A different strategy can be applied to each of the 
groups. 
 
The following strategies are available: 

- Strategy by part 
 Definition of the desired path between each part. 

The path can be defined between the internal 
and external cuttings for each part, providing that 
no blue links were imposed in the part. 
The cuttings are performed in the internal order, 
and then in the external order part by part. 
 

- Alternate strategy 
Same concept as the strategy by part by skipping 
a part to prevent overheating in strong 
thicknesses. 

 
- Strategy by horizontal or vertical bands 

 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 

- Entire sheet strategy 
All part's internal contours are processed before 
external contours. 

The Apply to all zones/groups button makes it possible to apply the same strategy to all zones/groups. 
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The Subroutines button lets you configure the way subroutines are generated. 

 
 
The Prototypes button allows you to graphically select the parts to be cut before the rest of the sheet. 

 
 
The simulation player displays the Strategies button which allows you to subsequently modify the cutting strategy. 
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Dialog box for punching/cutting combined machined 

A new Cut Strategies tab lets you set the cutting strategies independently of the punching strategies. 

 
 

When clicking this tab, the dialog box changes, allowing you to define the cutting strategies. 
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Operation order dialog box after simulation 

Further information has been added about the group number on the part and/or the band. 

 

Example: 

 
 
Once the simulation using cutting strategies is performed, you can see the black links that have been automatically 
created through the simulation process. 
If a waypoint is created on one of these links, this link will turn blue and will be imposed. 
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This section describes the new features in the version 6.17 of TopSolid'WoodCam. 

Rails and pods 

Distributed rails under the part 

This feature allows you to change the number of rails to be used under a part according to its length. 

• To configure the distribution of rails, use the  Rails and pods definition function. In the window, select a set 
of rails and pods, and then from the Distribution tab define the maximum number of rails for a given part 
length. 

The distribution values are saved in the document because they are included in the rail and pod definition. 
 

 
 

Adds a new line to the rail distribution table.  
 

 
Deletes the current line in the rail distribution table. 
 

 
 
 
 

 

  
On the left, pods are positioned without rail distribution. On the right, pods are positioned with rail distribution. 

Parking positioning of rails and pods 

The rails and pods that are arranged during a positioning now take account of the minimum distances between rails 
and between pods. These values can be defined in the document properties or in the configuration of the pod 
positioning function. 
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Push the rails and pods to their stroke limits 

The rails and pods can now be pushed independently of each other to their stroke limits by pressing the following 
keys: 

Step-by-step mode: 

- Left/Right Arrow 
- Up/Down Arrow 

Stop mode: 

- Ctrl + Left/Right Arrow 
- Ctrl + Left/Right Arrow 

The minimum distances between rails and between pods are taken into account. 

Element selection for clamp positioning 

The clamp positioning function enables the selection of a point or a face. 

 
 
For example, if a face is selected, the guiding axis of the clamp will be positioned against the face. 
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Automatic positioning of rails and pods in several areas 

When a machine contains multiple sets of rails and pods and a part positioned on a stop encroaches on various 
areas, TopSolid'WoodCam automatically positions the rails and pods for the areas concerned. 

The stops that are related to each of the rail and pod sets are defined in the Stops tab when you create the set . 

When the Use sets linked to the stop and Automatic positioning of rails and pods options are enabled in the 
 document properties, TopSolid'WoodCam positions all the rail and pod sets related to the stop being used. 

 

Fixed rails in a set 
When the pods are positioned manually, it may be necessary to fix the position of rails. 
The Fixed rail function has been improved so that all the set's rails can be fixed. 
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Vacuum blocks 

Updated vacuum block positions 

The new Update blocks positions during operation update option lets you update the block positions when re-
executing  the operation (without editing the block positioning operation). 

 
 

Processes 

Through pocket parameter 

When a part contains several apertures created through Boolean operations, 
TopSolid'WoodCam retrieves a set of curves for machining purposes. The 
disadvantage of this method is that all apertures are processed in the same way. 

The pocket operations have the advantage of being processed independently of 
each other by the process assigned to them. In addition, these operations can be 
sorted using the Operations sorting CAD function, unlike apertures. 

To dissociate through pockets from blind pockets, the new Through pocket 
parameter is available in the keywords. This Boolean parameter displays 1 if it is 
a through pocket or 0 if is it blind. 

It is now possible to activate a contouring for a through pocket and a pocketing 
for a blind pocket. 
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Partial hole 

A new keyword is available in the drilling processes, making it possible to detect whether a hole is the result of two 
holes facing each other in CAD mode. 

This boolean (.form_woodHole.IsPartialHole) displays 1 if it is a partial hole and 0 
if not. 
A different drilling depth can be given depending on whether it is a partial hole or 
not using the following syntax: 

(.form_woodHole.IsPartialHole==0)?.form_hole.depth:.form_hole.depth*0.6 
 
Then, from the Properties > Routing configuration > Holes section, you just need 
to choose whether through holes in two operations should be kept or processed 
as holes in a single operation. 
 
 

 
 
 
 

 

Found tool 

A new keyword lets you know whether a tool is compatible with an operation. 
In the keywords of the Tool chosen > A tool has been found operation, this Boolean displays 1 if the tool has been 
found and 0 if not. 
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Analysis 

Tool selection window display 

By default, during automatic analysis, if no matching tool is found, the process execution is interrupted with an error 
message. To avoid this happening, the Show dialog if tool request failed option is now available. 
This option is saved and can be configured for the document using the File >  Properties function or directly in the 
options of the analysis of part operations . 
 
Warning: The analysis is no longer stopped if a tool is missing, so you have to check that all of the operations have 
been machined. In multi-machining mode, errors are recorded in the log file. Consequently, it is up to you to 
check whether operations are missing in there. 

 

Multi-machining 

Directory explorer 

An Explorer icon has been added to choose each directory in the Tools > Options > Routing configuration > Multi 
machining section. 

 
 

Nesting 

Abort the execution of nesting operations 

The Esc key lets you stop the analysis of all the nesting operations. 
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Machinable part 

Simple panel and multilayer panel 
The panel entity and the multilayer panel are now processed as a single part during positioning and machining. 
This makes it possible to machine the edges and laminates and the operations that affect several parts of a 
multilayer panel without being detected several times for one single entity. 
The elements to be positioned can still be separated in the document properties. Consequently, the multilayer panel 
can be machined in multi-machining mode. Edges and laminates are represented in a simplified way on the 
machine. 

 

Mounted set 

The mounted set uses the concept of machinable part. As a result, all of the CAD set's parts are considered as one 
part in TopSolid'WoodCam. This removes unreachable operations between two parts and thus avoids detecting 
several times operations that affect several parts and are unreachable. 

Ghost drillings 

Reminder: In the CAD system, ghost drillings can be defined to lighten the 3D model. 
When a part contains ghost drillings, it is automatically converted into a machinable part.  
During conversion, the drillings are recreated (in real mode and not in ghost mode), allowing them to be normally 
machined. 

The machinable part can be disabled using the following configuration word: 
ZMI_WOOD_PART_CREATE_MACHINING_SHAPE 0 

In this case the machinable part is not created and TopSolid'WoodCam work as in the 6.16 version. 
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Panel positioning 

Intermediate stock for panel positioning 

When an incomplete panel (supports with edges, supports with laminates or simple supports) is positioned, 
TopSolid'WoodCam can use the enclosing shape of the positioned elements, or the panel's stock provided by 
TopSolid'Wood. 
The type of panel or support(s) can now be selected in the document's  Properties > Part positioning section. 

 
Different options are available: 

- Positioning of the incomplete panel: The panel's stock provided by TopSolid'Wood is used. 
- Positioning of the panel and edges: The panel's stock provided by TopSolid'Wood or the enclosing shape of 

supports and edges is used. 
- Positioning of the panel and laminates: The panel's stock provided by TopSolid'Wood or the enclosing shape 

of supports and laminates is used. 
- Positioning of simple supports: If there is only one support, the panel's stock provided by TopSolid'Wood is 

used. Otherwise, the enclosing shape of supports is used. 

This option also works if the machinable part is disabled by the configuration word. 
 

 

Set machining 

Unite set shapes 
The Unite set shapes option has been added to the document properties in order to activate the Unite shapes 
function by default when a set of parts is calibrated (but only if these parts were mounted in Create all parts mode).  
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5-axis machining 

Generation of orthogonal angles from real kinematics 

Certain 5-axis machines only accept the programming of theoretical axes. For these machines whose rotation axes 
are not orthogonal, programming in TopSolid'WoodCam with the real kinematics is now possible as well as the 
generation of programs in an orthogonal coordinate system, while keeping the angular limits of the real kinematics. 
Available for Head/Head machines with a C-A configuration from the kit later than 1.15.41. 
 
[POST PROCESSOR] 
#LABEL = Woodwop Theorical angles on real kinematic  
#COMPANY = TopSolid'WoodCam 
#MACHINE TOOL =  
#NUMERICAL CONTROL = T1 
#POST PROCESSOR NAME = TopPpWoodwopV135 
#FILENAME PARAMETER = TopPpWoodwop#V=T1#I=13.cfg 
 
[SPECIFIC] 
#Orthogonal_Axis = YES  
 

Ergonomics 

Multi-machining 

The multi-machining window has been modified in order to be able to read the sort criteria of parts correctly. 
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