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This document describes the new features made to the design application of the TopSolid’Design software in the 
version 6.15. 

Installation 

Prerequisites 

The installation procedure proposes to install or upgrade the components listed below with the following 
versions: 

Component Version 

Microsoft .NET Framework 2.0 

Microsoft .NET Framework 4.0 

Visual Studio C++ Redistributable 2005 

Visual Studio C++ Redistributable 2008 SP1 

Visual Studio C++ Redistributable 2010 

Visual Studio C++ Redistributable 2012 

Sentinel driver 7.5.8 

Sentinel RMS License Manager (floating license manager) 8.5.3 

Configuration 

Configuration styles 

Customization of TopSolid has been further improved. In addition to the configurable contexts in previous 
versions, it is now possible to define styles that contain the menus, functions and contexts to be used. 
This makes it possible, for example, to create a style for each application (TopSolid’Design, TopSolid’Draft, 
TopSolid’Mold,…). 
As with context customization, styles can be created using the Tools > Customize function and it is possible to 
switch from one style to the other using the Tools > Style configuration function. 
For each type of document, the last style used is saved so that it can then be automatically used when creating a 
new document. 

 
Style definition using the Customize function. 
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Style selection using the Style configuration function. 

Document 

Import project 

The File > Import project function now proposes to open the project just imported. 

Links in the tree 

The new Append links contextual function is used to create a tab that displays the document links. 
The status of documents is shown using icons and symbols: 

- Green padlock: The document is locked by the current user. 
- Red padlock: The document is locked by another user; the name of the station that locks the document is 

displayed after the name. 
- Yellow flag: A more recent version is available on the disk. 
- Modified documents are displayed in bold and preceded by the "*" symbol. 

The contextual menu allows you, among other things, to update or open documents, open the Explorer, etc. 

 

 

Addition of the Links tab and example of links. 
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Concurrent access to documents 

For users who want to work together on a same project, the Document > Others section of the Tools > Options 
function provides a new file locking mode: Lock when displaying + Secure local save. 
This mode corresponds to the lock when displaying mode with no changes allowed and no possibility to save a file 
by overwriting a more recent version on the disk and saved by another user. 
When opening a document, a blue frame around the graphical area indicates that the document is locked by 
another user. 
 

 
New locking mode setting. 

User interface 

Tree 

The unfolded nodes of the symbolic tree remain open when the tree is displayed again. 

Orientation 

In the status bar, the new Ax=yes/no mode is used to automatically reposition the view along the nearest axis. 
This setting is saved between two sessions. 

 

Presentations 

When creating a presentation, the COMMENT option allows you to associate a description with the presentation. 
When the presentation has been created, this comment can be entered from a contextual command. 

Compass 

The compass configuration information available in File > Properties has been relocated in Tools > Options. 

Selection 

The mode for selecting faces by color has been added to the Shape > Other shapes > Copy face, Shape > 
Surfacic/boolean operations > Smooth and Shape > Mechanical/other operations > Color functions. 
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Selection of an axis on a coordinate system created on the fly 

When an axis is asked, for example when creating a coordinate system on 2 axes, the THROUGH POINT option 
allows you to specify the axis by selecting 2 points. It is now possible to create a coordinate system on the fly so 
that one of these axes can be selected. 

Parameter 

Selection of the parameter to be modified 

When modifying a parameter, for example using the Modify parameter function, when several parameters are 
found on the selected element, these are available as buttons in the dialog bar. 
For greater clarity, these buttons now display the parameter values. 

 
Modification of a cylinder’s parameters. 

Expressions 

The WHEN, OR and AND functions have been optimized to calculate only the necessary expressions. 
For example: WHEN(length==0,0,100/length)  

- if length = 0, the 2nd part of the expression (100/length) is not calculated, which in this case avoids a 
division by zero. 

Contour 

Horizontal or vertical link 

During contour creation, after entering a through point, the Link=AXES (Z) option allows you to get a segment 
parallel to one of the coordinate system’s axes. This option is now available by indicating a starting point, then a 
profile, and vice versa. 

Invalidity 

A contour built on invalid elements now becomes invalid too. 
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Sketch 

Visualization of sewn curves 

In addition to show the ends of open curves, the Show extremities function now hatches the closed sewn curves 
in order to improve their visibility. 
Each area is hatched with a different pattern, color and angle; five patterns are used with pastel colors in order 
for curves to be readable. These hatchings are hidden during a dynamic movement (zoom or rotation). 
 

 

Fillet 

When the value is too large or segments are tangent, a yellow circle is displayed on the vertex where the fillet 
cannot be performed. 
The new Mode=Local/Global option is used to create a fillet on all angles of a sewn curve. A different radius can 
be specified for internal and external fillets. 
 

 
  

Examples of fillets in GLOBAL mode, with same radii (left), with different radii (center), and with a too large 
radius (right). 
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Repassing 

When creating a contour by passing over existing entities, leaving the cursor over a segment for one-half second 
allows this segment to be defined as a reference. In addition to the protractor, TopSolid then proposes a 
construction line parallel to the segment. 
Simply click on this line to create a "parallel repassing" with a dimension imposing the constraint. 
It is possible to build on segments of another sketch or on edges of a shape. 

 
When creating the right contour, hovering your mouse over the red segment (1) allows you to display the axis 

(2) in order to hook on it. 

Rectangle 

The new 3 POINTS option is used to create a rectangle by indicating 3 points; the rectangle thus obtained is 
constrained by 2 dimensions and perpendicularity constraints, which allows it to rotate around a vertex. 

Curves/Other operations 

Sewing 

In non-associative mode, in order for the resulting curves to remain on the same level as the original curves, the 
Check layer of curves option must be checked and the value "-1" must be entered in the Layer field. 
It is also possible to keep the original attributes by checking the Check color of curves and Check linetype of 
curves options. 

Curves/Manage 

Superposed curves 

Like for sewing, in order for the resulting curves to remain on the same level as the original curves, the Check 
layer of curves option must be checked and the value "-1" must be entered in the Layer field. 
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Shape 

Extruded shape 

The arrow for reversing the direction takes better account of the zoom in order to be visible on flat parts such as 
panels. 

Enclosing shape 

The Optimize=YES/NO option has been added in the case of an enclosing cylinder with a given axis; it accelerates 
calculation times in most cases. 

Copy faces 

In COMPOSITE SURFACE mode, the Follow=EXISTING OPERATIONS/SUBSEQUENT OPERATIONS option has been 
added. Moreover, the function ergonomics has been modified; the internal loop removal, trimming and merging 
options are now available in the advanced options that can be accessed using the button >>. 

 

Knurling 

It is now possible to knurl a planar face. This enables it to be associated with a knurling dimension in the draft. 

Drilling 

Major improvements have been made to the drilling function: 

- Blind hole with global offset: 
In previous versions, the offset was calculated in relation to the face intersecting the drilling axis. The new 
Global offset option takes all the part faces into account to calculate the offset (bottom faces + side faces). 
 

 
 

Examples of drillings with offsets: on the left the offset mode,  
on the right the new Global offset mode. 

 

- Drillings on circles: 
For documents coming from a 2D import (AutoCAD DXF, DWG or others), the new CIRCLES option available in 
the COORDINATE SYSTEM OR SKETCH mode allows you to quickly create drillings on circles by automatically 
retrieving the diameters. 
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After selecting the circles and the reference face, the drilling type selection window is displayed for each circle. 
The Merge=YES option is used to identify circles with the same diameters in order to display the drilling type 
selection window only once. 
The concentric circles are automatically recognized so that the spot faced holes can be performed. 

 

 
Retrieving a draft document. 

 

 
Rebuilding the initial shape. 

 

 
Creating the drillings on the circles with recognition of identical circles. 

 

 
Result after a few clicks. 

- Ghost drilling:  
In order to optimize the calculation time, in particular when inserting a component with a huge number of 
holes, it is now possible to create "ghost" drillings. A ghost drilling is a drilling without geometry; it is 
represented by a circular edge centered on its coordinate system and is positioned on the reference face. The 
circle diameter corresponds to the hole diameter. 
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The Ghost drilling mode is only available for holes performed in the tools of a component. 
From the TOOLS SET in the symbolic tree, the Define ghost tool contextual function activates the ghost mode 
using a Boolean parameter (1: ghost mode enabled / 0: ghost mode enabled) which is automatically declared 
as an optional driver. 
Then, when including the component, the Boolean driver is used to choose whether to create the component 
processes in ghost mode. 
 

 
Example of a sheetmetal with a component performing 3500 holes in "ghost" mode. 

Increased performance by more than 50%; the draft is created almost instantly. 

Smoothing 

The WITH A TOLERANCE mode has been added to the face smoothing operation. This mode only asks for the 
faces to be smoothed and a tolerance. Both selection by window and selection by color are now supported. 
The value of the maximum deviation is shown by a point on the surface and a message is displayed in the Alpha 
bar. 
 

  
Example of smoothing with tolerance. 
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Components 

Addition of driver parameters 

The management of driver parameters has been enhanced. Drivers can now be added to a component already 
included in an assembly. 
After selecting a component using the Modify element function, the PARAMETERS option detects that the 
component template contains new driver parameters and provides a new ADD THE NEW DRIVER PARAMETERS 
button. 
Using this button, the new parameters are then directly accessible from the modification window displayed by 
the CONFIGURE SINGLE option. 

Secondary drivers 

To make sub-component libraries easier to create, it is now possible to define secondary drivers. 

Drivers defined as secondary drivers (identified by the icon ) on sub-components can be modified at several 
assembly levels. This allows parameters specific to each sub-component to be used without having to redefine 
them as drivers in the assembly. 
The secondary driver parameter becomes useful only at the second level of inclusion; when a sub-component is 
replaced by another one, secondary drivers specific to the sub-component are then required. 

Tolerances in catalog files 

Values can be entered with tolerances for parameters in the catalog file of a standard component. Just like when 
entering tolerances in TopSolid, the values must be enclosed in brackets; they will be taken into account for the 
operations generated by the component processes. 

 

Tools 

Bisectrix coordinate system 

The new Bisectrix coordinate system function is used to create a coordinate system at the intersection of 
2 planes or 2 directions. 
 

 
Example of a bisectrix coordinate system (in red) created by selecting the directions 

 shown by gray arrows. 
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Dimensioning 

The Type=Angular/Linear option has been added. In the case of parallel or quasi-parallel lines or axes (whose 
angle value is less than 10-6 degrees), it allows you to get an angular dimension instead of the linear dimension. 

Attributes 

Material 

Transparency scales for material definition and those for texture definition have been standardized. In both cases, 
values can now vary from 0 to 10. 

TopSolid’Image 

Light and shadow settings 

When creating a light, settings for light and shadow have been separated to make the configuration easier. 
Moreover, the default values of the different settings (intensity, shadow opacity, shadow diffusion…) have been 
modified in order to provide lights that can be used directly. 

Reduced image calculation 

A new reduced image calculation mode enables you to calculate the selected image (in Global or Partial mode) 75 
or 50% smaller. This allows you to get a preview of your image more quickly in order to adjust light intensities. 

Brightness adjustment 

The new TONE MAPPING mode almost instantly adjusts the brightness of an image once it has been calculated. 
 

  
Brightness adjustment of an image. 

  



TopSolid 2014  What’s new in TopSolid’Design v6.15 

Missler Software  13 

Draft 

Dimensioning 

The Type=Angular/Linear option has been added. In the case of parallel or quasi-parallel lines or axes (whose 
angle value is less than 10-6 degrees), it allows you to get an angular dimension instead of the linear dimension. 

Drilling table 

Drillings can now be filtered according to their diameter/radius values. This mode can be accessed from the 
function’s advanced options. 

 
Filtering by diameter/radius. 

Moreover, the through all and through one holes are now differentiated in the depth column. 

Table export to Excel 

The SEVERAL TABLES option has been added to the Bill of material > Export tables function. It is used to export 
the different types of tables (table, drilling table, dimension table, bill of material,…) from a draft document to an 
Excel document. 
By default, each table of the draft document is exported into a different workbook of the Excel document. The 
names of Excel workbooks as well as the position of tables can be customized by using a template. 

 
Setting window for table export. 

Visualization of differences 

When the File > Properties - Projection parameters - Views create 2d curves option is checked, it is possible to 
view the differences when regenerating a document. Differences are displayed in a specific layer and elements 
that have changed are shown in magenta. 
These differences can now be identified when the document is updated, by also showing the dimensions and 
notes that have been modified. 
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In the tree, the current view and the previous view are respectively stored in the Resulting elements and 
Previous elements sections. In the Previous elements section, elements that are different before and after 
update are visible, others are hidden.  

 
Visualization of differences. 

Title block 

It is now possible to insert a multi-line text (note) in a title block. 
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Interfaces 

VRML import 

The VRML interface has been added. It allows you to import the surface shapes contained in the VRML 
documents and eventually to sew them. 

Step export 

When exporting a document in Step format, a drop-down list now allows you to choose the file extension (STEP or 
STP). 
 
Interfaces have been updated in order to support the following formats: 
 
Interface Supported version 

Import 
AutoCAD 2012 
Acis R24 
Inventor 2014 
Catia V5 (Datakit) 
Catia V5 (Spatial) 

R7 - R23 
R6 – R23 

Parasolid V26 
Pro/Engineer (Datakit) 2000i 

Creo 2.0 
Pro/Engineer (Spatial) 16 – WildFire5 

Creo 2.0 
Google SketchUp 8 
SolidWorks (Spatial) 98 - 2013 
Unigraphics (Datakit) NX8.5 
Unigraphics (Spatial) NX8.5 

  
Export 

Acis R24 
Catia V5 R6 – R23 

 
Parasolid V26 
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This section describes the new features made to TopSolid’Progress in the version 6.15. 

Part preparation 

Deletion of the AutoForm unstamping module (replaced by FTI) 

The AutoForm unstamping option has been removed and replaced by the FTI module. 
Former unstampings or former imported parts which used this option to be recalculated will be replayed without 
change, unless they are explicitly converted into FTI unstamping via the modification command. Additional 
information necessary to the calculation with FTI can then be required (the stamping direction, principally). The 
calculation result may be significantly different. 
Concerning the codes, a FTI unstamping module must be requested in place of AutoForm module(s). 

Improved selection of boundary edges 

New options are available when selecting the boundary edges: 

- Automatic selection of opposite edges to selected edges. 
- Automatic selection of lateral edges. 
- The Cut face option can be used at any time and no longer only at the beginning of the selection. 

 

These options are available in the following commands: 

-  Define guiding edges 

-  Remove a piece of the part 

-  Transform a piece of part 

-  Cut part 

-  Flange unfold 

-  Trim and thicken 

-  Lateral extension 

  



What’s new in TopSolid’Progress v6.15  TopSolid 2014 

18  Missler Software 

Improved Leading surface command  

A new type of surface is available, the Lofted mode, in addition to the existing Swept face and Extend faces 
modes. 
This new mode becomes the default creation mode as it provides better quality surfaces. 

  

Lofted mode Swept face mode 

 
A preview of the surface is now available when creating the surface. 

Strip 

Import part  

When importing a part from a station, several import modes are now available:  

- PROJECT: Profiles of the part selected on the station are projected to create the strip. Only the contours of 
the part edges are shown (internal edges are ignored). 

- DUPLICATE: This mode corresponds to the former import mode. 
- UNBEND: The part of the station is unbent in the same way as a sheetmetal part. 

Flange unfold  

The creation of the automatic surface has been improved. The Lofted, Swept face and Extend faces creation 
modes are available (see Leading surface command). 
It is possible to set an extension direction by point, just as it is possible to specify a unique extension direction.  
 
In the flattening parameters, it is now possible to create the boundary curves corresponding to the boundary 
edges. Especially when the area to process includes internal cuttings, those cuttings will be applied to the result. 
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Part to stamp Unstamping with boundary curves 

 

Improved management of 3D strips 

When creating a 3D strip, a 3D strip set is automatically created. This set allows you to strictly isolate elements of 
the "real" strip (the one which is built), especially for projections in drafts, or the kinematic, from elements used 
to create it. 

This set does not exist when the document is created; it can be created if needed. 
 

Processes 

Manage processability  

In PROCESSABLE mode, the multiple selection has been disabled to prevent handling errors. 

Processes 

It is now possible to delete empty operation folders generated through the creation of a process from the 
construction tree. 
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Components 

Improved Reproduce command  

The tools for selecting target components have been enhanced. Invisible components can now be selected. 

Configuration of components  

It is now possible to copy/paste the default clearances, standard machinings and attributes of a component to 
another component of the standard library. 
 

 

Definition of components 

A new type of process is available in the definition of the TopSolid’Progress standard components. A component 
with a not through countersunk hole can now be created as a process. 

Tools and dies 

Cutting die  

In the Cutting die command, when a circular profile is selected, it is possible to define the dimensions of the 
second part of the die with an explicit diameter value. It allows you to define round values, easier to manage for 
machining. 
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Progressive die kinematic  

The kinematic now takes into account the strips built in inverted direction, with their progression direction along 
x-. 
If the document contains a 3D invert strip, this strip is ignored unlike the "real" strip. 
A strip inserted as a component in a new document is now recognized as a strip in the kinematic of the 
progressive die. 
 

Draft 

Strip view in open views  

It is possible to add the strip projection to all open views by modifying these views. 
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This section describes the new features made to TopSolid’Cam in the version 6.15. 

2D milling 
 Optimization of milling toolpaths (like for drillings). 

 

Turning 
 Automatic synchronizations according to the Operations manager. 
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3D milling 
 New roughing. 

 

 New algorithms for left material machining. 

 Morphing from or to a point. 

 

Verification 
 Collision control with the finish. 
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WCS 
 Information on the work plane and PP words is now provided in the WCS manager. 

 

Parts 
 When including a part (for 3D milling), holes (ejector pin) and/or operations can now be deleted. 

 

 Draft analysis. 
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Shopfloor documents 
 The part views of operations are now in the same direction as the WCS. 

 
Old view: 

 

 
 

New view: 
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This section describes the new features made to TopSolid’Wood in the version 6.15. 

Improved sketches 
Some points of use of sketches have been improved to make sketches easier to use. 

Visualization of curves 

When creating or modifying a sketch, the Show extremities function now makes it easy to view the closed 

contours created within the same sketch.  

- Open contours are shown by two dotted circles at the ends of the contour. 

 

- Closed contours are now hatched. 

Each hatching uses a hatching template and a different color in order to be identified more easily. 
When zooming or moving in the sketch, these hatchings are hidden in order not to overload the view. 
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Parallel contour on the fly 

When drawing a contour in a sketch, it is now possible to directly draw a segment parallel to an element. 

 The function is available from a contour that is 

being created.  
 
 
 
 
 
 
 

 
 
 

 

 Position the cursor on the reference element to 
draw the parallel segment. 

Note: The reference element to draw the parallel 
segment can be an edge of a shape, a segment of the 
current contour or sketch, or a segment from another 
sketch. 

 
 
 
 
 
 

 A new dotted red construction line appears. This 
line is parallel to the selected element passing 
through the last point of the contour. 

 
 
 
 
 
 
 
 
 

 Select a point on this parallel line to draw the 
segment of the contour parallel to the selected 
element. 

A length dimension is created between the 
reference element and the segment of the contour. 
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Segment length 

In a sketch, when drawing a contour, it is now possible to directly enter the length of the next segment. 

 From a sketch, start the Contour function.  

 Click on a first point to start the contour. 

 In the Segment length box, set the length for the next segment of the contour, then press Enter to confirm. 

 
 

 Then click on the passing point of the 
segment. 

 
 
 
 
 
 
 
 
 
 
 

 A length dimension is automatically created 
on the segment with the length you 
entered. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 It is also possible to use the Link = Axes (Z) 
option in order to set the length of the 
segment aligned on X or Y. 
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Rectangle by 3 points 

When drawing a rectangular contour, a new option allows you to draw a rectangle by defining it by 3 points. 

 Select the Contour function , then Rectangular.  

 Select the 3 points option.  

 Select the 3 points to draw the rectangle. 

  
 

  

- If the selected points are vertices, coincidence constraints are created between the corner of the rectangle 
and the selected vertex. 

- The two rectangle dimensions are also created: if the rectangle dimension is constrained by the point 
selection, the dimension is passive (yellow), otherwise it is active (green). 

 

Selection of any point for the third point. 
An active dimension is created to dimension the 

rectangle. 
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Improved Fillet function 

Global fillet 

A new option enables fillets to be created automatically on a whole sketch contour. 

 From a sketch, select the Fillet function.  

 Set Mode = Local/Global. 

The local mode is used to create a fillet on a single selected angle. 
The global mode is used to create the fillet on all angles of the selected contour. 

 Enter the value of the fillet radius, and then select the contour. 

Note: The contour can be an open contour. 

 
 

  

 Then click on the Compute fillet(s) button to create the fillets.  
 
When viewing the fillets in red, yellow circles can be drawn at some angles of the contour. These are angles on 
which the fillet will not be performed. The fillet is not created if: 

- The angle is tangent, in which case a fillet is not necessary. 
- The fillet radius is too large and it is not possible to make the fillet. 
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Interior/Exterior fillets 

It is now possible, on a closed contour, to create fillets with a different radius if the fillet is inside or outside the 
contour. 

 Start the Fillet function.  

 Select the Radius inter/exter option.  

 Enter a radius value for interior and exterior fillets. 

 

 Select the closed curve on which fillets will be applied. 

 

Fillets are previewed in red. Fillet radii can be modified before being applied on the contour. 

 Select Compute fillet(s) to create the fillets. 
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Coordinate systems 

Selecting points to create a coordinate system axis 

When creating a coordinate system, when an axis is required, it is now possible to select two points in order to 
choose as the direction the line passing through these two points. 
This mode may be used when defining the axes manually from the Define part function. 

 

 When selecting an axis for the coordinate system being created, select Through point. 

 

 Select the first through point for the axis. 

 

Note: The selection order of the two points provides the axis direction, but it can be subsequently modified. 

 
 Then select the second through point for the axis. 

 

 

 The red arrow allows you to set the direction of the created axis. Click on the arrow to invert. 

 Confirm the axis direction by clicking on OK.  
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 Create the second coordinate system axis. 
 
The created coordinate system axis (in red below) passes through the two selected points (in blue). 
For the example below, the axis used by the coordinate system is shown by dotted lines. 

 

Bisectrix coordinate system 

A new Plane Bisectrix coordinate system allows a coordinate system to be positioned directly between two 
planes. 
For example, this makes it possible to create mitre cuts between complex parts. 
 

 

 Start the Tools > Coordinate systems function. 

 

 Select the bisectrix coordinate system.  

 Set the Plane mode.  

 Select the face on the first part. 
 
 
 
 
 
Note: The current coordinate system’s planes can be selected using the XY+, XY-… buttons, and planes parallel to 
the current coordinate system’s planes passing through a point can be selected using the Through point function. 
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 Adjust the face direction using the red arrow, 
then confirm by clicking on OK. 

Note: The directions of the two selected faces must 
be identical, inward or outward. The side will be 
used to position the X axis of the coordinate system 
thus created. 
 
 
 
 
 

 Select the second face, and then adjust the arrow direction like the first arrow. 

  

The coordinate system is positioned by default. 

 Select an origin point to position the coordinate system. 

Note: The selected point is projected onto the intersection 
curve of the two selected faces in order to position the 
bisectrix coordinate system. 

 
 
 
 

 Select Quit to finish creating the coordinate system.  
 
 
 
 
 
 
 
 
 

 Perform the cuts on the parts in relation to this bisectrix 
coordinate system using the Shape > Trim > By plane 
function, since the trimming plane is the bisectrix 
coordinate system created before. 
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Drilling improvements 

Drilling on a 2D circle 

A new option to create drillings directly from a 2D circle is now available. This circle can be for example a circle 
from a DXF document or a circle of a sketch. 
The circle diameter will be automatically measured on the selected circle. 

 Start the Drilling function.  

 Select the Coordinate system or sketch option, then the Circles option.  

 Set Merge drillings = Yes/No. 

Note: The Merge drillings = Yes option enables all the drillings to have the same parameters (except the diameter 
specific to each selected circle). 

 Select the circle(s) to be drilled using the selection.  

Note: The different selected drillings must be on the same reference face. 

 Select the reference face of the drillings. 

 Select the drilling model to be performed. 

 Set the drilling parameters, then confirm with OK to create it. 

Note: If the Merge drillings = No option has been selected, the drilling model selection window as well as the 
setting window are opened for each selected circle. 
 

  
 

Note: When selecting the circles to be drilled, it is possible to select two concentric circles. It will then be possible 
to select a spot faced drilling model: the drilling will be performed on the smallest circle and the spot facing will 
be performed on the largest circle. 
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Ghost drillings 

The new ghost drilling allows you to optimize performance on assemblies that use a lot of drilling processes. 
When performing these drillings, the full shape of the drilling is not displayed; only the circle on the machined 
face of the drilling diameter is displayed. 
The Ghost drilling mode is available for holes performed in the tools of a component. 
 

 In the template of the component which must perform the 
drillings, open the symbolic tree, then edit the tool set. 

 
 

 On the line of the tool, right-click > Define ghost tool. 

 

Note: The ghost mode can be set using a Boolean parameter. This parameter is used to enable the ghost mode 
(value 1) or leave the drilling to normal (value 0). 

 

 In the Ghost parameter field, specify the parameter to be used to drive the ghost tool.  
If there are Boolean parameters in the document, they are all available in the Parameter drop-down list. 

 

 Validate the parameter by pressing Enter. 

The drillings contained in the tool become ghost drillings if the ghost parameter is 1. 
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Note: If the tool defined as ghost contains several drillings, all the drillings contained are then defined as ghosts 
with the same Boolean parameter. 
However, it is possible to modify a drilling of a tool locally. 

 
 
 
 
 

 On the drilling to be modified, right-click > Define ghost tool. 

Note: The Reset ghost parameter option is used to remove the ghost option from a drilling or a ghost tool. 

 Select Reset ghost parameter if you no longer want to define this drilling as ghost.  

 

 In the Ghost parameter field, enter the new Boolean parameter to drive the ghost mode of the drilling. 

 
 

 

When inserting this component, it is then possible to perform the machinings in ghost mode. 
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When drafting parts with ghost drillings, drillings will only be visible on the top view of the ghost drilling’s 

reference faces.  
 

 
 

Performance gains 
 
Tests performed on a 2800x2070mm panel with 
4698 drillings in matrix repetition (32mm spaces): 

- X: 81 drillings. 
- Y: 58 drillings. 

 
 

Tests 
In place 

propagation 
File size File 

regeneration 
Export to 

WoodWop 
Component process 

creation 

Normal drillings 19s 5 275 KB 25s 2min 05 18s 

Ghost drillings 7s 759 KB 7s 5s 6s 
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Improved drivers 

Secondary drivers 

Secondary drivers have been created to improve the use of sub-components. 
 
Secondary drivers are defined in sub-components and can then be modified at several assembly levels. This 
allows you to define parameters specific to each sub-component without having to define them in all equivalent 
sub-components. 
The secondary driver becomes useful only at the second level of inclusion. 
 
In the example below, the Width, Height and Thickness parameters are present in all the models. 
On the left-hand panel, the Crosspiece width and Panel number parameters are specific to the model. 
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Parameters must be created beforehand in the sub-components. 

 Open the parameter list using Parameters > Edit list > Document. 

 From the Driver column, define the parameters specific to the sub-component as secondary 
drivers.  

 In the case of Boolean parameters (Yes/No), select Boolean secondary.  
 

 
 
 
 
 
 

 

Note: Secondary drivers can also be defined from the symbolic tree in 
the Entities tab. Open the Parameters list > right-click on the parameter 
to be modified > Define driver > Secondary driver = Yes. 

  
 
 

Secondary drivers are displayed with a yellow +.  
 
 

 In the component, define the sub-components using the Assembly > Define component > Define sub-

component function.  
 
 
 
 
 
 
 
 
 

 
When using the component, it is then possible to interchange the door panel model. 

 Start the Modify element function and select the component to be interchanged.  

 Select Sub-component.  

 Select the sub-component to be interchanged. 

 Select the Interchange option.  

 Select the new standard, then confirm with OK. 
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After interchanging the sub-component, it is proposed in the dialog bar to configure the secondary drivers 
specific to the standard selected for the sub-component. 
 

 
 

 
 
Note: The Secondary drivers = First level/All levels option allows you to select the secondary drivers to be 
configured: 

-  : Used to display only the secondary drivers of the interchanged sub-component. 

-  : Used to display the secondary drivers of all the sub-components contained in the 
interchanged sub-component. 

 Select the secondary driver to be modified in the drop-down list, then enter its new value. 

 Select the Configure single option in order to modify all the secondary drivers in one go.  
 
Note: The First level/All levels option is also available in the Configure single option. 

 
It is also possible to access the secondary drivers of a sub-component without interchanging it. 

 From the Modify element function, select the component to be configured.  

 Select Sub-component.  

 Select the sub-component to be configured. 

 Select the Parameters option.  
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Example: 
 

Oculus: Height and width parameters of the 
oculus. 

Panel: Positioning parameter of the oculus 
and the panel grain orientation. 

Door 

 

  
 

When modifying the secondary parameters of the door panel: 

- The First level option is used to modify only the secondary parameters of 
the panel. 

 

- The All levels option is used to modify the secondary parameters of the 
panel, as well as all the sub-components including the oculus. 

 
 

Improved driver block 

Direction of arrows 

To enable better understanding of the driver blocks, the arrows that symbolize the positioning faces now show 
the inside of the block. 

 



TopSolid 2014  What’s new in TopSolid’Wood v6.15 

Missler Software  45 

Double wrap 

The arrows that symbolize the double wrap of the double-wrapped driver blocks now show the outside of the 

block. Their shape is also changed for a double arrow.  

 

Visualization of hookings on publishings 

Since version 2013, if the positioning face of the driver block has a publishing, the driver block 
hooks on this publishing to enable better interchangeability. 
The hooking of the driver block on a publishing is now shown by a green arrow and a rectangle. 
 

 

Sub-slope driver block 

The new sub-slope driver block allows you to fit out volumes with an angle on the upper part. 
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 In a new TopSolid’Design document, 
start the Assembly > Define 
component > Define driver > Driver 
block function to create the driver block. 

 

 Enter the name of the driver block. 

 From the advanced parameters , set 
Sub slope = YES. 

 In the Angle field, enter the default value 
of the sub-slope angle. 

Note: Here, it is possible to enter a negative 
value to get a slope in the other direction. 
Only a value between -89 and 89° can be 
entered. 
 
 

  

  
 

 Then design the component in the driver block normally. 

 
 
 
 
 
 
 
 
 
 
 

 In the assembly, normally include the sub-slope driver block in the housing with an inclined top. 

 
Note: The sub-slope driver block can be included in Mode = Inside a block or Mode = Housing. 
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The sub-slope component is then calculated automatically. 
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Table text 

The table text is used to vary a text according to two parameters in a table. 
 
For example, in the case of this shelf, two parameters allow you to 
set the thickness and depth of the shelf. 
The table text will then enable you to choose the code of the cam 
to be used according to these two parameters. 
 
 
 

 Start the Tools > Text function. 

 Open the advanced parameters >>, and then select Table text.  

The table text can be set using a table; one parameter is on the table columns and the second one is on the table 
rows. 

 In the Column parameter field, enter the name of the parameter to be placed on the table columns, then 
confirm by pressing Enter. 

 

 In the Line parameter field, enter the name of the parameter to be placed on the table lines, then confirm by 
pressing Enter. 

 
 
The table is then created. 

 In the window that opens, enter the first value for the Column 
parameter, then confirm with OK. 

 Right-click on the column headers to insert, remove or modify 
a column. 

 
 
 
 
 

 Double-click on the first box of the first column to create a new 
value.  

 Right-click on a row to insert or remove a row. 
 

 Then double-click in each box of the table to enter the text to 
be displayed when the conditions of the row and column 
parameters are met. 

 Validate the table by clicking on OK. 
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 Click on an alignment point to position the text. 
 
The text displays the value defined in the table according to the values of the row and column parameters. 

 
 
In case this text must then drive a code or a sub-component variant, simply define the component as a sub-
component. 

Library update 
The Update libraries function has been enriched with a new function to regenerate the updated files. 

 Start the File > Update libraries function.  

 Set Regenerate files = YES, then confirm by clicking on OK. 

 
 
It is recommended that you save the library to be updated beforehand. 

 After saving, confirm the warning message with Yes. 

 Select the folder that contains the library to be updated, then confirm by clicking on OK.  

The TopSolid’Design files contained in the library are then opened, updated, regenerated, saved, and then closed. 
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Component distribution 

Gap management between each component 

A gap management is now made directly from the component distribution. This makes it possible to generate a 
free interval between each distributed component. 

When setting the distribution parameters, the Gap field is used to set this interval between each component. 

 

 
 

This parameter can then be modified using the Modify element function  on 
a distributed component, then select Distribution parameters. 

 
It is also possible to access this parameter by editing the distribution from the 
symbolic tree. 
 
Additional coordinate systems are also generated in the distribution:  

- One before each component (in blue below); 
- One in the middle of each generated interval (in green below). 

Note: These coordinate systems are hidden by default. Click on Inv=Hid in the status bar to display them.  

 

These coordinate systems are used to place components in the gaps. 
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If a component is placed using a key coordinate system on one of the gap coordinates systems (in green on the 
previous page), it will then be possible to repeat it automatically in each generated distribution gap. 

 Include the component in the distribution assembly. 

 Set the width parameter of the component to the gap value. 

 Place the key coordinate system of the component on one of the gap parameters. 

 Select the Repeat option , and then Serial copy.  

 Select the Automatic option.  

Note: If the Automatic option is not available, it means that the component is not positioned on one of the 
distribution gap coordinate systems. 

 If the component contains tools, select Automatic in order to perform them. 
 
Note: A serial component is then generated in the distribution gaps. 

 

If the distribution is modified and the number of gaps changes, the serial copy is used to automatically update the 
component quantity. 
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Empty space management 

When the Distribution mode = Mark out is used, each component is generated to the value given in the 
parameter and the adjustment is made on the last component. 
It is then possible not to generate this component in order to create an empty space using the Fill out mode = 
Void. 

 
 

 
 

The value of this empty space can now be recovered thanks to a parameter that is 
automatically calculated from the distribution edition in the symbolic tree. 
This Space parameter, which can be named to be used in the assembly, is then 
automatically updated after the distribution parameters are modified. 
 

Management of components with minimal value 

When the Distribution mode = Mark out is used, each component is generated to the value 
given in the parameter and the adjustment is made on the last component. If the length 
parameter used in the component distribution definition has a minimum value, the last 
component is not generated if its length is less than the defined minimum value. 
 

 In the component used for the distribution, define a minimum possible value on the 
parameter used in the distribution positioning. 
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If the space of the last component is greater than the minimum value, the last component is generated. 

 
 
 
 
 
 
 
 
 

 
 
 

 
However, if the space of the last component is less than the minimum value, the last component is not generated, 
an empty space is created and the value of the Space parameter is calculated. 
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TopSolid’Wood 

Integration of the Hettich 3D component library 

Hardware components of the Hettich catalog now come directly with TopSolid’Wood. 
Based on the same principle as the Blum hardware components, this library contains 
the 3D geometries of Hettich hardware components to allow more convenient integration and use in 
TopSolid’Wood. 

 From the installation of the 2nd TopSolid DVD, select Hettich Hardware Library. 

 

An installation of about 1,1GB will be downloaded. 

 Then install this application on the TopSolid’Wood station. 

The Hettich Hardware library will then be available from the standards.  

 
 
 
 
 
 
 
 

Edges and laminates 

Edges automatically modifiable in assembly 

A new option enables you to make all the created edges automatically modifiable in the assembly. 

 Open the options using Tools > Options. 

 Open the TopSolid’Wood configuration > Edge/Laminate section. 

 Check the Set edges modifiable in assembly box.  
 
As a result, when creating edges (Panels, Edges or Edge wizard functions) the created edges will be automatically 
defined as modifiable in the assembly. 
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Laminate notes in TopSolid’Draft 

When drafting laminates or laminate panels, a new function makes it possible to place notes on the laminates to 
display some specific information. 

 From the draft template document, open the document properties.  

 Open the TopSolid’Wood properties > Draft section. 

 In Elements to dimension, check Laminate dimensions.  

 Then open the Laminate tab and configure the elements to be displayed in the laminate note.  
 
Creation of laminates on a panel: 

 
 
Characteristics of the laminate: 

 

 When creating the draft, start the Wood > Laminate dimensions function.  

 Select the laminate to dimension, and then place the note. 

Note: By default, the information displayed in the note is that which is set in the document properties. 

 Click on the Informations to print in laminate dimensions button to modify the information to be displayed. 

 
 

 
 
Note: Laminate dimensioning cannot be made automatically when multi-drafting panels with laminates.  
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Modifying the part grain orientation of a component 

Modifying the grain orientation of a part is now possible in the assembly. 
This modification allows the part axes to be inverted, just like with the Invert axis button when defining an in-

place part.  
This rotation can be driven by a Boolean parameter, making it possible to invert the axes of several parts using 
the same parameter. 
 
Note: The grain orientation of a part can only be modified if: 

- The part has been predefined and the Add to cutting-up box is checked. 
- The dimensions are in Respect axis mode. 

 Open the symbolic tree. 

 Open the Main set tab. 

 Select the part(s) to drive in the assembly. 
 
Note: It is possible to select several parts by holding down the Ctrl key. 

 Right-click > Drive grain orientation. 

 

 Set Drive grain orientation: YES. 

 In the Condition field, specify the Boolean parameter to be used to invert the grain orientation: 

- If the Condition = 1: The grain orientation is rotated 90°. 
- If the Condition = 0: The grain orientation remains as defined by the axes. 

 
Note: The drop-down list is used to select an existing Boolean parameter directly. 

 

 Confirm the dialog by clicking on OK. 
 
As a result, modifying the parameter (in place or in the assembly) inverts or not the grain 
orientation on part(s) driven by this parameter. 
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Forcing the grain orientation 

It is also possible, in the assembly, to force the grain orientation of parts already driven by a parameter. 

 In the assembly, open the symbolic tree. 

 On the part where the grain orientation must be forced, right-click > Force grain orientation.  

 

 Set Force grain orientation = YES. 

 

 Enter the value 1 to rotate the part grain orientation and the value 0 for not rotating it. 

Note: Here, it is possible to specify a parameter of the assembly to drive the part grain orientation. 
 
The part grain orientation is then forced and will no longer follow the modification of the model’s driver 
parameter. 
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Define multiple parts 

Modifying the BOM depth 

It is now possible to modify the depth of the BOM displayed from the Define multiple parts window. 
The three BOM display options are then available: 

- Flat BOM 
- At top level 
- Multi level 

In Multi level mode, the Expand all and Collapse all buttons are used to expand or collapse all the nodes of the 
BOM. 

 

BOM sorting of the Define multiple parts 

It is now possible to sort the part list displayed in the Define multiple parts window in ascending or descending 
order according to a column of the BOM. 

 On the column to be sorted, right-click > Sort in ascending/descending order. 

Description management 

Descriptions are now managed from the Wood > Define > Define multiple parts function. The same description 
can be assigned to several different parts in one go. 

Column width management 

The column widths displayed in the Define multiple parts function can now be set by default. 

 From a Design document, edit the BOM file used for the Define multiple parts function using the Tools > Edit 
bom file function. 

 Modify the width values of the 
different columns. 

 Validate the BOM file with OK. 

 
 
 
 
 
 
When using the Wood > Define > Define multiple parts function, the column width is set according to the BOM 
settings. 
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Define part 

Machining and drawing default settings 

The Define part settings for machining and drawing can now be set by default in 
the options. 
These settings will be taken into account when defining new parts.  

 

 Open the new Define part settings using Tools > Options > TopSolid’Wood 
configuration > Define parts. 

 
 
 

 Set the default values to be used for the Machining  and Drawing  tabs. 

  

 Validate the options with OK.  

When defining new parts, the settings of the Machining and Drawing 
tabs will be those configured in the Tools > Options function. 

 
Note: Changes can be made to the default settings of the Machining 
and Drawing tabs from the Define part window. 
Then, when defining new parts, the default settings will be those 
configured from the Tools > Options function. 
 

Interface of the Cutting-Up and Machining tabs 

The Cutting-up and Machining tabs of the Define part window have 
been modified to provide better access to the functions and reduce 
the height of the window. 
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WoodWop interface 

Optional machine configuration 

The machine to be used for the WoodWop machining export can now be configured for all exports. 

 Open the WoodWop export options using Tools > Options > TopSolid’Wood configuration > Machining > 
WoodWop configuration. 

The Machine drop-down list allows you to use a specific machine for export. 
 
Note: Selecting a specific machine makes it possible to change 
some points of the export format in order to match the machine 
used in WoodWop. 
 
 

Milling lead in mode management 

Two new configuration words have been added to enable an advanced configuration of the lead in mode of part 
calibrations in WoodWop. 

Note: The configuration words are to be inserted in the topzwood.cfg file used. To know the location of this file, 
start the Help > Configuration function, and then open the TopSolid’Wood tab. 

Calibration origin in the middle of a segment 

ZX_ZWOO_CAM_CALIBRATION_CHANGE_ORIGIN 1 
 
At the value 1, this configuration word enables the starting point of a part calibration to be placed in the middle 
of a segment of the calibration. 
 

 

Modifying the calibration lead in distance 

ZX_ZWOO_CAM_MPR_CAL_DISTANCE  0.050 
 

 Enter a value in meters to set the lead in distance of a part calibration. 
 

 
 
 
The calibration lead in distance is available in WoodWop only on a closed calibration, if the Entry and Exit modes 
are vertical and if the Plunge is enabled.  
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Nesting: Customization of the displayed text 
It is now possible to customize the text displayed on the parts of a nesting. 

 

The text font can be customized using the Tools > Options > Nesting > Nesting default parameters > 
Identification command. 

 

The text can be customized via a Wood codification named WOO_NESTING_IDENTIFICATION in the BOM file 
used to sort the parts. 

Note: For additional information on using the Wood codification, refer to the Wood codification documentation. 

 

The Wood codification above will display the part designation, the set designation, as well as the part identifier. 

 Open the options using Tools > Options. 

 Open the TopSolid’Wood configuration  > Files  > Parts selection sorting section. 

 Double-click on the Automatic nesting line, and then select the BOM file with the 
WOO_NESTING_IDENTIFICATION. 

 Confirm the options by clicking on OK. 
 

 Perform the automatic part nesting. 

The customized text is then displayed. 
 
Note: The text follows the rotation of the part. 
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TopSolid’Image 

Reduced image calculation 

A new reduced image calculation mode makes it possible to calculate the selected image (in Global or Partial 
mode) 75 or 50% smaller. This allows you to get a preview of your image more quickly in order to adjust light 
intensities. 

 Start the Image > Display function. 

 Set Size = 50%/75%/100%. 

 Launch the image calculation by clicking in the document’s graphical area. 

 Save the image with a right-click > Save/Save as. 

 
Time for a calculation in Quality = 3 and Radiosity = 3: 
 
Calculation in 50% Calculation in 75% Calculation in 100% 

 

 

 
 

Brightness adjustment 

A new mode allows you to adjust the brightness of an image once it has been calculated. 

 Start the Image > Display function. 

 Set Adjustment = Tone mapping. 

 

 Launch the image calculation by clicking in the document’s graphical area. 

Once the calculation is completed, when the image is displayed, a Tone mapping 
window opens. 
 

 Move the slider using the mouse to adjust the brightness of the calculated image. 

 

 

 Validate the Tone mapping by clicking on OK. 

 Save the image with a right-click > Save/Save as. 
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Improved light definition 

When creating a light, settings for light and shadow have been separated to make the configuration easier. 
Moreover, the default values of the different settings (intensity, shadow opacity, shadow diffusion…) have been 
modified in order to provide lights that can be used directly. 
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This section describes the new features made to TopSolid’WoodCam in the version 6.15. 

Part holding 

Vacuum blocks for flat table 

A new function is available to manage the positioning of vacuum blocks on a flat table. 
It enables you to create an operation for positioning the blocks in order to send their coordinates via the post-
processor when the CNC control is equipped with a laser positioning system. 

Activating this new function: 

 Position the blocks on the machine table: 
Use the Assembly > Include standard function. 

Note: A component is available as standard in the TopSolid’WoodCam library for example (TopSolid’WoodCam > 
Machines > Pods > Vacuum block). 

 

 

 Define the vacuum block set: 
Use the Part > Flat table vacuum blocks > Create/modify set blocks function. 
Select the definition origin and the blocks to be taken into account in the operation. 

 
 

 Create the positioning operation for vacuum blocks: 
Use the Part > Flat table vacuum blocks > Create a positioning blocks operation function. 

Note: A part must be positioned on the machine to be able to create the operation. 
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This operation can then be edited from the list of operations with a right-click > Edit. 
Editing this operation allows you to switch between the blocks origin and the machine origin. 

 
 
It is also possible to display the position of blocks as a table in a setup sheet. 

 
 
Note: In order to save time, it is possible in the machine template to first insert the blocks and then create the 
vacuum block set. Then you just need to correctly position the blocks under the part and remove those that will 
not be used before creating the vacuum block positioning operation. 
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Improved rails and pods positioning 

Exterior margins are now taken into account for the rails and pods positioning under the aperture scraps using 
the two options for extremities. 

 
 
Result in version 6.15: 
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Nesting machining 

Multi-part remachining after nesting 

During the multi-machining process of a nesting, TopSolid’WoodCam v6.15 turns over each part with operations 
on its side and bottom faces one by one. This automates the remachining of parts which have not been fully 
machined during the first machining phase of the nesting panel. 

  
 
Note: This automation of the machining is based on CAD part definition. All settings of the Machining tab will thus 
modify this part remachining process. 
(Two files if necessary, Lateral operations in second machining file, First and second positioning…) 

Warning: The positioning for the part-by-part remachining is based on the stock of the CAD part definition. This 
means working with length and width overvaluations equal to zero. 
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Optimization by operation priorities 

It is now possible to follow the machining order of operations defined in CAD to machine a nesting. To do this, a 
new option is available in the nesting analysis. 

 
 
Note: This sorting option by priorities can result in non-optimized tool changes and rapid movements. 

Remachining of straight angles 
The multi-contouring has been enriched with a new option to go up in the corners. 
This enables the straight angles to be machined directly in the multi-contouring in a single operation. 
The Clearence method in straight angles option is available in the Main tab of the contouring operation. 
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Optimization of milling toolpaths 
The 2D optimization now takes into account the start and the end of open curves to calculate the nearest 
toolpaths. 

Without optimization: 

 
 
With optimization: 

 
 

Design properties available for setup sheets 
The custom properties of design documents (File > Properties in a *.top file) can now be edited in a setup sheet. 
In previous versions, only the properties of machining documents were retrieved. 

Note: The edition of the template does not propose these properties because at this stage of the document 
template definition TopSolid’WoodCam does not know yet which properties will be present in relation to the 
design file used. Detailing texts must therefore be created manually in order to enter the desired text. 
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Example: 

 In the .top file, user information setting via File > Properties: 

 
 

 In the setup sheet template, creation of texts with the prefix "$FINISH_": 

 
 

 Result after generating the setup sheets: 
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New Elem.FamilyKeyRef variable in the PDB 
The new Elem.FamilyKeyRef variable is used to provide the name of the spindle family when defining a machine. 
This variable is now available in the PDB. This allows you, for example, to manage the plunge of drilling blocks of 
some machines (Example: Holz-Her). 

Note: This new variable does not take into account the name of spindle families that have been created before 
the version 6.15. The new name must be rewritten or tool units must be reset so that the name is displayed in the 
PDB. 

Warning: Resetting the spindle families reassigns their default name. 
(Example: routing unit for TP1). 

 

Displaying PP words and work planes in the WCS list 
New information is now available in the Work Coord. Syst. > List command: 

- PP words 
- Work plane 
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Automatic creation of frames 
It is now possible to deactivate the automatic creation of frames when positioning the parts. 
This is very useful for the machining of complex-shaped parts or parts coming from a STL file import. 
This option is available in the Misc > Machines > Misc modifications command and is used to position parts with 
a lot of faces more quickly. 

 

ISO process 
The ISO process function directly runs the ISO program writing when the post-processor is already associated 
with the machine. 

Machining time 
During a multi-machining, the log displays the total machining time for the project. This time results from adding 
up the machining time of all the treated parts. 
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Online help 
The online help has been completely rewritten to enable better clarity and understanding. 
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What’s new in TopSolid’Planner & TopSolid’Quote v6.15 
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This section describes the new features made to TopSolid’Planner and TopSolid’Quote in the version 6.15. 

Panel brushes in the project settings 

The TopSolid’Planner project settings allow you to preconfigure a project before starting it. 
These settings are used to set the parameter values, select the sub-components and materials, and now configure 
panels (matters, edges and laminates). 

 Create a new Design document.  

 In this document, create a panel on any part.  

 Create a panel brush.  

 In the Panel(s) box, select the panel created before. 
 
Note: To be able to configure the panels in the TopSolid’Planner project, the panel brush must have the same 
name and use the same panel categories as the brushes to be configured in the TopSolid’Planner products. 

 Rename this brush the same way as the one in the product included in the project. 

 Also select the same panel categories. 
 
Example: This TopSolid’Planner file has a panel brush named Side panel 
which uses the TSW-Panel-front-right-edge panel category. 
 

 
 
 
 
 
 
 
 
In order to configure these panels using the project settings, the brush created in the configuration file is named 
Side panel and uses the TSW-Panel-front-right-edge panel category. 
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 To modify the panel material for the setting 
file, right-click > Modify on the Support 
material categories line 

 Without making any changes, confirm the 
categories used by clicking on OK. 

 Select the material category and the default 
material to be configured. 

 
 
 
 

 Repeat this operation to configure the default edge 
and default laminates to be used. 

 
 
 

Note: In this configuration file, it is possible to create several panel brushes in order to configure several ones by 
default. 

 

 Save this file in the Configuration folder and rename it topzcfgagc_ConfigName.top. 
 

 Create a new TopSolid’Planner project.  

As there is at least one configuration file, the Project settings window opens. 

 Select the configuration you want in the 
Configuration drop-down list. The 
parameters and sub-component, 
material and panel brushes created are 
then included in the different tabs. 

Changes can be made to brushes before 
starting the project. 
 
 
 
 
 
 
 

 Then insert elements in the project. 

Panel brushes of inserted elements are then directly configured when inserted in the 
project. 
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It is then possible, without modifying the panel brushes, to design two different projects. 
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Improved ergonomics 

Optional parameters 

The optional parameters of a component are now available in the Optional parameters tab of the Advanced 
mode when the component is configured. 

The component must have Optional 
parameters and/or Boolean optional 
parameters. 
 
 
 
 

 When configuring the component in the TopSolid’Planner project, open the Advanced mode. 

 Open the Optional parameters tab. 

 
Optional and Boolean optional parameters are then available. 
It is also possible to share them if the TopSolid’Planner document 
contains parameters. 

 
 
 
 
 
 
 
 
 

Navigating between parameters 

The navigation between parameters has been improved when configuring a component from TopSolid’Planner: 

- A left-click in the Value box directly edits the parameter. 
- The Tab key is used to validate the parameter being edited 

and edit the next parameter. 
- The Enter key is used to validate the value being edited. 

 
 
 
 
 

Online help 

The new TopSolid’Planner online help is now directly available from the icon bar.  
An online help tailored to TopSolid’Planner client functions is also available from a TopSolid’Planner client. 
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Improved draft 

Draft template 

It is now possible to create TopSolid’Planner draft templates. 
When creating a draft, the draft template to be used can be selected. 
 

 Create the different TopSolid’Planner draft templates. 

 Save these files in the Planner sub-folder of the Configuration folder. 

Note: The name of the draft template file will be the name displayed in TopSolid’Planner when selecting the 
template. 

 

 From a TopSolid’Planner project, launch the Draft function.  

If there are several draft files, they are all displayed in a drop-down list. 

 

 
Note: If only one draft template is available in the configuration, it is automatically selected. 
If no draft templates exist, the TopSolid’Planner default draft template is used. 

 Select the template to be used in the drop-down list or confirm with OK if the template you want is the first 
one in the list. 

The draft of the TopSolid’Planner project is then created. 
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Creating additional drawings 

Additional drawings can now be created in a TopSolid’Planner draft. 
These drawings are then created from a project view, but it is possible to trim this view. 

 From the TopSolid’Planner 3D project, open the Draft  tab, then select the Trimming curve function. 

 
 Draw the curve enclosing the element to project. 

Note: The curve must be closed. 

- The Stop option is used to close the curve directly.  

- The Right angle option is used to draw horizontal or vertical lines.  

- The Free option is used to draw any lines.  

 Enter a length in the Segment length box, and then confirm with Enter to set the length of the drawn 
segment. 

 

 

- The Rectangular option is used to create a rectangular trimming directly.  

 

 Enter the name of this trimming, and then click on OK to confirm. 
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 From the draft document, select the Drawing function.  

 Set the hook point of the new drawing, then click on a point in the draft to position the new drawing. 

 
 

 

 Select the direction to be used to draft the project. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Select the Stop button to draft the whole project according to the selected direction. 
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 Select the Trimming curve button to trim the view 
to a curve you drew earlier. 

 

 From the Trimming curve drop-down list, select 
the trimming curve to be used. 

 
 
Note: You can also click on one of the trimming curves 
directly from the 3D project. 
 

A new view is then created according to the selected direction. 
This view only contains the elements inside the trimming curve. 

 
 

 Select the New drawing option to create a new drawing.  

Select the Quit option so that no new drawing is created.  

 

Fit screen and zoom on drawing 

Two new functions are now available from the TopSolid’Planner context during drafting in order to improve 
navigation within the document. 

Fit screen 

 Click on the Fit screen icon  to perform a global zoom on all drawings included in the draft document. 

Zoom on drawing 

 Open the Zoom tab icon and select the Zoom on drawing function.  

 Select a drawing of the document in order to zoom in on the drawing. 

 Select another drawing to zoom in on it. 

 Exit the function by clicking on Quit.  
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Note 

The Note function has been added to TopSolid’Planner in the draft. 

 From a TopSolid’Planner draft document, select the Note icon.  

 Enter the note text in the Texts field. 

 

 Set the note parameters, then click on OK to confirm. 

 Position the note on a drawing with a left mouse click. 

 Select the elements to be indexed by left-clicking, then confirm with the Stop button.  

 

 Select the No leader option  so that no index is positioned with the note. 

The Note function will automatically restart to position a new note. 

 Exit the function by pressing the Esc key so that no new note is placed. 
 
Notes:  

- Note default setting values can be set in Tools > Options > Text/Note > Attributes/Initial values. 
- To set the Creation layer and the Text height, the document properties must also be modified in File > 

Properties > Text/Note. 
- Predefined note texts can be created in Tools > Options > Text/Note > Predefined texts/notes. 

- As TopSolid’Planner does not use layers, it is recommended to select Creation layer: No fixed layer. 
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Miscellaneous 

Ground projection 

Grounds are now projected in the 
TopSolid’Planner draft views. 
 

 
 
 
 
 
 
 
 
 

 
 

Note: However it is possible not to project grounds during the TopSolid’Planner drafting by creating in the 
template views an exception that excludes all elements with the Ground designation. 
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Improved scale factor calculation 

During the TopSolid’Planner drafting, the scale factor is now calculated in order to provide views that are more 
adjusted to the drawing. 
 

 
 
Note: Scale factors are calculated based on the drawing dimension, as well as 
the dimension of the view(s) and title block. 
 
A scale factor nearest lower to the calculated one is selected in the Scale factors 
list. 
This list is available in a Design document > Tools > Options > Multi-draft > 
Scale factor. 
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TopSolid’Planner client administration tools 

TopSolid’Planner library export 

When generating the TopSolid’Planner client installation, it is now possible not to export the libraries provided 
with TopSolid’Planner: 

- Decoration 
- Document template 
- Textures 

 From the TopSolid’Planner context , start the administration tool.  

The TopSolid’Planner libraries are installed during TopSolid’Planner client installation. 

 Open the Generation section.  

 Open the Configuration tab.  

 Uncheck: 

- Include decoration library so that the decoration library is 
not exported. 

 
 
Note: Excluding the TopSolid’Planner decoration library allows you 
to save about 200Mb. 
 

- Include template library so that document templates are not exported. 

 

 

Note: If the document template library is not installed and the component libraries do not contain document 
template libraries, it will not be possible to create new projects on the TopSolid’Planner client station. 

 
- Include textures library so that the Coating wall and floor 

textures and the Colour chart are not exported. 

 
 
 
 
 
 
 

 Then generate the TopSolid’Planner client installation normally. 

 

When installing TopSolid’Planner on the client station, the unchecked libraries will not be installed.  
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TopSolid’Quote 

Setting the quotations in Tools > Options 

Quotation parameters have been relocated in Tools > Options to have a more optimized organization of 
functions. 

  From the Tools tab, start the Options function.  

The Conditions of sale, Currencies and exchange rates, Bill of material and Reseller 
options are then available. 
 
Note: Depending on the license used and the rights of the TopSolid’Quote user, these functions may not be 
available: 

- TopSolid’Quote base license: the Bill of material options are not available. 
- TopSolid’Quote base license + non-admin user: the Conditions of sale, Currencies and exchange rates 

and Reseller options are not available. 

Real image in TopSolid’Quote 

When sending a project to TopSolid’Quote, it is now possible to generate previews of products in the project. 
This will display in the quotation images of products as they have been configured with their materials, 
dimensions, edges, etc. 
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Configuring the components 

Note: In order not to generate images on all components of the TopSolid’Quote bill of material, images are only 
generated on components with specific presentations. 

 Open the library component for which an image must be generated. 

 Configure the view  and the rendering  to be used to generate the image. 

 Start the Tools > Presentation function. 

 

 Rename this presentation BOM, then click on OK to confirm. 

 

Note: This presentation allows you to set the camera and the rendering mode used when 
generating the image. 
If this presentation does not exist in the component, the image is not generated. 

 Save and close this file. 

Configuring the BOM 

 Using a text editor, edit the BOM model file used by TopSolid’Quote. 

 Insert the following function after the last function: 
NAME=IMAGE 
"DEF=<IMAGE_PATH|FILE|IMAGE=4>" 
TYPE=STRING 
ALIGN=LEFT 
TITLE_ALIGN=LEFT 
WIDTH=0.015 
VISIBLE=YES 
; 

 Then insert the text ,IMAGE after the GROUP_BY and ORDER_BY lists. 

 

 Save and close the BOM model file. 
 

 Launch TopSolid’Quote. 

 Open the BOM parameters using Tools > Options > BOM.  

 Click on the Load a bill of material model file button, then select the previously modified BOM file.  

 Match the TopSolid’Quote picture path to the IMAGE column of the BOM. 

 

 Confirm the parameters with . 
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 Apply the new BOM to the existing catalogs using the Copy BOM parameters to some catalogs function.  

 Select the catalog to which the BOM must be applied, then confirm with . 

Creating the quotation 

 From the TopSolid’Planner project, generate the quotation.  

Note: A folder with the name of the TopSolid’Planner project is created in the project folder. 

This folder contains a pngs sub-folder in which images are stored. 

 From the Priced bill of material tab of the quotation, the path of the image thus generated is shown in the 
Image column. 

 

 Launch the Make a quotation function.  

The real previews of products are shown in the product summary 
of the Quote detail. 

 
 
 

 Launch the Quote preview function.  

The real images generated are then used for product previews. 
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Multi-user management 

Working in Client/Server mode (used to create quotations on a database shared by several TopSolid’Quote 
stations) has been improved to help increase data security. 

- Refresh quotations list  

When several users work on the quotations, the Refresh quotations list function updates the quotations and 
shows: 

o The new quotations (or the new versions); 
o The deleted quotations; 
o The quotation status changes. 

 

- Edit/Delete a quotation 

Editing and deleting quotations has been secured in order not to be able to edit or delete a quotation opened by 
another user. 
The message indicates the user who is editing the quotation, as well as the computer to which he/she is 
connected. 
 

 
 

Note: When a quotation is being edited by another user, it is also impossible to create a new version of this 
quotation. 

 
- Edit/Delete customers 

Editing and deleting customers has been secured in order not to be able to edit or delete a customer that is 
already being edited by another user. 
 

 

Moreover, if a user tries to edit/delete a customer that has already been deleted by another user, a message is 
displayed to indicate that this customer no longer exists and the customer list is refreshed. 
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- Connection to a user account 
If a user account is already used on another TopSolid’Quote station, using, deleting or modifying this account 
from another station has been secured. 
 

 

Displaying the product summary 

A summary of the product selected in the quotation is now displayed. 

 From a quotation, open the Quote detail tab. 

 Select a product in the basket. 

A new zone below the basket displays a summary of the 
selected product, including: 

- Designation 
- Supplier 
- Catalog 
- Preview 
- Comment 
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What’s new in TopSolid’SheetMetal v6.15 
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This section describes the new features made to TopSolid’Sheetmetal in the version 6.15. 

General 

Machining parts search – New function 

Function use 

Simplification of the Search machining parts 
function. 

Activating the function 

A new button has been added: Add the selection 
of parts in tasks manager. 

 Make your selection and press the button. 
 
 
 
 
 
 

Insert parts – Select multiple files 

Function use 

In the Insert part function, the Explorer, Search and 
Select from tasks manager functions allow you to select 
multiple files. 

Activating the function 

 Insert part function, use (for example) the Explorer 
function. 

 Select multiple files. 

The first part of the selection appears when the mouse 
hovers over it, the other parts of the selection appear in 
the thumbnail previews. 
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Ergonomics – Delete – Modify  

Delete Function Example on the punching menu 

New options have been added in the combo. 
 
Option to delete the following directly: 

- stops 
- trap doors 
- unloads 
- micro-attaches 
- punched attaches 

 
 
 
 
 

Example on the cutting menu 
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Improved detection on evacuation functions 

After having refreshed the sequence view 

using the  function, the last strike of the 
sequence concerning the evacuation can 
now be detected as well as the text. 
 
 
 
 
 
 
 
 
 
 

 

 

Improved view of micro-attaches and punched attaches 

Option to view a dashed circle around the attaches. 

Activating the function 

 Adjust the settings in Tools > Options > Display Options > Sequences. 

 Check the Draw circle around micro attach box. 

 Enter the attach height multiply factor. 

 
 

 To delete the micro-attach, proceed as follows: 

- Delete . 
- Select Micro attaches from the list. 
- Click on the circle around the element. 
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Improved Modify function  

After having refreshed the sequence view, with the evacuation modes now detectable and micro-attaches easily 
distinguishable, it is possible to click directly on the STOP, for example, to change it without having to change all 
of the machining. 

 

Example of changing the STOP with the possibility to directly change the clearance values. 

 

By clicking on the trap door status text or symbol, it is possible to directly change the shift or the position of the 
trap door. 

 

Example of changing the TRAP DOOR. 
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For machines able to unload parts, by clicking on the text, the system displays the vacuum lifter and prompts you 
to select or change the positions of the vacuum cups. 

 

Example of changing the UNLOAD. 
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Ergonomics – Creation of micro-attaches 

Function use 

Modification of the micro-attach creation function 
to make it more flexible to use. 
 
 

Using the function 

Now, the choice of the position of micro-attaches is offered by a COMBO. 
 
The status of the combo as well as the most common values are stored during the session. 
 
Entry fields such as "Position value" or the number of micro-attaches distributed are directly accessible. 

 
 

 

Positioning by "distribute on contour" 

 
Additional options are available with the >> button. 

 

Additional options 
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Tasks manager 

Cancel a waste (extracted) 

Function use 

In the tasks manager, you have the option to cancel an extracted 
waste in order to return to the nesting as it was before the 
extraction was carried out. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Activating the function 

 Use the wrench, click on . 

 Select Cancel extracted waste from the drop-down list. 
 
 
 

 
The sheet returns to its original size. 
The waste marking text as well as the waste have also been removed from the matters to use in the tasks 
manager. 
 
Note: It is possible to use the Undo function. 

  



TopSolid 2014  What’s new in TopSolid’SheetMetal v6.15 

Missler Software  101 

Manual nesting (from the Tasks Manager) 

Function use 

Option, with a new function, to manually nest parts from the Tasks Manager. The quantities of parts as well as the 
sheet are managed by the manager. 

Activating the function 

 From the Tasks Manager, in the 
Parts to machine tab, check the 
parts to be nested that must 
imperatively have the same matter 
(or the same type of matter), the 
same thickness and be machined 
on the same machine. 

 

 In the Matters to use tab, check at least 
one entity with the matter and thickness 
of the previously selected parts. There 
may be other entities checked that do 
not have the characteristics of the parts. 

 Specify an order name and check the 
boxes for the automatic numbering of 
orders (or automatic numbering of 
nestings). 

 

 Press the Manual Order button. 
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In the case where there are several 
matters selected (having the 
characteristics of the parts), a dialog 
box prompts you to choose the exact 
nesting sheet. 
 
 
 
 
 
 
 
 
 
 
 
A new nesting document is created 
on the given machine and with the 
desired sheet. 
In the case of a non-rectangular 
sheet, the option to make it 
symmetrical and/or turn it is given. 
Parts are inserted from the thumbnail 
previews. 
 
 
 
 
 

 Once manual nesting is complete, manually check the nesting so that the quantity of manually nested parts is 
decreased in the Manager and that the sheet is also decreased in the Matters to use tab. 

The order appears in the Orders done tab. 
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TopSolid’Punch – Punching 

Maximum overflanking for automatic punching 

Function use 

Option to define a maximum overflanking value for machining on lines. 

 
 

Activating the function 

 Go to Menu > Tools > Options > Punch > Automatic allocation > Adjustments. 

 Go to the Lines > Allocate section. 

 Enter the chosen value into the Maxi. tool width field. 

Manual punching – Automatic tool mounting 

Function use 

Option to automatically mount a tool 
selected from the list on the turret 
throughout the manual machining function. 
The turret will remain in manual mounting 
for the other tools. 

Activating the function 

 Tool box list: tick the Mount this tool 
automatically if necessary box. 

 
 
 

Note: The checkbox status remains the same throughout the TopSolid session. 

  



What’s new in TopSolid’SheetMetal v6.15  TopSolid 2014 

104  Missler Software 

Management of ZN35 tools 

Function use 

Option in tool management to define a priority security area in relation to that of the station where the tool is 
mounted. This function has been developed for ZN35 tools which are intended to strike in an area closer to the 
clamps than traditional tools, avoiding a clamp-shift. 

Activating the function 

 Tools management > check the Clamps zone box. 

A dialog box opens allowing access to the accessibility area of tool parameters. 

 

In this example, only the height has been entered. Other values that have remained at 0 will be defined by the 
station Management > Machine > Stations definition > Station accessibility area. 
 

The parameters will be: 

- a=97 
- b=97 
- c=97 
- d=97 
- h=35 
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Management of the Deburring function 

Function use 

Option to carry out deburring 
of a geometry of the part 
already machined with a tool. 

Activating the function 

 Adjust the relevant tool 
settings in Management > 
Tools 

The new Deburring feature is 
available for round, square 
and rectangular tools. 
  

Symbols 

In contrast to other machinings, 
deburring is drawn in cyan blue 
with the shape of the tool (round, 
etc.) at the beginning and end of 
the geometry. 
Only the line or arc are drawn. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Use 

Three operating modes are available: 

- Segment mode 
- Full contour mode 
- Part of contour mode 
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Segment mode 

When the segment to be deburred 
is selected, it is possible to restrict 
the deburring to the length 
between two punched attaches. 
An overflanking value can also be 
entered. 
 
 
 
Full contour mode 

When the contour to be deburred is selected,  
an offset value is proposed. 
 

This value is equal to half the width of the tool already 
positioned. 

 If you subsequently wish to change the offset value, 
use the wrench and select the "cyan blue" colored 
line. It is also possible click the geometry where the 
main tool is positioned to change the offset value of 
the deburring tool. 

 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 

 To remove the deburring function, use the Delete  function and select 
Deburring from the list. 
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Part of contour mode  

 Click on the first segment of the 
contour. 

The offset value is retrieved according 
to the tool present on the geometry. 

 Reverse the direction if necessary. 

 Change the offset value if 
necessary. 

 Select the last segment to be deburred. 
 

Reminder: Using the wrench allows you to change the offset value at a later stage. 

 

Simulation – Operations order  

In the case where there is no stop/unload/trap door on 
the geometry, in the operations order and manually, the 
deburring tool must be placed last. 
 

However, in the case of deburring limited to attaches, 
the main sequence will be performed. As the part is held 
by the two attaches, deburring will be performed on the 
machined section (with possible overflanking). The last 
two attach strikes will be given to release the part. 
 
 
 
 
 
 
 
 

 
 
 

Automatic punching/Maximum overflanking 

Function use 

Option to define a maximum 
overflanking value for lines. 

Activating the function 

 Adjust the settings in Tools > 
Options > Punch > Automatic 
allocation > Adjustments. 

 Check the Maximum 
overflanking for lines box. 
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Mark open curves during punching 

Function use 

Option to use RollerBall tools on open 
curves during automatic punching. 
In previous versions, RollerBall was 
only effective for curves from text or 
lettering. 

Activating the function 

 Adjust the settings in Tools > 
Options > Punch > Automatic 
allocation > Adjustments. 

 Check the Mark opened curves 
box. 

 
 
 

Example: Fold lines and open curves marked with the RollerBall. 
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TopSolid’Cut – Cutting 

Cut parameter custom colors by machine 

Function use 

Option to define by machine a custom color for each cut parameter. 

Activating the function 

 Adjust the settings in 
Tools > Options > Cut > 
Cut parameters > Use 
colours defined in 
cutting parameters on 
elements. 

 
 

The color is permanently assigned to the cuts of the part. 

Notes: 

- Links are unaffected and their color remains navy blue. 
- Lead ins are unaffected and their color remains yellow. 
- Lead outs are unaffected and their color remains green. 
- Additional cuts (loopings, etc.) are unaffected and their color remains green. 

Use 

When cutting parameters management  is activated, the default colors appear on each parameter. 
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 Hover over the parameter name (for example: Contour#1). 

The Choose color button becomes 
active. 

 Click on the Choose colour 
button. 

 Choose the color for the 
desired parameters. 

 
 

Note: White, black and navy blue 
are not present in the palette. 
 

 
 
 

When creating cutting paths on a 
new part, the colors are 
permanently associated. 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 

  

The cutting parameters  Information/modification button also makes information appear. 
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The colors are also shown on 
the path instances on the 
nesting. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Update old parts 

 After having configured the colors of the 
cutting parameters, open an old part machined 
without the new function. 

 Activate the Update machining parameters 
function to obtain the defined colors. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Cutting gas by material/by machine 

Function use 

Option to define the default cutting gas for a given machine (function prior to version v6.15) 
Additional option to define the cutting gas to suggest by default for a given material. 
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Activating the function 

 Adjust the settings in Tools > Options > Cut > General > Default gas. 

 

Use 

By checking the box for the first time, all 
materials have the same gas by default. 
You just need to specify the gas using the 
list on the right. 
 
 

When importing a part, and when the 
machine and the material are selected 
from the lists, the gas combo will position 
itself on the gas preset in Tools > 
Options. 
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Laser path ergonomics 

Function use 

To make laser paths easier to read, it 
is possible to no longer show the 
extremities of paths (red squares to 
define the beginning and end of the 
path).  
 
 

 
 
 

 

Activating the function 

 Adjust the settings in Tools > Options > Cut > General. 

 Check the box Show extremities of trajectories. 

 

Use 

 Regenerate the view of the document sequences. 
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Automatically contour unsafe links 

Function use 

In the case of potentially unsafe links between cuts made "head down", it is possible to automatically contour 
cuts crossed by these unsafe links. 

Activating the function 

 Adjust the settings in Tools > Options > Cut > General. 

 Check the boxes corresponding to the Unsafe links – Contouring functions. 

 

Check function  

After having launched the check and chosen to hide all safe paths, a question bar allows faster access to the 
various options. 

 

To automatically contour unsafe links, there are several possible options: 

 

 

 Adjust the security distance and define the link to be contoured or choose to contour all unsafe links with the 
security distance entered. 

Result without contouring     Result with automatic contouring 
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Manual creation of links between cuts function  

When links are created manually between cuts, option to automatically contour if the link that has just been 
created is potentially unsafe. 

 
 

Detection and correction before simulation of unsafe link paths in the Meg 

When the Check unsafe links during 
simulation box is checked in Tools > Options, 
an alert may be reported if potentially unsafe 
links are found. 

 Check the box in Tools > Options enabling 
automatic contouring. 

 
 
 
 
 

 

Note: The automatic creation of cuts and links 
function does not check for unsafe paths. You 
must use the Check function. 
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TopSolid 7 and TopSolid’Sheetmetal link 

Ignore the case in material names 

Function use 

TopSolid'Sheetmetal ignores the case for material names from 3D TopSolid. 

If a 3D part is made of Stainless steel and the material entered in the sheet management of TopSolid'Sheetmetal 
is stainless steel or STAINLESS STEEL, there will be no conflict. 

Ignore major revision indications 

Function use 

Option to ignore major revision indications when importing parts from TopSolid V7. 

Retrieval of colors from the unfolding document in TopSolid'Sheetmetal  

Function use 

Option to find out the colors used in TopSolid 7 
on the unfold in order to configure in Tools > 
Options the different colors relating to "cut" 
contours, "marked" contours and "burns", as well 
as the color of "free" points on which automatic 
pointing will be applied. 
 

 To find out the colors of the V7 unfold, go to 
the PCH document properties. 

 

Each line corresponds to the different 
profile/point categories encountered with the 
color from the palette and its number. 
 

 
 
 
 

The PCH part display presents the profiles and points of the V7 unfold with their attributes. Also shown are the 
points on curves to which primings will be attached by default. 
 

Note: The profiles are highlighted when a line in the box is clicked. 


