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TopSolid'Wood - Machining Export: BiesseWorks Introduction

Introduction

BiesseWorks is the machining software for programming Biesse numerically controlled machines.
The interface sends the parts drawn in TopSolid'Wood to BiesseWorks with the machining definitions.
TopSolid'Wood then produces a .cix file which can be directly opened in BiesseWorks.

Missler Software



TopSolid'Wood configuration TopSolid'Wood - Machining Export: BiesseWorks

TopSolid'Wood configuration

= ﬁ bl achining

. . . . .- {18 PanelCab configuration
Export to BiesseWorks can be configured in Tools > Options > TopSolid'Wood |58 WoodwOP configuration

configuration > Machining > Biesse CIX configuration. _____ 3 Xilog Flus configuration

------ e M aestro configuration

- 2 ML Hops config
General Conﬁgumﬁon @ Biess configuration

- Number of decimals: Corresponds to the number of decimal places to be exported. Let's take a drilling
10.1234mm deep, for example, for 3 decimal places, the depth exported to BiesseWorks will be 10.123mm.

Murmber of decimals |3

- Tolerance of discretization: The tolerance of discretization defines the level of accuracy used to export the
machining geometries, including curved and circular paths. The finer the tolerance, the closer the exported
curve is to the drawn curve, but the longer the calculation. The value of 1°-05 (in meters) is the most common
average value used, because it provides a good compromise between precision and performance.

Tolerance of discretisation: |1e-05

- Files save path: Lets you specify the path of the directory where the exported files will be saved.

Filez zave path :|E:HPrDietHBiesse Ewport

Note: By default, if no directory is specified, the files will be saved in the folder of the exported project.
- The Unit section lets you configure the type of unit (Millimeter or Inch) for the machining file.

it

(@ Millimeter (I Inch
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TopSolid'Wood - Machining Export: BiesseWorks TopSolid'Wood configuration

Configuring default machining options
You can adjust some default machining settings in the TopSolid'Wood configuration.
Drilling settings
- Maximum diameter: This option lets you specify a maximum drilling diameter for machining.

If the drilling diameter is strictly greater than this setting value (in millimeters), the drilling is not exported
to BiesseWorks.

Diilling operation

b @i diameter : |40, 000mm

Tool path setting for grooves, rabbets and mouldings

You can choose to export the centered or shifted tool path for each operation (Groove, Rabbet and Moulding).

Tool path settings can be configured in Tools > Options > TopSolid'Wood configuration > Machining > Biesse CIX
configuration.

Tool path
Groove R abbet Moulding
(®) Centred () Shifted (®) Centred () Shifted (®) Centred () Shifted

Examples of groove exports with the Centered option (left) and Shifted option (right) enabled:

Note: This setting will be only applied to grooves and rabbets using a router.
The grooves that go through the part are systematically exported in Centered mode.

Missler Software



TopSolid'Wood configuration

Tool calibration over-thickness value

TopSolid'Wood - Machining Export: BiesseWorks

You are able to export an over-thickness value for calibration machining to BiesseWorks. This value corresponds to
the tool's exceeding value under the part.

This default value can be adjusted in Tools > Options > TopSolid'Wood configuration > Machining > Over-thickness

(-2).

Application configuration

(1 Configuration
=] ‘ﬁ TopSolid'Wood configuration
@ stibutes

& Configurators
Bill of material
3 Multi-drilings
B Assemblies

Propagation

% Propagations configuration
" Automatic assembly
W Initialization
v Edge / Laminate
2y Define parts
faml Matters overvaluations definition
-3 Warking stations configuration
_ Draft

(A Files
¥4 Triviso
T Conditional selection of tools
(=28 ™ 1 achining

>

m

Machining
Calibration

Over-thickness [-Z):|3.000mm

Default reversal

Note: This default value can be modified at each export in the part selection window.

Rot X Ret Y [T

BOM configuration for part selection sorting

You can set a default BOM file for part selection sorting in TopSolid'Wood.

The BOM file to be used for part sorting can be set in Tools > Options > TopSolid'Wood

configuration > Files > Part selection sorting.

BiesseWorks executable location configuration

Categories

(- Tools

+- Aggemblies
- Parts selection sorting

- b atters configurator

- Edge configuration

- Laminate configuration

- Properties configuration

- Multi-draft : D:AMisslersTSWooo
- Export 201 /2 machining

- PanelCAM export

- WoodW 0P export : D:AMizslery
- #ilog Plus export

- b aestio enport
- MC Hopz export

In order to automatically launch BiesseWorks after a machining export from TopSolid'Wood, you can specify the
location of the BiesseWorks executable.

The executable path can be set in Tools > Options >
TopSolid'Wood configuration > Files > Applications.

Categories

- Tools

(- Assemblies

[+ Parts selection sorting
[+ Symbols

B- Applications

i PanelCaM interface

- #ilog Plug interface

- MC Hops interface

ditor\Editar. exe
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TopSolid'Wood - Machining Export: BiesseWorks TopSolid'Wood configuration

Export configuration using configuration keywords

The configuration keywords are used to set some export parameters that are less common than those available in
Tools > Options > TopSolid'Wood configuration.

To modify/add configuration keywords, proceed as follows:

e Using the Notepad (or any other text editor), open the topzwoo.cfg file which is located in the folder
Missler/ConfigV6x/V6x/topzwoo.cfq.

Note: When in a Group configuration, open the Missler/GroupV6x/Vé6x/topzwoo.cfq file.
In this file, copy and paste the configuration keywords followed by the rules (setting values) separated by a tab
character.

e Before pasting a new configuration keyword, check that it does not already exist by using the Search function
of the Notepad (Edit > Search or Ctrl + F).

Rechercher | Remplacer | Rechercher dans les fichiers d'un dossier | Marguer

Recherche : | ¥ _AW00_CAM_CIX_DRILL_TOOL_MNAME v| | Suivant

Compter

Rechercher dans tous les
documents ouverts

Rechercher dans le
[ ]Mot entier uniquement document actuel

General configuration keywords

Configuration keyword Value Result

ZX_ZWOO_CAM_NO_CALIBRATION 1 Automatically deactivates the
part's calibration when the
overdimension values are set to
Edge shape or Abacus mode.

0 (default value) The part's calibration is always
exported.
ZX_ZWOO_CAM_CALIBRATION_CHANGE_ORIGIN | 1 The starting point of the part's

calibration will be in the middle
of a calibration segment.

0 (default value) The starting point of the part's
calibration will be at the end of a
calibration segment.
ZX_ZWOO_CAM_GROUP_DRILLS 1 (default value) Groups together the drillings
during export.

0 Allows the drillings not to be
grouped together during export.
D_SH OP_POC_USE_MAC_PROPERTY 1 Allows for the correct export of
overlapping operations with
pockets.

0 (default value)

Missler Software 5



TopSolid'Wood configuration

TopSolid'Wood - Machining Export: BiesseWorks

ZX_ZWOO_CAM_REMOVE_FACING_HOLE

1 Allows the through hole of a spot
facing not to be exported.
0 The spot facing and the through

hole are exported.

ZX_ZWOO_CAM_THROUGH_DRILL_IN_FIRST_FILE

0 (default value)

Through holes are exported on
their reference face.

In Two files if necessary mode,
the through holes are exported in
the first machining file.

ZX_ZWOO_CAM_THROUGH_DRILL_ABOVE_ONE_FI
LE

1 (default value)

In One machining file mode, the
bottom through holes are
exported on the top face.

Through holes are exported on
their reference face.

ZX_ZWOO_CAM_THROUGH_POC_ABOVE

1 (default value)

Exports the bottom
pockets on the top face.

through

0

Through pockets are exported on
their reference face.

ZX_ZWOO_CAM_MPR_THROUGH_POC_TO_MILL

1 (default value)

Through pockets are exported as
millings. Only the contour of the
pocket will be exported.

A through pocket is exported as a
pocket. All of the material will be
machined.

ZX_ZWOO_CAM_MPR_INSIDE_SAWING_TO_MILL

Exports the closed trimmings
performed inside the part as a
milling.

The closed trimmings performed
inside a part are not exported.

ZX_ZWOO_CAM_MPR_MILL_CHANGE_ORIGIN

The starting point of the part's
internal milling will be in the
middle of a milling segment.

0 (default value)

The starting point of the part's
internal milling will be at the end
of a milling segment.

ZX_ZWOO_CAM_DRILL_DEPTH_WITHOUT_TIP

0 (default value)

The drilling depth is exported
without the tip.

The drilling depth is exported with
the tip.

ZX_ZWOO_CAM_THROUGH_DRILL_IN_FIRST_FILE

0 (default value)

Through holes are exported on
their reference face.

In Two files if necessary mode,
the through holes are exported in
the first machining file.

Missler Software



TopSolid'Wood - Machining Export: BiesseWorks

Interface-specific configuration keywords

TopSolid'Wood configuration

Configuration keyword

Value

Result

ZX_ZWOO_CAM_CIX_DRILL_TOOL_NAME

101

""(default value)

Default tool number assigned
to the drilling operation.

ZX_ZWOO_CAM_CIX_POCKET_TOOL_NAME

101

""(default value)

Default tool number assigned
to the pocket operation.

ZX_ZWOO_CAM_CIX_MILL_TOOL_NAME

101

""(default value)

Default tool number assigned
to the milling/calibration with
router

ZX_ZWOO_CAM_CIX_SLOT_MILL_TOOL_NAME

101

""(default value)

Default tool number assigned
to the groove with router.

ZX_ZWOO_CAM_CIX_SLOT_SAW_TOOL_NAME

101

""(default value)

Default tool number assigned
to the groove with saw.

ZX_ZWOO_CAM_CIX_THROUGH_POC_DEPTH_OFFSET

0.003

""(default value).

Default over-thickness
dimensions (in meters) used
for through pockets.

Missler Software




BiesseWorks configuration TopSolid'Wood - Machining Export: BiesseWorks

BiesseWorks configuration

No special settings are required in BiesseWorks to import the files generated by TopSolid'Wood.
However, some options such as tool compensation reversal can be adjusted via File > Settings.

e From the Password tab, enter the password (proman by default) and click the Confirm button to validate.
1 B e o g s 1

| _:_'ll General I ar | ser | T._?j Password |

1 g

1
L Todls I wJ Leaddin Lead-out I ’.E Machining operatiol
Insert passward

C )
User Level 3

| Lt | User Level 4 Confirm password:

User Level &
P | |

oy LR e e e s 1

Change Password

User Level 1 Insert new password:
User Level 2 | |

Password:

Cument lewvel:

e From the Machining operations tab, check or uncheck the User correction option.

| Machiring operatons | [[] Bomngdata | |7 |

i | GEHEEH I El} L_|5a_ I ‘J‘E;] ﬁassward I ﬂ Toals _l o LeEld-lin Lead-out

cal

Left Comection

Tool comection: relative tool positions and path

v

Right Comection

Active machining operations Active Inputs and Outputs Default values

W_CUTTING 30LineCurve Piercing Zlmml: 5
W_DRILLING ‘ 3DProfile lercing Zpor]:
!

WINSERTING Corected 30Gve — o1

e Confirm the options using the Save and exit button. il
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TopSolid'Wood - Machining Export: BiesseWorks Making an export

Making an export

From TopSolid'Wood

e Select Wood > Machining export > Export to Biesse CIX.

B8 0-

Export to 20%: machining

@

@) Text outline I

Export to WoodWOP

+ Machining export T P TP P PR —
[® Cut export ¥ | [a Export to 2D% machining Export to PanelCAM
= Export bill of material [ Export to WoodWOP

Export to Xilog

-

1 TopSolid'WoodCam Export to PanelCAM
22 Export to Xilog

2 Export to Maestro
o2 Exportto NC Hops

Fﬂ Export to Biesse CIX

Export to Maestro
&g TopSolid'Wood Help

Export to MC Hops

N H QBN

Export to Biesse CIX

Note: The Machining export > Export to Biesse CIX function can also be accessed from the icon bar of the Wood
context (on the left side of the screen).

o Choose the One part or Multi-parts mode. [ONE PART][MULTI'PARTS]

- The One part mode lets you export only one part. You can also use this mode to add milling operations to
the part manually.
- The Multi-parts mode lets you export several parts of an assembly.

One part mode

e Select the One part mode. GHERAT

The file explorer opens in the folder that is defined by default in Tools > Options.

e Select the folder where you want your file saved and give the exported file a name (by default the name of the
original Design file).
e Select the part to be exported to BiesseWorks.

Part to machine:|

{ L)
n

WO =B\

o |f the selected part is set to Optimized machining mode, the following two options are available:

- OKto continue without updating the machining face.
- Update machining face to update the machining face of the exported part.

|UPDATE MACHINING FACE |

Missler Software 9



Making an export TopSolid'Wood - Machining Export: BiesseWorks

e Next pick the positioning face (CNC positioning face, the bottom in BiesseWorks).
e Select the Positioning for part definition option to use the positioning face set in the part definition.

[POSITIUNNING FOR PART DEFINITICIN]

REe=PBIN

|F'EISITIEINNINI3 FOR PART DEFINITIEINI Positioning face :|

5 X

Note: The part is placed in top view in relation to the selected face.

e Select the part's positioning orientation for the BiesseWorks machining export using the << and >> arrows from
the dialog bar.
e Click OK to confirm the positioning.

G O G
[ oo o o o oo |
Part displayed in TopSolid'Wood Part positioning in BiesseWorks

Note: In TopSolid'Wood, the part's horizontal axis from left to right will be the X+ axis in BiesseWorks and the
vertical axis from bottom to top will be Y+.

The Other routings of contour button lets you add milling operations to the exported part:

|DTHER ROUTINGS OF CONTOUR|

10

Edges on planar face: Lets you select several edges at once from a reference selected face.
[EDGES ON PLANAR FACE |

All face edges: Selects all edges of the selected face. [ALL ERGES,OF FACE]
i =|22
Relative depth: Machining depth value (in millimeters). festo sl

Depth from face: The relative depth value is calculated by default from the reference face you selected
previously. To change the reference face for the machining depth, click Depth from face and select the new
. DEPTH FROM FACE|

reference face for the machining dept
Follow tangent edges = Yes/No: You can choose to associate or not associate the tangent edges with the

selected edge. Follow tangent edges=| YES €2

Reference edge for tool path: Lets you pick the edges you want to add to the tool path.

Missler Software



TopSolid'Wood - Machining Export: BiesseWorks Making an export
e Once you have selected one or more edges, click OK to confirm.
e |tis possible to select another reference face. If you want to keep the previously selected face, click Stop.

Note: All paths selected from the Other routings of contour option, except those selected from Edges on planar
face, are not aggregated as a single machining. Each selected edge will be exported as one separate machining.

e Click OK to confirm the other routings in order to create the CIX file.

Multi-parts mode

e Select the Multi-parts mode.

Several options for selecting parts are available in the dialog bar:

- Main assembly: Selects all parts of the main assembly.

MAIN ASSEMBLY

- If several sub-assemblies are created in the document, a drop-down list appears and lets you select a sub-

assem ny Sub-assembly= Cabinet (in place sub-set] «

- Depth: Lets you select the depth type to display the elements of the selected assembly.

Depth: MULTILEVEL +

- Filter bom by criteria: Lets you select a filter to filter the parts in the selected assembly.
Filter bom by criteria= nao filter v

- Update machining face: This option is available if one part is in Optimized machining mode. It updates the
machining faces of parts exported in Optimized mode.

Update machining face =

- Select element to use: Lets you select parts manually:
o Left-click on the parts to be selected. Once the parts are selected, they turn red.

o Click STOP to confirm the selected part(s).

Over-thickness:[3.000mm
Selection type

The Multi machinings window opens. S earLh

() Selectparts by material

> Alder black - 19mm

- Over-thickness: The default over-thickness value is || - soueme
provided in Tools > Options, but you can modify this value EponED e

(®) Select by criterions

for the exported project. Citerions
. H Type >
- Select type: Part selection mode. =00
- Expand all/Back-up: Opens or closes all of the assembly in Conting >
the BOM. [ Thickness > 19mm

[“]Property > Bottom operations

EXPAND ALL BACK-UP

=9 1 Fixed shelf o
“# 1 chantplat
B 1 Fixed shelf
=] 1 Rectangular coffee table
“# 1 Glass table top
“§ 1Baseb
“P 1Baseb
“# 1Base 4
“P 1Base 3
“# 1Base 2
P 1Base1
2@ 1 Interior counter
“¥1Top
B 1 Shelf
P 1 Right side
P 1 Leftside
*§ 1 Bottom
@ 1 Horizontal separat
=9 1 Fixed shelf
“§ 1 chantplat
“P 1 Fixed shelf
=9 1 Fixed shelf
“§ 1 chantplat
*B 1 Fixed shelf v

\U Part selected

n panel component

[“IClose files

oK Cancel
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Making an export TopSolid'Wood - Machining Export: BiesseWorks

e Right-clicking on a part of the list displays several options:

- Select: Selects the part. Select

- Deselect: Deselects the part.

- Select same parts: Selects all parts that are identical to the selected ones.

- Positioning: Opens the setting window for the part positioning. This window
allows you to change the positioning direction of the part in BiesseWorks.

Deselect

Select same parts

Positioning...

Note: This change in positioning will only apply to this export.

~

-

Gores

Note: At the bottom of the window, an information box indicates the number of selected parts.

[1 Part selected

e Selecting the Close files option prevents the generated files from opening. Check this box when exporting a lot
of parts.

Close files

Choose a directory

o Click OK to start the export.

e The folder selection window opens on the folder configured in the “'
options. Select a destination folder for the exported files. @ BandL

> ) Cupboard

I . Dec Opérations
. Rainures
> 1. Public

= Temp
I» e Lecteur DVD RW (E5)

I L@ FICHIERS_HOTLINE-VPN (\\srv-qua2) (I:)
I+ g Src (Wsrv-devd) (%)
I» Lo Objets (\srv-dev5) (T:)

Créer un nouveau dossier

TopSolid'Wood then generates the CIX files. Once the export is finished, the number of generated files is displayed
in the alpha bar.

Machining export | Export to WoodWOP.

3 file(s) saved

Note: If you did not check the Close files option, all the generated files will be opened.
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TopSolid'Wood - Machining Export: BiesseWorks Making an export

From BiesseWorks

e If the part does not open automatically, click File > Open and select the generated .cix file.

By default, the screen is divided into the following three areas:

& File Edit Inset Display Progam Tools Windows Help — -
DEE M6 8 Feases 5 2@
LY

-7 Proguam Ny

o T — o 9
{91159 Genere bore D= 100002 5230 V25 [ece

9129 Generc bore Ip="100%03" X=30¥=9.5
12| Geneic bore ID="100004" X250 V=95
9112 Generic bore ID="100005" ¥=50 =85

A1 | Generc bore 0=10006" 50¥=24 &} @] @]

71(29| Geneic bore ID="10000T" X=50 V=238

e}
=l
o
e}
o
Ly

1L
[e] 2 2= =)=

IS

[ eo o o [5) oo |
I“Plzu Side0  Side1 Side? Side3 Sided Side5 )
frour oo 10 h
BG |D-"1DO00" AP -
B 0710000 e
B 10-10000¢
BG ID-"1DO00S"
B 0-"1D00E:

Faid -
=142 DiA=15 RTY=px OX=150 OY=0 NAP=

Premere. 71 perun aua

TP P Y= O TP 2T TR -1

1. Program

This area lists all the operations performed on the part and allows you to edit them with double-click or
show/hide them in the graphics area using checkboxes.

2. Graphic display area

This area displays the 2D part. The different 2D views of the part's faces can be displayed using the lower bar
of the area.

|| Piece | Side 0 | Side 1 | Side 2 | Side 3 | Side 4 | Side 5 |

The part's operations can also be edited from the area.

3. Edit field

This area displays the program lines for each operation of the part. Values like coordinates can be changed from
this area.
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Notes
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