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Create the geometric component 
To create a geometric driver component, it is necessary to don’t design the component on the absolute 
coordinate system. 
The entire component has to have no link to the absolute coordinate system. So the driver elements have to be 
basics. 

Create the document and the geometrics drivers 

 Create a new design document.   

 Set the level 1 current and hide the level 0.  
Note: The goal is to hide the absolute coordinate system to don’t draw on it. 

 Create 3 points in the graphical zone with the function Tools > Points. 

 Break the associativity of these points with the function Edit > Break associativity.  

 Select the 3 previously created points to transform them in simple points.  
Note: Before breaking associativity, the points where relative to the absolute coordinate system. After breaking 
associativity, there are independent. 
Depending to these independent points, a coordinate system will be created. It will be used to create the part. 

 

 Start the function Tools > Coordinate system > Coordinate system 3 points.  

 Select as Origin point the bottom left point. 

 Select as Point towards x the bottom right point and as Point towards y the top point. 

 Select the button Set as current to use this coordinate system.  
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 Save the document in a new folder Chair and named this document Chair seat.  

 Start the function Edit > Name. 

 Select as Element to name the 3 created points and name them: 

- Name: p1 Designation: Top point 
- Name: p2 Designation:  Bottom left point 
- Name: p3 Designation: Bottom right point 

Note: When the chair seat will be included in the assembly document, the 3 points will be modified to modify the 
geometry of the chair. So these 3 points have to be defined as drivers.  

 Define the point as Driver element with the function Assembly > Define component > Define drivers.  

 Write as Driving element to insert: p1 and validate with enter. 

 Validate the default Designation and do the same operation with the point p2 and p3. 
 

 Create 2 other Length parameter: 

- Value: 50mm Name: pw Designation: Part width 
- Value: 19mm Name: th Designation: Part thickness 

 Set these parameters as drivers. 
 
 

Create the part 

 Create the bellow sketch in passing by the 3 driving points. 

- Create two lines passing by the point p1, p2 and p3. 
- Create a parallel contour of these lines at the value of pw. 
- Close the contour with two lines and apply a perpendicular constraint with the original contour. 

 

 Apply a Global fillet of 10mm on this contour. 
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 Close this sketch and extrude it with a thickness value of th. 
 Define this part. Set the cutting-up axis as the bellow picture. 

 

 Set the Part’s designation: Chair seat part and chose a material. 

 Save this document. 

Create the chair component 

 Create a new design document.  

 Create 5 parameters: 

- Value: 450mm Name: sh Designation: Seat height 
- Value: 300mm Name: bh Designation: Back height  
- Value: 110° Name: ba Designation: Back angle 
- Value: 350mm Name: cw Designation: Chair width 
- Value: 300mm Name: cd Designation: Chair depth 
- Value: 19mm Name: th Designation: Panel thickness 

 Save this document and name it Chair. 
Note: In a furniture document, the conception is better if the 
absolute coordinate system is oriented as the X+ axis is on the 
furniture width, the Y+ axis on the depth and the Z+ on the height. 

 Set the level 1 current and hide the level 0. 

 Create a 2 axis coordinate system with: 

- X axis: Y- 
- Y axis: Z+ 

 Set current this coordinate system. 
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 Create this sketch with the previously parameters. 

 Close this sketch. 

 Set the level 2 current. 

 From the tab Layers of the tree, make a right click on the levels 
to Set name: 

- 0- Absolute coordinate system 
- 1- Chair lateral sketch 
- 2- Back sketch 

 

 
 
 
 
 
 
 
 
 
 
 
Note: Actually, there are two parameters for the chair width and for the panel thickness which will be make the 
real chair width. 
So here we need a parameter to calculate the real chair width. 
 

 Create a new parameter. 
 Set the value: floor((cw-th)/(th*2))*(th*2) 
 Set Name: rcw and Designation: Real chair width. 
 
Remark: The floor function is an expression function which allows calculating the 
inferior rounded value of the calculated value in brackets. 
So if the result of (cw-th)/(th*2)=8.71, floor((cw-th)/(th*2))=8. 
 

 Create a 2 axis coordinate system.  
 For the X axis, select Through point and select the top sketch point. 

  

 Then select the Z- axis.  
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 For the Y axis, select the same through point and select as Direction the 
sketch line.  

 Rule the arrow to the top and validate the direction with OK. 

 Select Quit and set Current this coordinate system. 
 
 

 
 
 
 
 

 Create a new sketch.  

 Create the top pattern for the chair as you want. The total width of the contour must be the parameter rcw. 

 
 
 
 

 Close this sketch and save the document.  
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Points creation 

 Set the level 3 current and name it Points. 

 Select the function Current coordinate system  and 
select Absolute coordinate system. 

 

 Change the conception color.  

 Start the function Tools > Points and create the 3 driving 
point as the following picture.  

 
 
 
 
 

 Repeat the two bottom points with the function Edit > 
Repeat: 

- Linear 
- X+ 
- Distance per instance = 2*th 
- Total number = (rcw/(2*th))+1 

 
 
 
 
 
 
 

 Then select Redefine to create a new repetition.  

 Select in the drop down list On curve.  

 Select as Curve on which to propagate the top sketch. 
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 Rule the propagation: 

- Distribution mode: Mark out 
- Distance computing mode = Fixed direction 
- Transformation mode = Frenet coordinate system 
- Distance = 2*th 

 

 

 Validate with OK. 

 Select as Direction X.  

 For the Number of instance, select the option On 
all curve to calculated automatically the point 

number on the curve.  

  Then select the top point to repeat it.  
 
 
 
 
 
 
 
 
 
 
 
 
Remark: Distribution mode: 

- Mark out: Allows giving a distance 
between each instance.  
The number of instance can be given 
or automatically calculated with the 
curve length, but the last length 
between the last element and the 
curve endpoint can’t be managed. 

- Distribute: Allows giving only an 
instance number automatically 
distribute on the curve length. 

 
Repeat an element on curve with a fixed 
direction allows repeating the element on 
the selected curve and obtaining a distance 
between each point on a specific direction 
(here X axis). 
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Include the part 

 Set the level 4 current and name it Seat parts. 

 Hide the level 0, 1 and 2.  

 Include the component Chair seat with the function Assembly > Include 

sub-assembly / Part.  

 Select for the Top point, the Bottom left point 
and the Bottom right point the 3 first points of 
the repetitions.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Give a value for the Part width. 

 Merge automatically the parameter th of the 
component with the parameter th of the 
assembly document with the button 
AUTOMATIC > Panel thickness=19mm. 

 
 Then the first component is calculated. 
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 Select Stop to don’t apply constraint on this element.  

 In the dialog to propagate the component, select Serial Copy.  
Note: During a Serial copy of a component, it’s possible to select some elements in the document to create the 
list to copy the component in serial. 
But when the component is created on a repetition like here, it’s possible to select the repetition automatically as 
the serial component list. 
Note: It’s possible to do a Serial copy after component inclusion. Start the function Assembly > Copy component 
> Serial copy. 

 Let the default Serial mode = Normal and select as Top point list the option Automatic.  

 Select Automatic again for the Bottom left point and Bottom right point. 
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Feet creation 

Seat modification 

The seat will be modified to create two slots to position the feet. The slot for the back foot will be sloped. 

 In the chair document, launch the function File > Lock document update.  
Note: When an assembly contains a component, if this component is modified, the assembly is updated at each 
modification. 
The function Lock document update allows doesn’t updating the assembly at each modification. With this, it’s 
possible to do all the modification in the component and to update the assembly only one time. 
The red frame around the design area show if the document is locking for update. 

 Start the modify element function and select the seat.  

 Select the button Template to open the seat 

template document.  

 Modify the original part’s sketch. 
 
 
 
 
 
 
 
 
 

 Create two rectangular slots. The back slot is 
sloped. 

 
 
 
 

 Dimension these slot: 

- Width: th 
- Height: th 
- Distance from the side: 50mm 
- Left slot angle: 110° 
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 Start the function Trim.  
 Rule: 

- Mode = Delete 
- Mode = Trim 

 

 Select the superposed segment to trim and sew automatically the contour. 

 

 Apply 4 filets with a 5mm radius in the two slots  

 

 Close the sketch to update the part.  

 Open the chair document.  
The component chair seat has been modified, so the 
assembly must be update now. 

 Click on the button Delayed update to update the 

document.  
The serial component is update with the slots. 

 Quit the update lock with the function File > Lock 
document update. 
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Feet creation 

 In the chair document, set the level 5 current and name it Feet. 

 Set the coordinate system 2 axis created on the level 1 to design the chair sketch current.  

 Display only the levels 0, 4 and 5. 

 Create the bellow sketch for the feet. The sketch is constrained on the slot of the first serial copy part. 
 

 
 

 The bottoms of the rectangles are constrained on the absolute coordinate system. 
 

 
 

 Close this sketch and extrude it in Global mode and One 
shape per profile mode: 

- Offset from starting curve = -((cw-rcw)/2) 
- Direction: Z- 
- Height: cw 
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Trim the feet 

 Hide the levels 0 and 4. 

 Create a coordinate system on face and point. 

 Select as Reference face the back face of the back 
foot. 

 Select as Origin point the bottom right point of the 
selected face. 

 
 
 
 
 
 
 

 Orient the coordinate system with the red arrow 
to obtain the sided coordinate system. 

 Do the same operation to obtain a coordinate 
system on the front foot.  

 
 
 
 
 
 
 
 
 

 Set current the back coordinate system and create the bellow sketch. 
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 End the sketch and trim the part with it. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 To create the slot on the feet, create the bellow sketch. 
This sketch is created on the first serial component, which 
will always exist. 

 Close this sketch and trim the feet with. 

 Start the function Shape > Propagate operation to 

propagate the trim.  

 Select the last trim and configure: 

- Linear 
- X- 
- Distance per instance = 2*th 
- Total number = rcw/th/2+1 
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 Do the same operation for the front foot. 

 
 

 Then define the two feet to finish the chair. 
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