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Introduction 
Hardware manufacturers allow the 3D models of their products to be downloaded. This makes it possible to get 
the real geometries of hardware in TopSolid’Wood to correctly position the associated machinings. 
It is necessary to follow this way of working to be able to properly use the 3D files recovered from a manufacturer 
of runner systems. 
The files provided for this documentation are Blum TandemBox Antaro drawer runners and M Height sides. 
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Creation of runners 

Recovering files 

The 3D files of Blum and Hettich hardware are installed on DVD 2. 
Libraries can be installed under: C:\Missler\V615\z\woo\lib. 
It is possible to search for components by entering the supplier's reference in the Windows search field. 

 
 

Saving files 

The 3D files of the drawers provided by manufacturers are not configured. There is a 3D file per runner length. 
This first section will allow these runners to be saved in a library in order to simulate to the software a single 
configured file using a catalog code. 

 Open the 9 right runners provided in the Tandembox Antaro\Runners\Right folder. 

Note: These runners can be opened simultaneously by selecting them from Windows Explorer and dragging them 
into TopSolid’s graphical area. 

 
 
 

 
 
 
 
 
 
 

 Save the first runner in the library by selecting Assembly > Define component > Edit/Save standard template. 

 

 Select Save standard template.  

 Select Standard: My 3D standard. 

 Then enter: 

- New family: BLUM drawers 
- New type: TANDEMBOX runners 
- New variant: Right 
- New version: 00 

 Check the Supplier code box, and then enter the 
length of the saved runner in the New code field. 
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Note: The length of the opened runner is displayed in the file name:  
TANDEMBOX#V=558_2701b#I=00#R=NR.top 
TANDEMBOX#V=558_3001b#I=00#R=NR.top 
TANDEMBOX#V=558_3501b01#I=00#R=NR.top 

 Validate with OK to save the runner in the library. 

 Repeat this procedure to save the 9 runners in the library.  

 Create the catalog by selecting Assembly > Define component > Edit catalog header. 

 Validate the dialog box by pressing Enter to generate the Excel catalog. 
 

Catalog optimization 

Excel catalogs make it easy to order data in the file cells. However, these files take a long time to load when using 
components. 
You can convert these catalogs to .cat format in order to reduce the load times of components in TopSolid’Wood.  

 

 From the Excel catalog, start File > Save As. 

 Leave the default destination directory and file name. 

 Select Type: Text (Tab delimited) (*.txt) in the drop-down list. 

 Validate by clicking the Save button. 

 Validate all Excel warning messages, and then close this file without saving it. 
 

 Open the Windows folder of the library where the runners were saved. 
 

Note: Here we find the saved runners, the Excel catalog and the new catalog in Text format. 

 Delete the Excel catalog.  

 Rename the Text catalog in order to change its .txt extension to .cat. 

 
 
Note: If file extensions are not displayed, open the options of the Windows folders using Alt > Tools > Folder 
Options > View > Uncheck Hide extensions for known file types. 
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Creating the tools and key points 

Creating the drawer runners in TopSolid’Wood allows you to automatically perform machinings on the elements 
in which drawers are inserted. 
To do this, you must create in the runners the tools that will help drill the sides. There is a function for creating 
the tools automatically in the components from a template file. 

Creating the template 

 Create a new Design document without template. 

 Create a part 600mm long, 50mm wide and 19mm thick. 

 

 Create a parameter: 

- Unit: Length 
- Value: 224mm 
- Name: d 
- Designation: Drilling distance 

 Create a first drilling centered on the part’s width and positioned at 37mm from the end of the part: 

- Hole 
- Blind 
- Diameter: 5mm 
- Depth: 12mm 
- Bottom angle: 0° 

 

 Create a second drilling centered on the part’s width and positioned at d+37mm from the end of the part. 
This drilling is the same as the previous one. 
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 Create a tool by selecting Assembly > Define component > Define tool.  

 Set Operation type = Local operation on shapes. 

 Enter Name of tool element: Tool1 and Designation of the tool element: Right runner drilling. 

 Select the two drillings on the martyr part, and then validate with Stop. 

 Validate the window with OK. 
 

 Create a coordinate system on two axes using Tools > Coordinate 

system > Coordinate system 2 axes.  

 Select the cylinder of the 1st drilling for the X axis. 
 

 
 
 
 
 
 
 

 

 Adjust the axis direction towards the part thickness, and then validate 
with OK. 

 Select Y+ for the Y axis.  

 Define this coordinate system as a key coordinate system by selecting 

Assembly > Define component > Define key points.  

- Name of key coordinate system: cs1 
- Designation of key coordinate system: Runner coordinate system 

 

 Save this file and rename it Right martyr. 

 Define the d parameter as a driver. 

 Define the part without specifying any designation. 
 

Using the template 

The tool template of the runners will be imported to automatically create the tools and key points in the runners. 

Note: There will be no link between the template file and the runner files. 

 Using Assembly > Define component > Edit/Save template > Edit standard template, edit the standard file 
BLUM drawers > TANDEMBOX runners > Right > Code 270. 

 Set the render mode to Realistic rendering + edges + wireframe.  

 Select Assembly > Define component > Import tools and publishings.  

 Set: Publishings = No, Key points = Automatic and Tools = Yes. 

 

 Select Right martyr in the drop-down list as the document to import. 
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 Set Drilling distance = 224mm. 

 The martyr part of the template file is then imported. Select the document’s 
absolute coordinate system as the destination coordinate system. 

 Select Stop to finish the import.  

Note: The tools and the key point are then imported in the runner document. 

 Save and close this file. 
 

 Repeat the operation for the other runner lengths by setting the following drilling 
distances. 

 
Runner length Drilling distance 

300mm 224mm 

350mm 288mm 

400mm 288mm 

450 mm 320mm 

500 mm 416mm 

550 mm 416mm 

600mm 480mm 

650mm 512mm 

 
 

 Once all of the right runners are done, repeat these steps to create the left runners in the library: 

- Saving files in the library 
- Catalog creation 
- Catalog optimization 
- Creation of the tool template and the key points 
- Importing the tools and the key point 
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Creation of additional elements 

Creating the front fixing bracket 

 Open the file under Tandembox Antaro\Screw-on front fixing bracket. 

 Save it in the library as: 

- Family : BLUM drawers 
- New type: Accessories 
- New variant: Screw-on TANDEMBOX front fixing bracket 
- Uncheck Supplier code. 

 Define the set by selecting Wood > Define > Define 

set:  

- Designation: Screw-on front fixing bracket 
- Reference: ZSF.3502 
- Supplier: Blum 
- Assembly nature: Single unit 

 Using a sketch, create a martyr part in front of the front fixing bracket. 

 Make two drillings on this martyr part, aligned on the drillings of the front fixing bracket: 

- Hole 
- Blind 
- Diameter: 5mm 
- Depth: 10mm 
- Bottom angle: 0° 

 Define these two drillings as a tool:  

- Name of tool element: Tool1 
- Designation of the tool element: Front fixing bracket drilling 

 Make layer 1 current and switch off layer 0. 

 Create a coordinate system identical to the absolute coordinate system using 
the Tools > Coordinate system command, and then press Enter to copy the 
current coordinate system. 

 Define this coordinate system as a key point:  

- Name of key coordinate system: cs1 
- Designation of key coordinate system: Right coordinate system 

 Create a duplicate coordinate system of this coordinate system by selecting Tools > Coordinate systems > 

Duplicate coordinate system.  

 Select the previous coordinate system and configure the following transformation: 

- Transformation: Translation 
- Direction: X- 
- Translation distance: 31mm 

 Define this second coordinate system as a key point:  

- Name of key coordinate system : cs2 
- Designation of key coordinate system: Left coordinate system 

 Save and close this file. 
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Creating the sides 

 Open the 9 right sides provided in the Tandembox Antaro\Stainless steel drawer side\Right folder. 

 Save the first drawer in the library by selecting Assembly > Define component > Edit/Save standard 

template.  

 Click on Save standard template.  

 Select Standard: My 3D standard. 

 Then complete the following: 

- Family: BLUM drawers 
- New type: Drawer side Tandembox 
- New variant: Antaro M right 
- Version: 00 

 Check Supplier code, and then provide the length of the 
saved side in the Code field. 

 
 
 
 
 
 
Note: The length of the opened side is displayed in the file name:  
TANDEMBOX intivo#V=358m2702ia#I=00#R=NR.top 
TANDEMBOX intivo#V=358m3002ia#I=00#R=NR.top 
TANDEMBOX intivo#V=358m3502ia#I=00#R=NR.top 

 Validate with OK to save the side in the library. 
 

 Set the render mode to Realistic rendering + edges + wireframe.  

 Define the absolute coordinate system as a key point.  
 

 Repeat this procedure to save the other sides in the library. 

 Then create the catalog by selecting Assembly > Define component > Edit catalog 
header. 

 Validate the dialog box by pressing Enter to generate the Excel catalog. 
 

Catalog optimization 

 From the Excel catalog, start File > Save As. 

 Leave the default destination directory and file name. 

 Select Type: Text (Tab delimited) (*.txt) in the drop-down list. 

 Validate by clicking the Save button. 

 Validate all Excel warning messages, and then close this file without saving it. 

 Open the Windows folder of the library where the sides were saved. 

 Delete the Excel catalog.  

 Rename the Text catalog in order to change its .txt extension to .cat. 
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Creating the bottom adapters 

 Open the two files for the bottom adapters under Tandembox Antaro\Bottom fixing bracket. 

 Save the right adapter in the library:  

- Family: BLUM drawers 
- Type: Accessories 
- New variant: Bottom adapter TANDEMBOX M right 

 Define the absolute coordinate system as a key point.  

 Repeat these steps for the left adapter.  
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Creation of complete drawers 

Creating the parameters 

 Create a new Design document without template. 

 Create two length parameters: 

- Value: 270, Name: d, Designation: Drawer depth 
- Value: 800, Name: l, Designation: Drawer width 

 
Two texts will be created in order to be able to vary the references of the runners and sides depending on the 
depth selected from the drawer catalog. 

 Select Tools > Text.  

 Enter Text: Runners reference. 

 Name this text using the Edit > Name function: 

- Name: ru_ref 
- Designation: Runners reference 

 Validate this text by pressing Enter, and then position it in 
the graphical area. 

 Create a second Text: Sides reference. 

 Name this text using the Edit > Name function: 

- Name: si_ref 
- Designation : Sides reference 

 Save this file in the library: 

- Standard: My 3D standard 
- Family: BLUM drawers 
- New type: Complete drawers 
- Variant: TANDEMBOX Antaro M 30kg 
- Uncheck Supplier code 

Inserting the runners and sides 

 On layer 1, create a duplicate coordinate system of the absolute coordinate system in translation to X+ at a 
distance of l/2. 

 Create a second duplicate coordinate system of the absolute coordinate system in translation to X- at a 
distance of l/2. 

 On the right-hand coordinate system insert the Runners TANDEMBOX right 270mm, and then the Drawer 
side TANDEMBOX Antaro M right. 

 Then on the left-hand coordinate system insert the Runners TANDEMBOX left 270mm, and then the Drawer 
side TANDEMBOX Antaro M left. 
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Inserting the adapters 

 Make layer 2 current. 

 Create two duplicate coordinate systems of the left and right coordinate systems in translation to Z- at a 
distance of d. 

 Insert the left and right adapters on these coordinate systems. 

 

Inserting the front fixing brackets 

 Insert the front fixing bracket on the two front left and right key points. 

 

Creating the panels 

 Make layer 3 current, and then create a new sketch.  

 Draw any rectangular contour. 

 Dimension the height of this rectangle to 16mm. 

 Dimension its width to l-75mm. Apply a symmetry constraint on Y to this dimension. 

 

 Dimension the distance between the bottom of the rectangle and the absolute coordinate system to a 
distance of 24mm. 
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 Create a second rectangular contour to create the back. 

 Dimension its width to l-87mm. Apply a symmetry constraint on Y to this dimension. 

 Dimension the height of the rectangle to 84mm. 

 Align the bottom of this rectangle with the bottom of the base. 

 

 End the sketch.  

 Start the Create extruded shape function, and then set the Sketch = Local mode.  

 Select the base sketch. 

 In the advanced parameters , set Offset from starting curve = -37mm. 

 Click the Direction option to impose the Z- direction. 

 Enter Height: d-24mm. 

 Use the Driving elements function, and then select the base to display its sketch again.  

 Then extrude the back. 

 Open the advanced parameters , and then select the rear of the base. 

 

 Validate the advanced parameters with OK. 

 Enter Height: 16mm. 

 Define the two parts: 

- Designation: Base / Back 
- Material: wood > particle board. 
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Creating the catalog 

Creating the catalog of this drawer makes it possible to vary several elements according to the selected code: 

- The drawer depth. 
- The reference of the runners. 
- The reference of the sides. 
- The code of the right runner. 
- The code of the left runner. 
- The code of the right side. 
- The code of the left side. 

 
To vary the codes of the runners and sides, you must first name the components. 

 Use the Edit > Name function. 

 Select the left runner, and then enter Name: lr. 

 Name the right runner to rr, the left side to ls and the right side to rs. 
 

 Create the catalog of the component by selecting Assembly > Define component > Edit catalog header.  
 

 Open the drop-down list and select All parameters and texts. 

 From the Excel file, delete the column of the l parameter (drawer width). 

 
Note: The l parameter will simply be a driver parameter in order to be able to control the drawer width. 

 On the line of the column headings, type the following in 4 additional columns: 

- lr.code 
- rr.code 
- ls.code 
- rs.code 

 

 
 

Note: In a catalog, typing the name of a component followed by .code allows you to drive the component code 
depending on the catalog. 

 Then complete the drawer codes, the depth parameter values, the references of the runners and sides, as 
well as the codes of the runners and sides to be used, as shown below. 

  

 

 Save this file in the Text (Tab delimited) (*.txt) format. 

 Delete the Excel catalog. 

 Rename the Text catalog in order to change its .txt extension to .cat. 
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Creating in place sub-sets 

Creating in place sub-sets allows elements to be grouped together in a file so that they appear in the form of a bill 
of material under an additional assembly. 
Here, the runners will be grouped together in order to obtain a single BOM line. The same procedure will be 
repeated for the sides and the bottom adapters. 

 Start Wood > Define > Define set.  

 Select the New in place sub-set function.  

 Set Serial set = No, Insert in = Main assembly, Name of new sub-set: Runners. 

 

 Validate by pressing Enter.  

 Click the Insert button, and then select the left runner.  

Note: A warning message informs you that the runner will be removed from the main assembly to be placed in 
the Runners sub-set. 

 Validate the warning message with Yes. 

 Set Length axis: X+ and Width axis: Y+. 

 Uncheck Add to sawing-up in the assembly definition window, and then validate with OK. 

 Click the Insert button, and then select the right runner.  

 Click the Characteristics button to define this in place sub-set.  

- Designation: Runners TANDEMBOX Blumotion 30kg [d] 
- Reference: [ru_ref] 
- Supplier: Blum 
- Assembly nature: Single unit 

 
Note: Entering the [d] variable in the designation displays the 
depth of the drawer used. 
Entering [ru_ref] in the reference allows the ru_ref text (whose 
value is configured in the catalog according to the selected 
depth) to be recovered. 

 
 
 
 
 
 

 Then create a new in place sub-set named Sides. 

 Insert the two drawer sides in this sub-set. 

 Define the sub-set using the Characteristics function: 

- Designation: Sides TANDEMBOX Antaro M stainless steel [d] 
- Reference: [si_ref] 
- Supplier: Blum 
- Assembly nature: Single unit 
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 Finally, create a new in place sub-set named Adapters. 

 Insert the two bottom adapters in this sub-set. 

 Define the sub-set using the Characteristics function: 

- Designation: Back adapters M left/right 
- Reference: Z30M000S.04 
- Supplier: Blum 
- Assembly nature: Single unit 

 

 Define the assembly by selecting Wood > Define > Define set > Characteristics: 

- Designation: Drawer TANDEMBOX Antaro 30kg M Stainless steel [d] 
- Assembly nature: Sub-assembly 

 Validate the assembly definition window with OK. 
 

Defining the drivers and key points 

 Define the l parameter as a driver. 

 On layer 4, create a coordinate system on 2 axes. 

 Select Through point, and then select Point.  

 Choose the Cartesian point.  

 Select the origin of the absolute coordinate system as the origin point and then enter: 

- Coordinate X: -l/2 
- Coordinate Y: -33.1mm 
- Coordinate Z: 37mm 

 Select Direction: Z-. 

 Next select the Through point option, and then select the previously created point. 

 Select Direction: Y+. 
 

 Define this coordinate system as a key point:  

- Name of key coordinate system: cs1 
- Designation of key coordinate system: Bottom left side point 

 

 Save and close this file. 
  



Creation of a drawer unit  TopSolid’Wood: Creation of drawers 

16   Missler Software 

Creation of a drawer unit 
A drawer unit will be created from a driver block to automatically place a 
repetition of drawers. Their depth will be selected based on the depth of the 
driver block. 
 

Creating the driver block 

 Create a new Design document. 

 Create a driver block by selecting Assembly > Define component > Define 
driver > Driver block. 

 

 On layer 1, create two martyr parts for the sides. 

 Create a parameter without unit: 

- Value: 4 
- Name: n 
- Designation: Number of drawers 

 

 
 

 Create three length parameters: 

- Value: 2, Name: fg, Designation: Front gap 
- Value: 19, Name: th, Designation: Thickness 
- Value: (db.z-(n+1)*fg)/n, Name: fh, Designation: Front height 

 Define the n parameter as a driver. 

 Save this file in the library: 

- Standard: My 3D standard 
- Family: BLUM drawers 
- New type: Drawer units 
- Variant: TANDEMBOX 
- Uncheck Supplier code 

Creating the fronts 

 On layer 2, create a coordinate system on 2 axes: 

- X axis: X+ 
- Y axis: Z+ 

 Make this coordinate system current. 

 In a new sketch, create a rectangular contour. 

 Dimension this rectangle to a distance of fg from the bottom, the 
right and the left of the driver block. 

 Dimension this rectangle to a height of fh. 
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 Extrude this contour: 

- Direction: Z+ 
- Offset from starting curve: (db.y/2)-th 
- Height: th 

 Repeat this part: 

- Propagation: Linear 
- Propagation direction or first point: Y+ 
- Distance per instance: fh+fg 
- Total number : n 

 Define the fronts: 

- Designation: Front 
- Material: wood > particle board 

 
 

Inserting the drawers 

 Make layer 3 current, and then switch off layers 0 and 2. 

 Include the standard BLUM > Complete drawers > TANDEMBOX Antaro M 30 kg. 

 To specify the drawer width, select the document parameter db.x/X length of db in the drop-down list. 
 

 

 Position the Bottom left side point component key point on the inner face 
of the left-hand martyr part. 

 Select the lower face of the martyr part as the first alignment face or edge. 

 Enter Distance = 4mm. 

 Select the front face of the martyr part as the second alignment face or 
edge. 

 Enter Distance = th. 
 

 Select the Repeat option to repeat this drawer.  

 Display layer 2, and then select a drawer front to repeat the drawer just like 
the fronts. 

 Select the Automatic option to create the drawer processes on the fronts. 
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Automatic selection of the drawer depth 

The next step will consist in configuring the drawer to make sure the correct length is automatically selected 
according to the depth of the driver block. 

 Start the Modify element function, and then select a drawer.  

 Click the Template option.  

 Select Assembly > Define component > Define sub-component.  

 Select the template of the drawer repetition. 

 Enter Name: drawer and validate by pressing Enter. 

 Check the Variant box. 

Note: Checking the Variant box allows you to interchange this drawer template with another 
template from your library defined in the same way (key point and tools). 
 

 In the Defined conditions field, type: drawer.d<db.y-20mm. 
 
Note: By using this formula, the sub-component will be selected so that the d parameter (depth of the drawer set 
in the catalog) is always strictly less than the dimension of the driver block on y (bp.y) minus 20mm (safety value). 

 Validate the sub-component with OK, and then click on STOP to not specify any variant driver.  

Note: The default drawer is 270mm deep. It will always be less than the depth of the driver block. Adjustment can 
be made in order to select the greatest possible drawer depth depending on the condition. 

 Open the construction tree, and then edit the 
document assembly. 

 Unfold the drawer repetition, and then right-
click on the template and select Choose first 
code = YES. 

 
 
 
 
 
 
 

 To display the drawer repetition again, select Edit > Repeat > Show 
repetition, and then select the repetition template. 

 Display layer 2, save the file, and then close it. 
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Using the drawer unit 

 Open the provided file Kitchen.top. 

Note: This file contains 600, 500 and 350mm deep cabinets. The same drawer unit component will be used for the 
different depths. 

 Insert the standard component Drawer units > TANDEMBOX.  

 In Multiple inclusion = YES mode, place the component in the 5 available cabinets. 
 

 
 

 Set Number of drawers = 3. 

 Select Automatic to create the runner processes in the cabinets. 
 
The components are then calculated and the runners 
are selected based on the depth of the cabinet in 
which they are inserted. 
 
 
 
 
 
 
 
 
 
 

 
 

 Start the Modify element function, and then select an inserted drawer unit. 

 Click the Sub-component button.  

 Open the node of the Drawer unit component, and then select Drawer TANDEMBOX Antaro 30kg M 
Stainless steel 550. 

 Click the Interchange button.  

The sub-component selection window opens. If other drawer templates were available, it would be possible to 
select another drawer template to modify the drawer unit.  
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